VirtualBox

Ticket #6677 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

Ubuntu 10.04 guest: syntax error on installing guest additions

Reported by: mbvlist Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 3.1.8 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When I run the command 'sudo /media/VBOXADDITIONS_3.1.6_59338/VBoxLinuxAdditions-x86.run' the script stops with 'syntax error: unexpected ")" '. This is probably caused by Ubuntu that links SH to Dash instead of Bash: when I executed the script with 'sudo bash -x' it worked. Easiest fix would be to change the first line to #!/bin/bash, which is the shell your script depends on.

Change History

comment:1 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

No. The correct fix is to start the guest additions with sudo sh /media/VBOXADDITIONS....

comment:2 Changed 3 years ago by frank

At least this works with Ubuntu guests with VBox 3.2.x additions here.

comment:3 Changed 3 years ago by michael

It works here with an Ubuntu 10.04 guest and VBOXADDITIONS_3.1.6_59338. If this is still relevant you might try re-downloading  http://download.virtualbox.org/virtualbox/3.1.6/VBoxGuestAdditions_3.1.6.iso and/or try with a freshly installed 10.04 guest to see if it makes a difference.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use