VirtualBox

Ticket #6668 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

avahi-autoipd doesn't work with bridged adapter

Reported by: albertstrasheim Owned by:
Priority: major Component: network
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Host: Fedora Core 12 64-bit and Vista 32-bit VB version: 3.1.4 on FC12 and 3.2.0beta1 on Vista Guest: Fedora Core 12 64-bit

Network configured with a single bridged adapter. Tried various adapter types.

avahi-autoipd is the standard Zerconf IPv4LL implementation on Linux.

It configures an interface on the machine with an unique IPv4LL IP address according to the Zeroconf spec, which involves sending a bunch of ARPs and other things.

The first time I start the guest, avahi-autoipd gets stuck in its "probing" state and never gets an IP address for the machine. It succeeds very occassionally but mostly gets stuck.

If I restart avahi-autoipd or reset the guest (without killing the VirtualBox process), it binds an IP address without problems.

Additionally, If network adapter is configured as NAT or host-only, avahi-autoipd works without problems.

To reproduce, install FC12 guest, install avahi-autoipd package. Put the following in /etc/event.d/avahi-autoipd.eth0:

start on runlevel [345] stop on runlevel 0 stop on runlevel 1 stop on runlevel 6 console output respawn pre-start exec /sbin/ip addr flush eth0 exec /usr/sbin/avahi-autoipd --debug eth0 post-stop exec /sbin/ip addr flush eth0

And maybe add the line

ip route replace default dev "$2"

to the BIND part in /etc/avahi/avahi-autoipd.action

Restart the VirtualBox process and boot the guest.

Change History

comment:1 Changed 4 years ago by albertstrasheim

start on runlevel [345]
stop on runlevel 0
stop on runlevel 1
stop on runlevel 6
console output
respawn
pre-start exec /sbin/ip addr flush eth0
exec /usr/sbin/avahi-autoipd --debug eth0
post-stop exec /sbin/ip addr flush eth0

comment:2 Changed 4 years ago by albertstrasheim

I have investigated some more with Wireshark.

I set up a filter to watch the VB Ethernet card: eth.src==08:00:27:D5:07:BD

The first time the guest boots up, all avahi-autoipd sends is:

Broadcast ARP Who has 169.254.7.155? Tell 0.0.0.0

After the process is restarted or the guest is rebooted, it sends:

CadmusCo_d5:07:bd Broadcast ARP Who has 169.254.7.155? Tell 0.0.0.0 CadmusCo_d5:07:bd Broadcast ARP Who has 169.254.7.155? Tell 0.0.0.0 CadmusCo_d5:07:bd Broadcast ARP Who has 169.254.7.155? Tell 0.0.0.0 CadmusCo_d5:07:bd Broadcast ARP Gratuitous ARP for 169.254.7.155 (Request) CadmusCo_d5:07:bd Broadcast ARP Gratuitous ARP for 169.254.7.155 (Request)

comment:3 Changed 3 years ago by aleksey

  • Status changed from new to closed
  • Resolution set to worksforme

With VirtualBox 4.0.2 avahi-autoipd works without any issues in Fedora 14 guest. I didn't use /etc/event.d/avahi-autoipd.eth0, I simply selected 'Link-Local Only' method in IPv4 Settings tab of Network Connections. I am resolving this ticket as it looks like guest configuration issue to me. Please reopen it against 4.0.2 if the problem remains.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use