VirtualBox

Ticket #6666 (closed defect: worksforme)

Opened 4 years ago

Last modified 3 years ago

kernel module crash and hangs debian 3.1.8 => don't use binutils-gold

Reported by: kapouer Owned by:
Priority: critical Component: installer
Version: VirtualBox 3.1.8 Keywords: debian
Cc: Guest type: other
Host type: Linux

Description (last modified by frank) (diff)

Using this latest debian package, modprobe vboxdrv gives following output.

Please note i'm running debian/sid with kernel 2.6.33-2-686 #1 SMP, and virtualbox debian package version 3.1.6 did not have this problem.

Also i did obviously run /etc/init.d/vboxdrv setup, which compiles the module without errors.

[   71.748654] BUG: unable to handle kernel paging request at f804ccc3
[   71.748664] IP: [<c11355bf>] vsnprintf+0x2ca/0x2fa
[   71.748678] *pde = 3660e067 *pte = 00000000 
[   71.748685] Oops: 0000 [#1] SMP 
[   71.748691] last sysfs file: /sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0A:00/power_supply/BAT0/voltage_now
[   71.748697] Modules linked in: vboxdrv(+) sco bridge stp bnep rfcomm l2cap bluetooth cpufreq_conservative
  cpufreq_powersave cpufreq_stats cpufreq_userspace binfmt_misc deflate zlib_deflate ctr twofish twofish_common
  camellia serpent blowfish cast5 des_generic cbc aes_i586 aes_generic xcbc rmd160 sha512_generic sha256_generic
  sha1_generic hmac crypto_null af_key microcode fuse xt_recent nf_conntrack_ipv4 nf_defrag_ipv4 xt_state
  nf_conntrack xt_tcpudp iptable_filter ip_tables x_tables coretemp firewire_sbp2 acpi_cpufreq loop
  snd_hda_codec_si3054 snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep arc4 snd_pcm_oss snd_mixer_oss
  ecb snd_pcm snd_seq_midi iwl3945 snd_rawmidi pcmcia snd_seq_midi_event iwlcore snd_seq mac80211 yenta_socket
  snd_timer rng_core rsrc_nonstatic snd_seq_device cfg80211 pcmcia_core snd tpm_tis rfkill i2c_i801 soundcore
  snd_page_alloc tifm_7xx1 tifm_core psmouse pcspkr evdev tpm ac processor battery tpm_bios serio_raw ext4 mbcache
  jbd2 crc16 usbhid hid sg sr_mod sd_mod cdrom i915 drm_kms_helper crc_t10dif drm i2c_algo_bit firewire_ohci
  firewire_core i2c_core thermal sdhci_pci sdhci intel_agp mmc_core r8169 ata_generic led_class crc_itu_t video mii
  output uhci_hcd thermal_sys agpgart ata_piix libata ehci_hcd scsi_mod usbcore nls_base button [last unloaded:
  scsi_wait_scan]
[   71.748887] 
[   71.748893] Pid: 2438, comm: modprobe Not tainted 2.6.33-2-686 #1 M5x0N/M5x0N
[   71.748899] EIP: 0060:[<c11355bf>] EFLAGS: 00010082 CPU: 0
[   71.748906] EIP is at vsnprintf+0x2ca/0x2fa
[   71.748911] EAX: 00000000 EBX: f804ccc3 ECX: f18efed8 EDX: c1438e68
[   71.748916] ESI: f18eff8c EDI: f18efef0 EBP: c1439268 ESP: f18efea4
[   71.748921]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[   71.748927] Process modprobe (pid: 2438, ti=f18ee000 task=f1905dc0 task.ti=f18ee000)
[   71.748931] Stack:
[   71.748933]  c1438e68 f18efed8 00000000 c109b0b0 b7663000 f18d9268 f6fed180 00000000
[   71.748945] <0> c2464920 09b00eb0 00000400 c1438e68 f7cf3000 00000000 00000000 00000000
[   71.748957] <0> 00000000 00000000 00000000 00000400 f18eff8c c1438e68 f804ccc3 c113565f
[   71.748969] Call Trace:
[   71.748979]  [<c109b0b0>] ? __do_fault+0x381/0x3b1
[   71.749010]  [<c113565f>] ? vscnprintf+0xc/0x19
[   71.749019]  [<c10312be>] ? vprintk+0x145/0x32f
[   71.749046]  [<c1260669>] ? mutex_lock+0xb/0x24
[   71.749055]  [<c107f031>] ? trace_module_notify+0x286/0x290
[   71.749064]  [<c10739a5>] ? tracepoint_module_notify+0x1d/0x20
[   71.749072]  [<c1048f8e>] ? notifier_call_chain+0x2a/0x47
[   71.749107]  [<f7d23000>] ? VBoxDrvLinuxInit+0x0/0x148 [vboxdrv]
[   71.749114]  [<c125f513>] ? printk+0xe/0x13
[   71.749161]  [<f7d23033>] ? VBoxDrvLinuxInit+0x33/0x148 [vboxdrv]
[   71.749183]  [<c100113e>] ? do_one_initcall+0x55/0x155
[   71.749191]  [<c1058ee9>] ? sys_init_module+0xa7/0x1d7
[   71.749198]  [<c1002f9f>] ? sysenter_do_call+0x12/0x28
[   71.749202] Code: 4c 24 60 83 ec 18 b9 06 00 00 00 8b 74 24 1c 89 e7 f3 a5 52 89 ea 50 8b 44 24 20 e8 2c e3 ff ff
89 44 24 20 83 c4 20 8b 5c 24 30 <80> 3b 00 0f 85 a4 fd ff ff 83 7c 24 28 00 74 11 39 2c 24 73 08 
[   71.749267] EIP: [<c11355bf>] vsnprintf+0x2ca/0x2fa SS:ESP 0068:f18efea4
[   71.749276] CR2: 00000000f804ccc3
[   71.749282] ---[ end trace 19827c632663a728 ]---

Change History

comment:1 Changed 4 years ago by kapouer

sorry, i should have added this in first place :

  • rmmod -f vboxdrv says "module is busy"
  • /dev/vboxdrv is not created

comment:2 Changed 4 years ago by frank

Please reboot your host and recompile the kernel modules again.

comment:3 Changed 4 years ago by kapouer

i removed vboxdrv init script from init sequence and rebooted.
vboxdrv module (expectedly) is not loaded.
/etc/init.d/vboxdrv setup
recompiles the modules and when done states that /dev/vboxdrv device is not created.
modprobing gives the above log.

comment:4 Changed 4 years ago by frank

  • Description modified (diff)

Please could you double check that the 3.1.6 modules load fine on your box? We cannot reproduce this issue here and AFAICS there were no changes in the host kernel modules between 3.1.6 and 3.1.8

comment:5 Changed 4 years ago by kapouer

thanks for your quick replies, by the way where could i find previous 3.1.6 debian package ?
i did not keep it when i updated. I am sure it worked (since i've been using it), however i'm
willing to check if a reinstallation of 3.1.6 triggers the same bug now.

comment:6 Changed 4 years ago by frank

  • Description modified (diff)

comment:7 Changed 4 years ago by frank

Please download the old package from  http://download.virtualbox.org/virtualbox/3.1.6

comment:8 Changed 4 years ago by kapouer

I had the gold linker installed : going back to the standard one fixed the issue.

comment:9 Changed 4 years ago by frank

  • Summary changed from kernel module crash and hangs debian 3.1.8-6134 to kernel module crash and hangs debian 3.1.8 => don't use binutils-gold

comment:10 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use