VirtualBox

Ticket #6649 (closed defect: fixed)

Opened 4 years ago

Last modified 7 weeks ago

Windows crash dump won't work properly with additions installed => Fixed in SVN

Reported by: bifferos Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.1.2 Keywords: display driver
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Guest: Windows XP, SP2. Host: Slackware 13.0 (also reproduced on Windows 7 host) Reproduced with these versions: v3.1.4, v3.1.6

Steps to reproduce: My computer -> Properties -> Advanced -> Startup and recovery. Ensure memory dump is on.

Set the following registry entry (assumes PS/2 keyboard):

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters]
"CrashOnCtrlScroll"=dword:00000001

(Don't forget to reboot) This will allow you to 'blue screen' on demand.

Hold down right ctrl and press 'scroll lock' twice, to get crash dump.

Without additions installed, Windows writes a memory dump as expected.

With additions installed, the guest locks up, consumes 100% cpu and no memory dump appears. Sometimes (but not always) the machine recovers and reboots, but in either case no dump is written.

Attachments

winxp.png Download (79.6 KB) - added by mhanor 8 weeks ago.

Change History

comment:1 Changed 4 years ago by bifferos

This may have something to do with the mode switch back to text mode for the blue screen. I suspect it's due to the additions graphics driver incorrectly dealing with that scenario.

I've just recalled (although it didn't occur to me before) that on shutdown I often get the guest freezing and I'm forced to power off the VM. It could be a related issue.

comment:2 Changed 4 years ago by mhanor

I have tested Windows XP SP3 as guest OS with GA installed and Notmyfault app to generate a BSOD inside it
 http://download.sysinternals.com/Files/Notmyfault.zip

The VM hangs with some screen corruption.
If I attempt to close the VM window, the Close Virtual Machine window appears, while the content of the VM window changes in the background, displaying part of the actual BSOD screen image. By canceling the Close window, the whole BSOD screen becomes visible.

comment:3 Changed 4 years ago by ties

I ran into the same problem, invoking the 'kill VM' window results in the BSOD.

Uninstalling the GA-tools results in a working BSOD out-of-the-box.

comment:4 Changed 4 years ago by mhanor

it's same thing with 3.2.4

comment:5 Changed 3 years ago by bifferos

Bump. Still seems to be an issue in V4.0. (v4.0.4 tested). It's a real nuisance, can someone look into it?

comment:6 Changed 3 years ago by sunlover

  • Version changed from VirtualBox 3.1.6 to VirtualBox 4.1.2

We are aware of this problem. It is caused by VBox graphics driver. We will see what can be done to fix it, but it is not the highest priority here.

comment:7 Changed 3 years ago by bifferos

I guess you don't have too many users developing windows drivers, so I can understand it's not a priority. The problem for me is that there is no work-around. Not using the VBox driver is not really an option as it makes using the virtual machines difficult. My machine may exhibit a problem perhaps once in a month, and I need to get the crash dump when the machine is in exactly that state to track down the problem. I can't go back in time and disable the display drivers once a fault has occurred. I will really appreciate if you can fix it, or even provide some kind of work-around, like "Run program X before taking the crash dump". Anything will be better than nothing! Thanks.

comment:8 Changed 3 years ago by sunlover

There is a new additions ISO with a partial fix for the problem:

 VBoxGuestAdditions-r73849.iso

The guest is able to write the crash dump but to see the BSOD screen you'll have to Pause and Resume the VM. I hope this is better than nothing :)

comment:9 Changed 3 years ago by bifferos

@sunlover - Of course it's better than nothing :-D. Tested on Win XP and working nicely. I haven't analysed the crash dump but it looks the right size.

Thank you very much for taking the time to fix this, you probably have many demands on your time!

comment:10 Changed 2 months ago by frank

  • Description modified (diff)
  • Summary changed from Windows crash dump won't work properly with additions installed to Windows crash dump won't work properly with additions installed => Fixed in SVN

We think that we finally found and fixed the problem. The fix will be part of the next 4.3.x maintenance release.

comment:11 Changed 8 weeks ago by frank

Could you test  VBox 4.3.8 RC1?

comment:12 Changed 8 weeks ago by mhanor

I've tested it. Host Windows 7 64 bit, guest Windows XP SP3. The crash files seem OK, the BSOD screen looks fine, but the screenshot is not OK. See the attached file

Changed 8 weeks ago by mhanor

comment:13 Changed 7 weeks ago by frank

mhanor, you mean a normal screenshot (not related to any BSOD) has the wrong aspect ratio?

comment:14 Changed 7 weeks ago by frank

Actually it looks like we found and fixed this problem as well.

comment:15 Changed 7 weeks ago by sunlover

mhanor, thanks for feedback. Right, screenshot was not taken correctly in this case.

Here is a new build with a fix:

https://www.virtualbox.org/download/testcase/VirtualBox-4.3.8_RC1-92408-Win.exe

comment:16 Changed 7 weeks ago by mhanor

Everything looks fine now, including the screenshot.

comment:17 Changed 7 weeks ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use