VirtualBox

Ticket #6604 (new defect)

Opened 4 years ago

Last modified 4 years ago

3D functionality

Reported by: Nillem Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

I tried to use OGRE ( http://www.ogre3d.org/) in VirtualBox since you claim to support 3d features and I wanted to try out this combination for a research demonstrator project. I received the following exception:

OGRE EXCEPTION(3:RenderingAPIException): No GLX FBConfig support on your display in GLXGLSupport::GLXGLSupport at /home/student/ogre/RenderSystems/GL/src/GLX/OgreGLXGLSupport.cpp (line 787)

This bug occurred when I tried the SampleBrowser which is part of the Ogre distribution:

$ ./SampleBrowser Creating resource group General Creating resource group Internal Creating resource group Autodetect SceneManagerFactory for type 'DefaultSceneManager' registered. Registering ResourceManager for type Material Registering ResourceManager for type Mesh Registering ResourceManager for type Skeleton MovableObjectFactory for type 'ParticleSystem' registered. OverlayElementFactory for type Panel registered. OverlayElementFactory for type BorderPanel registered. OverlayElementFactory for type TextArea registered. Registering ResourceManager for type Font ArchiveFactory for archive type FileSystem registered. ArchiveFactory for archive type Zip registered. DDS codec registering FreeImage version: 3.10.0 This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See  http://freeimage.sourceforge.net for details Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,exr,j2k,j2c,jp2 Registering ResourceManager for type HighLevelGpuProgram Registering ResourceManager for type Compositor MovableObjectFactory for type 'Entity' registered. MovableObjectFactory for type 'Light' registered. MovableObjectFactory for type 'BillboardSet' registered. MovableObjectFactory for type 'ManualObject' registered. MovableObjectFactory for type 'BillboardChain' registered. MovableObjectFactory for type 'RibbonTrail' registered. Loading library /home/student/ogre/build/lib/RenderSystem_GL Installing plugin: GL RenderSystem OpenGL Rendering Subsystem created. < Here exception occurs >

Although I am unsure of that you can interpret this, my question is if a) this is a bug? b) if it is not a bug, then do you plan to support this "GLX FBConfig" in the future?

Essentially, I want to use Gazebo (a robot environment 3D simulator based on OGRE) in a dynamic deployment profile of the demonstrator we are constructing. The potential performance penalty of using it on top of VirtualBox may be prohibitive, but I am currently investigating possibilities.

I attache the vbox.log

Attachments

VBox.log Download (64.5 KB) - added by Nillem 4 years ago.
VBox-20100429.log Download (81.3 KB) - added by Nillem 4 years ago.

Change History

Changed 4 years ago by Nillem

comment:1 Changed 4 years ago by Technologov

VBox Log says:

832 00:00:24.519 VM: Raising runtime error '3DSupportIncompatibleAdditions' (fFlags=0x4)

833 00:00:24.519 Console: VM runtime error: fatal=false, errorID=3DSupportIncompatibleAdditions message="An attempt by the virtual machine to use hardware 3D acceleration failed. The version of the Guest Additions installed in the virtual machine does not match the version of VirtualBox on the host. Please install appropriate Guest Additions to fix this issue"

Please reinstall GuestAdditions.

-Technologov

Changed 4 years ago by Nillem

comment:2 Changed 4 years ago by Nillem

Released and remove the guest addition .iso file. Downloaded new copy via virtualbox menu choice (Device/Install Guest Additions)

Re-ran the guest installation script. Worked fine, no errors.

Restarted the virtual machine and attempted to execute the SampleBrowser. Result: same exception. Shutdown the virtual machine and made a copy of VBox.log. Note, the new log file (VBox-20100429.log, a renamed copy of VBox.log) does not seem to contain the error mentioned by Technologov any longer.

comment:3 Changed 4 years ago by Nillem

BTW, I can probably put up a copy of the exported machine on the web so you can try it out for yourselves if it will help you.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use