VirtualBox

Ticket #6556 (closed defect: obsolete)

Opened 4 years ago

Last modified 5 months ago

Ubuntu 9.10 Host/Windows Server 2008 guest - guest intermittent hang

Reported by: LinxPatrick Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.6 Keywords: Windows Server 2008 hang crash service
Cc: Guest type: Windows
Host type: Linux

Description (last modified by frank) (diff)

Host is: Ubuntu 9.10 64-bit Server Kernel = 2.6.33 but older kernels had the same issue Processor = Intel Xeon E5506 times 2 Memory = 23.6GB

Guest1 is: Windows Server 2008 Standard 64-bit SP2 Memory = 6GB but I've gone as low as 2GB Processor Cores = 3 with VT-x enabled but the number of cores don't seem to matter Video Memory = 128GB with 2D and 3D Acceleration enabled

Guest2 is: Windows Small Business Server 2008 64-bit SP2 Memory = 8GB Processor Cores = 3 with VT-x enabled but the number of cores don't seem to matter Video Memory = 128GB with 2D and 3D Acceleration enabled

The problem is that either guest will intermittently hang. Guest1 is more prone to hanging than Guest2. Guest2 has only hung-up a couple times since January of 2010. Guest1 may hang while booting or it could run for a week or more. It will typically hang-up every two or three days. Sometimes after rebooting the host the issue gets considerably worse or considerably better but there is no way I know of to reproduce one or the other.

The work-around that I've come up with is to stop the VirtualBox Guest Additions Service after booting the guest and logging in. I have not tried setting the service to disabled or to start manually.

I have a 10-year old Pentium-4 (32-bit) server with 2 processors with Ubuntu 9.10 as the host OS and one Windows XP (32-bit) guest. That machine has not experienced this issue.

Change History

comment:1 Changed 4 years ago by LinxPatrick

This is an update by the originall poster. I have determined that the problem is not the VirtualBox Guest Additions, unless the gues additions are using the hard drives extensively. I have found that the hard drives fail under heavy load. To reproduce the symption, run a defrag. To see the symptom occur, run defrag on both machines on the same host at the same time.

The work-around that I came up with is to not run any scheduled defrag operations. My concern is that backing up the system puts the hard drives under a similar load and so I expect the hard drives to fail, just not as often.

Patrick

comment:2 Changed 4 years ago by LinxPatrick

This is yet another update by the original poster.

I would really like to see VirtualBox succeed. I like some of the features in VirtualBox better than other products. Plus, if the product worked, the price is right.

That being said, I had to switch to VMWare Workstation for this application and I can now see some other issues with other VirtualBox installations that are not show stoppers but are annoying and need to be fixed ASAP.

Staying with the issues that I posted this thread about I have some additional information.

1) The host uses Intel Xeon E5506 processors. Two of them. 2) There is 24GB of memory in two banks of 12GB 3) The host uses Ubuntu Linux software RAID. 4) I was also able to see the problem by attempting to run software that zeros out the free space in preparation for shrinking the VDI or VMDK file. 5) This case has not been assigned to anyone yet. This is not the way to keep customers. It would at least be nice to know that someone has looked at the issue.

Patrick

comment:3 Changed 4 years ago by sandervl73

No need to describe your setup in so much detail. Just add the VM's VBox.log. That will actually show us much more. I suspect this is a duplicate of the nested paging regression introduced in 3.2.0 (which is already fixed), but can't say for sure without the log file.

comment:4 Changed 4 years ago by LinxPatrick

I no longer have a log file to provide. This couldn't have been introduced in 3.2 since it has been going on since I initially installed VirtualBox on the machine in December of 2009. I reported the issue as being a 3.1.6 issue because that is the version I was using when I started this thread but it affected earlier versions, as well. All versions tested have been 3.x.

Patrick

comment:5 Changed 4 years ago by LinxPatrick

This update is by the original poster. In the original post I referenced a 32 bit machine that was set up similarly to the 64 bit machine but that was not having the same issues. Last Friday I added a second VM to that machine and what do you know? Immediately the virtual hard drives began having corruption errors. Both VMs were affected.

I changed from Linux to Windows XP 32 bit for the host machine and used fake RAID for the RAID sets. Once I got the VMs restored the problems seemed to go away but I did have troubles restoring the VMs from the backup drive to the host drives.

I have done limited testing because I also determined that the age (performance) of the host machine is not going to work well for what I am trying to accomplish.

The important things to note here is that the problem is not specific to 32 or 64 bit OSs and that there is a vast difference in age and power between the two host machines that I am using.

Patrick

comment:6 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use