VirtualBox

Ticket #6506 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Appliance export is horribly slow

Reported by: mickler Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

Dear developers,

I am using Debian Lenny 64-bit host system. I created and installed a Scientific Linux 64-bit guest with dynamic sized hard disk (20 GB max). Now I want to export it using the File->Export Appliance... Wizard. The write speed varies between 500k and 1.5MB per second while reads are occuring intermittently at ~10MB/s (numbers taken from iotop). The progress meter tells me that the remaining time is something about 4 hours.

I think this is a serious performance flaw in VirtualBox... I see roughly the same disk speed if I do dd if=/dev/zero of=somfile bs=1, i.e. writing 1 byte at a time to a file on disk. When using a tmpfs as target for the export, it is reasonably fast - but I don't have enough RAM to use this a a work-around ;-)

If this is of interest - my file systems are XFS and the virtual machine files are under /home/ and export is done to /opt/:

/dev/sda6 on / type xfs (rw,relatime,logbufs=8,logbsize=256k) /dev/sda7 on /home type xfs (rw,relatime,logbufs=8,logbsize=256k)

Thanks in advance for your help.

Cheers, Holger

Change History

comment:1 Changed 4 years ago by drescherjm@…

I have the same problem with this under 64 bit gentoo. I have a 100+ GB appliance and at the rate it is going it may be done in a week..

BTW, I am also using xfs as the destination.

comment:2 Changed 4 years ago by drescherjm@…

I switched the destination to ext4 and these options

rw,extents,commit=120,barrier=0,data=writeback

and writes are over 10MB/s instead of 1.5 MB/s max.

comment:3 Changed 4 years ago by frank

What did you use before, ext3? Which mount options?

comment:4 Changed 4 years ago by drescherjm@…

Before xfs with default mount options on the destination.

rw,noatime,nobarrier

The source is on a completly different drive.

comment:5 Changed 4 years ago by jms19

A bit of extra information. I have also posted in issue #3719 that this is possibly a duplicate of.

I've got myself a shiny Macbook Pro and quickly found that exporting is waaaay quicker than my XP Pro E8500 3.1GHz machine I mentioned in #3719.

Also the progress bar seems better correlated with time and no sitting at 100% done for ages like the windows box, which incidentally is defragged on both source and destination drives.

comment:6 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use