VirtualBox

Ticket #648 (closed defect: worksforme)

Opened 7 years ago

Last modified 6 years ago

Vista host and Xp guest, shared folder inacessible from host

Reported by: tulving Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.0 Keywords: shared folder
Cc: Guest type: other
Host type: other

Description

I installed VirtualBox 1.5 on my Windows Vista pc, where I have a folder UNIFORM in my Documents folder,

I add a new virtual machine, with Windows XP. I set as share folder that folder: Users\<myUser>\Documents\UNIFORM.

The problem is than now, if I am on the Vista host, if I go to Documents folder I can't reach the folder UNIFORM, I see it not as a normal folder but as a link to a net folder, and that messagge if I try to reach it: \VBOXSVR\UNIFORM is not accessible

I've tried to dismount as share folder, but still same situation.

Attachments

VistaDocuments.png Download (183.4 KB) - added by tulving 7 years ago.
Documents folder with 'Uniform' subfolder as a link to a net folder
VistaDocuments2.png Download (207.8 KB) - added by tulving 7 years ago.
erroe message when I try to access the folder
VirtualBox.xml Download (1.3 KB) - added by tulving 7 years ago.
Windows XP.xml Download (2.6 KB) - added by tulving 7 years ago.

Change History

Changed 7 years ago by tulving

Documents folder with 'Uniform' subfolder as a link to a net folder

Changed 7 years ago by tulving

erroe message when I try to access the folder

Changed 7 years ago by tulving

Changed 7 years ago by tulving

comment:1 Changed 7 years ago by sandervl73

Can you access the shared folder directly? (using the vboxsvr entry in the network list of windows explorer or using net use x: \vboxsvr\uniform)

comment:2 Changed 7 years ago by tulving

No, if I tried to search for a vboxsvr net on the Vista host networks, there's no entry or matching doing a serch for the folder \vboxsvr\uniform.

I've also tried to run the command net use x: \vboxsvr\uniform: no error message, but same situation.

The folder Documents\Uniform is now not accessible from the Vista host. I've also tried to set it again as shared folder, to see in it is accessible from the Xp guest virtual machine, but I can't, because is seen as a net foder. In fact, the VirtualBox error message is:

Shared folder host path '\VBOXSVR\Uniform' is not accessible.

Codice&nbspd'uscita: E_FAIL (0x80004005) Componente: Machine Interfaccia: IMachine {31f7169f-14da-4c55-8cb6-a3665186e35e}

comment:3 Changed 7 years ago by sandervl73

Others have reported that uninstalling the additions, rebooting, installing the 1.5.0 additions and rebooting again fixed their problems.

Could you check which additions are installed? (hover the mouse over the VBox icon in the taskbar)

comment:4 Changed 7 years ago by tulving

Yes, I'tried twice, but nothing changed. The addition are the last version, 1.5.0.

In other hand, I've used a workaround: I created a new folder on my Vista Documents host folder. Using shell prompt command, the "not accessible" folder was visible, so I've moved all files and its subfolders via shell command to the new one folder.

After this step, I erased the old folder, using Vista Windows Explorer (where the folder was seen as a link file and not as a real folder), and changed the new one name folder with the same of the old erased.

Now, to avoid to be another time not able to reach an important folder on my host, I created a new folder dedicated only for sharing data with the virtual machine.

Thanks

comment:5 Changed 6 years ago by wtfbrb

Same issue but with vista host and 2003 server as guest, I dig the work around, but it doesn't work for IIS so I still need to copy files to testing server all the time!!! arg. Doesn't happen with ubuntu guest fyi.

comment:6 Changed 6 years ago by wtfbrb

Sorry I guess I don't have the same exact problem...my folder was not viewed as a link, just not writable and I thought you meant I could link the folder I want to share and share the folder containing the link....not true so I am still stuck without a testing server.

comment:7 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to worksforme

Your original reports makes no sense whatsoever. If you assign a directory as a shared folder, then your host will not be affected in any way. If you can't access it in your guest, then it's another story, but a duplicate of other defects.

Try again with 1.6.2 when it's out please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use