VirtualBox

Ticket #6476 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Multicast packets cannot reach Windows host and Linux guest

Reported by: gowa Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.1.6 Keywords: multicast IGMP
Cc: Guest type: Linux
Host type: Windows

Description

Under some circumstances neither Windows (host system) nor Gentoo linux (guest system) receive multicast packets (e.g. IGMP join).

I have a Windows machine (A) that connects to the WAN through the other Windows machine (B) which has VirtualBox with Gentoo installed on it. Gentoo acts as a router. It uses VirtualBox' bridging (e1000) for two real ethernet interfaces: one for WAN, one for LAN.

Machine (A) starts VideoLAN Client to get IP-TV. VideoLAN sends IGMP packet to multicast address (it could be sniffed by Wireshark on this machine (A)). But this packet does not reach Machine B (router). Wireshark on Windows (B) and tcpdump on Gentoo (VirtualBox) show that there are no IGMP packets at all.

To fix this I do one very simple action: I stop my VirtualBox and start it again. This thing helps endeed - everything works fine after that.

So, at least a kind of instable behaviour take place here. Do not know - VirtualBox problem or Windows one...?

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #6353.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use