VirtualBox

Ticket #6421 (closed defect: invalid)

Opened 4 years ago

Last modified 10 months ago

COM Ports above 9 are not supported

Reported by: jmahmens Owned by:
Priority: minor Component: uart
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

Using a Virtual COM Port on Windows XP Host by COM2USB Adapter which creates a COM10 Port. This COM10 is not usable as Hostport. Using an other USB Port which creates a COM9 is usable.

The following Message is created:
Failed to open host device 'COM10'
(VERR_FILE_NOT_FOUND).
Details:
Fehlercode: E_FAIL (0x80004005)
Komponente: Console
Interface: IConsole {6375231a-c17c-464b-92cb-ae9e128d71c3}

ps: No Copy possible in Errorbox. Avialable yes, but no Content.

Attachments

Hamn007 als VM-2010-03-25-10-56-18.log Download (34.5 KB) - added by jmahmens 4 years ago.
Vbox.log

Change History

Changed 4 years ago by jmahmens

Vbox.log

comment:1 follow-up: ↓ 2 Changed 4 years ago by Technologov

Rare configuration :)

Added myself to this bug.

-Technologov

comment:2 in reply to: ↑ 1 Changed 4 years ago by jmahmens

Replying to Technologov:

Rare configuration :)

Added myself to this bug.

-Technologov

I think not, My Host is an Notebook with Dockinstation an I'm using a Com2USB adapter. My Notebook has 4 USB Ports and dhe Dockingstation has 6. So that more then 10 for a COM Port is more than possible. Have a nice day with this ;) JPM

comment:3 Changed 10 months ago by Garbz

This is not a bug and can be closed. Windows provides legacy names only for COM ports 1 through to 9.

For all other COM ports you must use the full device naming convention under windows. i.e.:

\\.\COM10

comment:4 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to invalid
  • Description modified (diff)

Thanks for the information!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use