VirtualBox

Ticket #6384 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Virtualbox OSE 3.1.4 runs in circles when guest Linux tries to attach to IPv6 socket before initialization completes

Reported by: Zugschlus Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hi,

this is an annoying issue of virtualbox 3.1.4 OSE when starting a guest Linux (Debian lenny and Debian sid) running any kernel later than 2.6.32, including 2.6.33. My host OS is Debian sid as well. I am not using the distribution kernels but am building from vanilla sources myself. The last guest kernel that doesn't show this issue is kernel 2.6.31.6.

When the ipv6 module is started, it takes a few seconds (much longer than on real hardware) until ipv6 autonegotiation begins. If any application tries to create an IPv6 socket before this autonegotiation, the virtualbox process begins to run around in circles, taking one available CPU, until the guest is aborted manually.

I may think that this is a kernel bug (which is reported to the LKML as  http://marc.info/?l=linux-kernel&m=126313553029280&w=4 and  http://bugzilla.kernel.org/show_bug.cgi?id=15042), but as I am only seeing this on virtual hosts, this may also be an issue of virtualbox not being able to cope with some new way of the Linux 2.6.32 kernel to do things.

Has anybody seen this behavior from virtualbox recently? What can I do to fix this?

I would also be interested in obtaining a sysrq-t dump of the running guest system, or some other way to get a memory image from the virtualbox system that I could feed to crash(8). If somebody could tell me how to do this with virtualbox, I might be able to further pursue this with the kernel people.

Any hints will be appreciated.

Vbox.log attached. All log entries in the first minute of the log are from the machine coming up, the entries from minute 02 are the system aborting.

Greetings Marc

Attachments

VBox.log Download (50.4 KB) - added by Zugschlus 4 years ago.
Vbox lof of a hanging machine (including abort sequence starting minute 02)

Change History

Changed 4 years ago by Zugschlus

Vbox lof of a hanging machine (including abort sequence starting minute 02)

comment:1 Changed 4 years ago by frank

  • Component changed from other to network/hostif

comment:2 Changed 4 years ago by frank

Is there an easy way to reproduce this problem? Is it sufficient to load the ipv6 module on the guest and on the host or is there an IPv6 setup required?

comment:3 Changed 4 years ago by Zugschlus

The virtual machine in question is on a host-only network, and the host doesn't respond to IPv6 router solicitations. It does, however, have an fe80 prefix address autoconfigured and the virtual machine does the same.

I'd say, it is sufficient that both host and guest are IPv6 enabled.

Greetings Marfc

comment:4 Changed 4 years ago by Zugschlus

On the vbox-users-community mailing list, Michal Seben suggested that this issue might been related to  http://vbox.innotek.de/pipermail/vbox-dev/2010-April/002503.html.

I updated my virtualbox OSE 3.1.4 to 3.1.6 and applied Sander's patch from  http://www.virtualbox.org/changeset/28090 and have not seen the issue again. Since it was an issue that didn't happen on every system boot, this might be good news, but does not necessarily need to be.

I'll report back if the issue surfaces again.

Greetings Marc

comment:5 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Ok, I'll close this one then. Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use