VirtualBox

Ticket #6305 (closed defect: obsolete)

Opened 4 years ago

Last modified 3 months ago

VBoxTestOGL.exe crash on Windows 7 with ATI graphic drivers.

Reported by: Shinkan Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.4 Keywords: ati, windows 7, OGL
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

I just set up my graphics drivers (ATI) update from my laptop manufacturer Website.

When I tried to launch VirtualBox, a Windows 7 failure popup said that "VBoxTestOGL.exe" crashed. I tried to uninstall/re-install VirtualBox (3.1.4), install official ATI drivers instead of laptop manufacturer provided, and got the same error. VirtualBox still seems to work after, but VBoxTestOGL.exe crash occurs on some GUI tabs.

Windows 7 gives "atio6axx.dll_unload" name in crash report details, so I thing it's about conflict between ATI graphics drivers and how VirtualBox tests OpenGL.

More details :
VirtualBox : version 3.1.4
Windows : version 7 64bits Business
ATI Drivers : version 8.632.1.2000, DDI version 10.1, WHQL signed

Attachments

error.txt Download (613 bytes) - added by qffc 4 years ago.
Crash report
error.xml Download (2.1 KB) - added by thomas_s 3 years ago.
Part of error report (lenovo laptop)
errorlog.txt Download (614 bytes) - added by unknown_one 3 years ago.
errorlog of crash

Change History

comment:1 Changed 4 years ago by Shinkan

Note : this bug might be related to #6247, because it talks about VBoxTestOGL.exe and ATI drivers.

comment:2 Changed 4 years ago by Shinkan

Still true with VirtualBox 3.2 and Windows 7

comment:3 Changed 4 years ago by qffc

Confirmed here as well!

Crash report:

Problem signature:

Problem Event Name: BEX64 Application Name: VBoxTestOGL.exe Application Version: 0.0.0.0 Application Timestamp: 4be72920 Fault Module Name: atio6axx.dll_unloaded Fault Module Version: 0.0.0.0 Fault Module Timestamp: 4a8a1300 Exception Offset: 0000000069a6c11c Exception Code: c0000005 Exception Data: 0000000000000008 OS Version: 6.1.7600.2.0.0.256.1 Locale ID: 1033 Additional Information 1: ee09 Additional Information 2: ee09b57e6d8ea36036aece147453466b Additional Information 3: 0df6 Additional Information 4: 0df698bb0e9ebdf512478f7fa42751d6

Changed 4 years ago by qffc

Crash report

comment:4 Changed 4 years ago by qffc

This error also appears when you enter "Settings" for a virtual machine.

Under "Display" the Enable 3D/2D Video Acceleration check boxes are disabled (grayed out).

comment:5 Changed 4 years ago by Shinkan

For me, this has been solved by using AMD/ATI Catalyst 10.4 drivers. No more errors, and 3D accel works fine.

comment:6 Changed 4 years ago by qffc

Those drivers are not installable on this machine (Toshiba A200) because of some stupid reason, Toshiba want to distribute the drivers themselves. The problem is that Toshiba does only provide drivers older than my grandmother.

But since I really want this feature to work, I tried installing 10-4 using ATI Mobility Modder .NET and it still gave the same error. I also tried installing 10-5 using the same method and still the same error.

Also, other OpenGL applications run fine using any of the mentioned drivers here.

Catalyst Control Center now reports Driver Packaging Version: 8.632.1.2-090817a-086997C-ATI

I guess if the drivers are faulty, there is no way to get VirtualBox to run here...

comment:7 Changed 4 years ago by leonid

This problem might be fixed in 3.2.2, please retry when it's out.

comment:8 Changed 4 years ago by qffc

I've just tried 3.2.2 and it does not seem to be fixed. I get the same error as before.

comment:9 follow-up: ↓ 10 Changed 4 years ago by dirkp

I've just tried 3.2.4 and it does not seem to be fixed. I get the same error as before.

I use Virtualbox and Win7 as 64bit version

comment:10 in reply to: ↑ 9 Changed 4 years ago by qffc

Replying to dirkp:

I've just tried 3.2.4 and it does not seem to be fixed. I get the same error as before.

I use Virtualbox and Win7 as 64bit version

Yes, I also use Win7 64bit version. This is stated in the bug description.

comment:11 Changed 4 years ago by hbchai

I just encountered this issue as well - using 3.2.6, on 32-bit Windows XP, ATI FireGL V3100.

comment:12 Changed 4 years ago by john.doe

I've encountered this in 3.2.8 so it is not fixed yet.

comment:13 Changed 4 years ago by frank

  • Component changed from other to 3D support

comment:14 Changed 3 years ago by zahneny

I found this issue resolved in the latest ATI driver update. Following the drivers I have installed for your reference:

Catalyst™ Version: 10.11 Driver Packaging Version: 8.723.8.2-100920a-105610C-Sony

I'm running VirtualBox 3.2.10 on a Windows 7 Home Premium Notebook (it is not related to VirtualBox as I got the same error when I using old ATI driver)

comment:15 Changed 3 years ago by thomas_s

I don't think that this is related to ATI graphic cards - at least not only. I do have an integrated Intel HD graphic card in my lenovo laptop and experience the same error.

Changed 3 years ago by thomas_s

Part of error report (lenovo laptop)

comment:16 Changed 3 years ago by ilyabreev

Got the same error, but with atioglxx.dll_unloaded. Windows 7 x86. VirtualBox 4.0.4. ATI Mobility Radeon HD 3400 Series. Driver v8.632.1.2000.

comment:17 Changed 3 years ago by Cooperdale

Ati 5870HD, Catalyst 11.3, same error. I never had this error until 11.2.

comment:18 follow-up: ↓ 19 Changed 3 years ago by unknown_one

I have updated to Ati Catalyst 11.4 from 10.12 and I get a slightly different error (Windows 7 64 Home edition SP1 ita + VirtualBox 4.0.6 + ATI Mobility Radeon HD 5730):

Firma problema:

Nome evento problema: APPCRASH Nome applicazione: VBoxTestOGL.exe Versione applicazione: 0.0.0.0 Timestamp applicazione: 4db006db Nome modulo con errori: aticfx64.dll Versione modulo con errori: 8.17.10.1059 Timestamp modulo con errori: 4cef2204 Codice eccezione: c0000005 Offset eccezione: 00000000000303e2 Versione SO: 6.1.7601.2.1.0.768.3 ID impostazioni locali: 1040 Informazioni aggiuntive 1: eebd Ulteriori informazioni 2: eebd2ce2c5f6f8251551f41ee7498fac Ulteriori informazioni 3: f639 Ulteriori informazioni 4: f63961366b93a0d86e488f997a56b627

Changed 3 years ago by unknown_one

errorlog of crash

comment:19 in reply to: ↑ 18 Changed 3 years ago by unknown_one

I've solved my problem. My issue was with aticfx64.dll which unexpectedly remained the 10.12 version after the driver update to 11.4, so it was conflicting with the other never dlls. You can check your version by comparing the version module code with those listed here:  http://developer.amd.com/drivers/ccc/pages/default.aspx My solution was to completely delete ATI software and video driver (from both "Device Manager" and "Programs and Features" in control panel) and reinstall the never version. This solved my problem and maybe it can happen with other dlls from Ati package.

Replying to unknown_one:

I have updated to Ati Catalyst 11.4 from 10.12 and I get a slightly different error (Windows 7 64 Home edition SP1 ita + VirtualBox 4.0.6 + ATI Mobility Radeon HD 5730):

comment:20 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use