VirtualBox

Ticket #630 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

Failed to initialize COM or failed to find VirtualBox COM server. (RPC_E_CHANGED_MODE) -> fixed in SVN/1.5.2

Reported by: -NG- Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

When start virtualbox I have a dialog with following Message:

Failed to initialize COM or failed to find VirtualBox COM server. Most likely, the VirtualBox server is not running or failed to start. The application will now terminate. Call RC: RPC_E_CHANGED_MODE (0x80010106)

With 1.4 I don't have this problem , and i uninstalled 1.4 & then install 1.5 got this problem

P.S. my OS T.Chinese XP Pro SP2 w/ lastest update

Change History

comment:1 Changed 7 years ago by sandervl73

  • Priority changed from major to critical
  • Summary changed from version 1.5 , Failed to initialize COM or failed to find VirtualBox COM server. to Failed to initialize COM or failed to find VirtualBox COM server. (RPC_E_CHANGED_MODE)

comment:2 Changed 7 years ago by dmik

Please try the recent SVN tree if possible (revision 4557 and above): the problem should have gone now.

comment:3 follow-ups: ↓ 4 ↓ 5 Changed 7 years ago by sandervl73

I will send you a link to a test build using the email address you registered with here.

comment:4 in reply to: ↑ 3 Changed 7 years ago by dlittier

Replying to sandervl73:

I will send you a link to a test build using the email address you registered with here.

can someone send me the link? ( dlittier@… )

comment:5 in reply to: ↑ 3 Changed 7 years ago by -NG-

Replying to sandervl73:

I will send you a link to a test build using the email address you registered with here.

I installed that test blind , but still got the same problem , so sad :(

comment:6 Changed 7 years ago by vboxlover

Just writing to learn what the latest word is on this one - I'd really like to upgrade to 1.5, but I can't until this is resolved.

Been getting the same problem on XP Tablet edition. Service seems to start. Or at least, there's no debug output and I can see it running as a service. Weird.

comment:7 in reply to: ↑ description Changed 7 years ago by shinji

I am also curious to the current nature of the situation. I downloaded 1.5.0 to evaluate and luckily I have 1.4.0 to fallback on right now but I would like to see this resolved.

OS: English (US) Windows XP Media Center Edition SP2

comment:8 in reply to: ↑ description Changed 7 years ago by twilight

Same prob ( I had installed/tried to start Vbox on Acer5024 laptop (Error code: RPC_E_CHANGED_MODE (0x80010106). If you need to test debug version I can help.

comment:9 Changed 7 years ago by vboxlover

I am wondering if it has something to do with the platform. Mine is also an Acer - running XP Tablet Edition. Coincidence?

comment:10 Changed 7 years ago by aadimiro

I have also the same problem since 1.5.0 under Windows XP SP2 (German). 1.4.0 works fine.

Motherboard: ASUS P5N SLI CPU: Intel Core Duo E6550 2Gb RAM

comment:11 follow-ups: ↓ 12 ↓ 22 Changed 7 years ago by yura2883

Please, Sorry for my english. I have russian WXP Pro. I solved this problem by disabling "Support text services for all programs" in language properties.

comment:12 in reply to: ↑ 11 Changed 7 years ago by dmik

Replying to yura2883:

Please, Sorry for my english. I have russian WXP Pro. I solved this problem by disabling "Support text services for all programs" in language properties.

yura2883, thanks for the advice, but even enabling this setting (i.e. clearing the check box) didn't bring the problem here. Can you constantly reproduce it on your side by doing the same?

comment:13 in reply to: ↑ description Changed 7 years ago by twilight

I had erased my XP Pro and setup Ubuntu on the PC where win32 VBox version crashed. Linux version running well. That's the only one 100% solution of the issue for the present moment :)

comment:14 Changed 7 years ago by dmik

Since the problem is still not reproducible here and I don't have any clue why the fix I've applied didn't help, I need a person who:

  1. has the given problem
  2. can build the debug version of the VBox SVN head on XP
  3. can hang on the #vbox channel ( irc://irc.freenode.net/vbox) for a while answering my questions

My channel nick is dmik, dmik|something etc.

comment:15 Changed 7 years ago by shinji

I think I have figured out where this might be coming from. A possible inability to handle foreign fonts properly. Here is the information that I had from testing. I bit of kicking came from yura2883 on this one...


VirtualBox - Critical Error

Failed to initialize COM or to find the VirtualBox COM server. Most likely, the VirtualBox server is not running or failed to start.

The application will now terminate.

Callee RC: RPC_E_CHANGED_MODE (0x80010106)

Known Workarounds (Both of these will work to get around of this issue): Disable option "programs" in Regional and Language Options control panel applet (Languages Tab -> Details button -> Advanced Tab).

Enable Compatibility option "Turn off advanced text services for this program" for the shortcut or directly on the executable file.


Need to reproduce the issue? Here is what I had set. This was in Windows XP Pro SP2 US English Language.

Checked "Install files for East Asian languages" Enabled option "Extend support of advanced text services to all programs"

comment:16 Changed 7 years ago by lynx

Thanks a lot shinji!

The last solved my problem: "Enable Compatibility option "Turn off advanced text services for this program" for the shortcut or directly on the executable file."

comment:17 Changed 7 years ago by shinji

I would like to add that if you do have this issue then please respond with the following information if you havn't already regardless of if the previously mentioned workaround corrected it or not. This may give some bearing on where the issue is coming from.

Operating System
OS Language
Is support for east asian languages installed?
Is support for complex scripts and right-to-left languages installed?
If you do have either of the above installed then is text services extended to all applications?

comment:18 Changed 7 years ago by vikrant

Yes the same i can reconfirm the issue was resolved on my laptop as well once i turned off the text service extended to all the applications..

The OS - WinXP Professional English OS Language - English Yes - East Asial Language Installed No - Support for complex right-to-left language not installed.

I can reproduce the bug every time i enable the advanced text service extended to all the applications.

comment:19 Changed 7 years ago by lynx

Hi shinji,

Operating System: Windows XP Professional OS Language: English (with German locales and keyboard layout) Is support for east asian languages installed: yes (need it for Cyrillic) Is support for complex scripts and right-to-left languages installed: no If you do have either of the above installed then is text services extended to all applications: yes (need it for other applications, that's why I selected an option to disable this support on VirtualBox.exe specifically, not for all applications)

Hope this helps Thanks

comment:20 Changed 7 years ago by dmik

shinji, thanks for this information. However, even when I turn on all these extended input services and support for Asian languages, I cannot get the described problem here. Probably, some other system component that triggers it isn't installed on my system. So I still need a person who can constantly reproduce the problem and has a wish to assist me in finding the reason (see comment:14). Building the SVN version of VBox is easier than you may think so feel free to contact me.

comment:21 Changed 7 years ago by shinji

Not a problem dmik. Unfortunately I don't actually have the required software to do a full build (I only have VC++ Express Edition). However I am using VirtualBox to do a sandboxed environment that is devoid of 3rd party software in order to see where the root cause may be. First step is see if it is immediately reproducable on a clean install. I will create a snapshot of the environment right after activation so I can go from there. I will be activated right away.

And yes... I have the required licensing to do 2 XP installations. Discussion on this can continue on irc. I just wanted to give you a heads up now.

comment:22 in reply to: ↑ 11 Changed 7 years ago by vboxlover

Replying to yura2883:

Please, Sorry for my english. I have russian WXP Pro. I solved this problem by disabling "Support text services for all programs" in language properties.

Yura2883, Shinji - you're genius! Thank you very much for the quick-and-easy workaround.

All is well in VirtualBoxLand.

comment:23 Changed 7 years ago by shinji

Just so you know I managed to do some scenario testing with 1.5.0 within a VirtualBox VM run (yep. installing VM software in a virtual environment... lol). Here is my results.


Test Scenario 1 -- Clean install XP -- No updates
Result: PASS


Test Scenario 2 -- Install East Asian language support
Result: PASS


Test Scenario 3 -- Extend support for advanced text services to all programs w/ East Asian Support
Result: FAIL


Test Scenario 4 -- Extend support for advanced text services to all programs w/o East Asian Support
Result: FAIL


Please note that beyond the VirtualBox Additions and VirtualBox itself nothing else was installed at all. This was a clean install with no updates at all of any kind as this install had no internet connection and had to be activated manually. This is kinda conclusive as to where the issue is. Now then all that is needed to do is to see what has changed between 1.4.0 and 1.5.0.

comment:24 Changed 7 years ago by dmik

The source of the problem is the conflict between MS system OLE components that are non-threadsafe and require STA, and VBox components that are thread-safe and require MTA.

So far, this was fixed by entering MTA early before OLE is initialized by Qt. VirtualBox now works even if "Extend support for advanced text services to all programs" is turned on for those people who experienced problems before. However, as a result of this fix, some system functions like Drag&Drop to VBox entry fields may not always work any more. A better solution is to be found. Thanks to yura2883 for the initial idea of the workaround. Thanks to shinji for further assistance and testing new builds.

The fix is in SVN, and will appear in the next 1.5.x maintainance release.

comment:25 Changed 7 years ago by dmik

  • Status changed from new to closed
  • Resolution set to fixed

comment:26 Changed 7 years ago by sandervl73

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:27 Changed 7 years ago by sandervl73

  • Summary changed from Failed to initialize COM or failed to find VirtualBox COM server. (RPC_E_CHANGED_MODE) to Failed to initialize COM or failed to find VirtualBox COM server. (RPC_E_CHANGED_MODE) -> fixed in SVN/1.5.2

comment:28 Changed 7 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use