VirtualBox

Ticket #6242 (closed defect: fixed)

Opened 4 years ago

Last modified 4 months ago

VT-x causes massive DPC latency

Reported by: maqr Owned by:
Priority: critical Component: VMM
Version: VirtualBox 3.1.4 Keywords: DPC, VT-x
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

I am running Windows 7 x64 on a q6600 with virtualization enabled in the bios. Whenever my guest (x64 or x86) is under any kind of load (even just booting the Ubuntu installer), I get big DPC latency spikes. This is obviously a problem because it causes choppy audio, video, and generally degrades performance. Once inside the guest OS, this is can be easily reproduced with a simple bash script: while true; do ""; done

I have reproduced this on an i7 920 with the same problem.

Attached is a dpclat screenshot and a dump from xperf. If the ETL would be beneficial in debugging, I could produce one.

The "fix" for me was to install a 32-bit guest and disable VT-x in the vbox options.

Attachments

Untitled.png Download (48.6 KB) - added by maqr 4 years ago.
DPClat screenshot
vbox.txt Download (28.5 KB) - added by maqr 4 years ago.
Summary from xperf

Change History

Changed 4 years ago by maqr

DPClat screenshot

Changed 4 years ago by maqr

Summary from xperf

comment:1 Changed 4 years ago by camason

I just assumed that the jumping issues were normal behaviour. When I run with 2 cores and VT-x (especially when running a 64-bit OS) I get audio choppiness, mouse juddering, and a whole host of other host and guest based performance issues.

comment:2 Changed 4 years ago by frank

Yes, this behavior is possible with Windows 7 / x64 and there is already a fix in the trunk. Not sure if the next version or the version after the next version will contain the fix.

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Should be fixed in VBox 3.2 (IIRC) and VBox 4.0.

comment:4 Changed 3 years ago by gijs007

  • Status changed from closed to reopened
  • Resolution fixed deleted

im also having quite high dpc latency's with the latest virtual box 4.0.8 this happens under a powerful machine.

I have made a post on the forums already, which describes everything:  http://forums.virtualbox.org/viewtopic.php?f=6&t=38561

comment:5 Changed 3 years ago by frank

The posting is not 100% clear: What is your host, Windows Server 2003 r2? Or is that your guest?

comment:6 Changed 3 years ago by gijs007

host is windows 7 64 bit(now with sp1), the guest is server 2003 r2 32 bit. I have also tried as guest windows 7 sp1 32 bit, it has the same issue.

ill try a 64 bit guest soon.

comment:7 Changed 3 years ago by gijs007

I tried server 2008 r2(64 bit) as a guest os, the dpc latency might have been a bit lower bit it was still on the high side and this was idle with a clean install.

comment:8 Changed 3 years ago by gijs007

oh btw im running dpc latency checker on the host os.

comment:9 Changed 5 months ago by frank

  • Description modified (diff)

Should be improved with VBox 4.3.4.

comment:10 Changed 5 months ago by tk-oracle

I just want to confirm that this problem is gone on my Windows 7 64 Bit system. I have been just looking for the reason of the DPC latency, which I found on my system. After upgrading to Version 4.3.4 it is gone. Thanks a lot.

comment:11 Changed 4 months ago by JosefCarlin

I also had this problem and it immediately went away after installing 4.3.4. I checked the changelog and found this report. In my case I was using Win7Ultimate 64-bit host with various 32/64 bit guests (WinXP 32/64-bit, OEL 64-bit, RHEL 32/64-bit, Centos 32/64-bit). The host has a Intel Core 2 Quad CPU Q9550 @ 2.83GHz and 8 GB of memory. Typically I allocate 2 cores and 2GB to the VM's. The audio/video streams were to Windows Media Center from a Hauppauge HD PVR Tuner and Realteck High Definition Audio devices running on the host. Symptoms included choppy audio and video which "creeped" into the playback after 30 minutes or so.

Last edited 4 months ago by JosefCarlin (previous) (diff)

comment:12 Changed 4 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Thank you for the feedback. I will close this ticket as further improvements are not to be expected.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use