VirtualBox

Ticket #6221 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Reloading windows guest in seamless mode collapses virtual viewport

Reported by: dwt Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: Mac OS X

Description

Mac Snow Leopard Host, Windows XP Guest, VirtualBox 3.1.4, r57640, current guest extensions installed. Dual Monitor setup (I don't think this matters though)

To Reproduce:

  • Start XP in Seamless mode with the windows toolbar at the top of the screen
  • Suspend Windows
  • Reload it.

Seamless mode is still enabled, but the virtual viewport shrinks to about 2 by 4 inch, patly behind the menu-bar at the upper left corner.

Switching Seamless mode off and on doesn't help, but sometimes leads to different very small virtual viewports.

A workaround that works for me is disabling seamless mode, then resizing the virtual viewport-window (at the lower right handle, just resizing with the window sizing controll doesn't work) and then turning seamless mode on again.

This seems to be a case of uninitializd variables, or somethign that gets some default values after the wake from sleep - so please fix it. :-)

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Component changed from other to GUI/seamless

Please reopen if still relevant with VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use