Ticket #6196 (closed defect: fixed)

Opened 6 years ago

Last modified 4 months ago

VirtualBoxSDK-3.1.4-57640 sdk java webservice jax-ws sample not working

Reported by: gernst48 Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

I try to use the examples for java/jax-ws webservice on Windows 7 with the jdk1.6.0_18 Compiling works as expected, but running the clienttest gives the following error:

From java machine I got the following error:

"C:/Program Files (x86)/Java/jdk1.6.0_18"/bin/java -cp ../lib/vboxws_java16.jar:
./gen16 clienttest show vms
Exception in thread "main" org.virtualbox_3_1.
InvalidObjectFaultMsg: VirtualBox error: Invalid managed object reference ""
        at clienttest.<init>(
        at clienttest.main(
Caused by: org.virtualbox_3_1.InvalidObjectFaultMsg:
  VirtualBox error: Invalid managed object reference ""
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
        at java.lang.reflect.Constructor.newInstance(
        at $Proxy33.iVirtualBoxGetVersion(Unknown Source)
        ... 2 more

From the VirtualBox 3.1.4 vboxwebsrv.exe the error:

Sun VirtualBox Webservice Version 3.1.4
(C) 2005-2010 Sun Microsystems, Inc.
All rights reserved.
Socket connection successful: host = default (localhost), port = 18083, master socket = 448
1: accepted connection from IP= socket=216... Request served
2: accepted connection from IP= socket=216... #### SOAP FAULT:
  VirtualBox error: Invalid managed object reference "" [SOAP-ENV:Client]
Request served

This was also not working in 3.1.2 and I have no idea whats wrong here.

Change History

comment:1 Changed 6 years ago by frank

  • Description modified (diff)

comment:2 Changed 4 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)
Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use