VirtualBox

Ticket #6181 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

opensolaris b132 Xorg 1.7.5 guest window does not auto-resize with vbox 3.1.4 guest additions

Reported by: jkeil2 Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.4 Keywords: autoresize
Cc: Guest type: Solaris
Host type: Solaris

Description

I have a 64-bit opensolaris b132 vbox guest, running on a 64-bit SX:CE b129 vbox host. vbox 3.1.4 is installed, and the 3.1.4 guest additions are installed in the guest.

Mouse pointer integration works fine, but the vbox gui is stuck at a size of 1008x666 pixels. GUI auto resize does not work.

ps -ef shows that three VBoxClient processes are running:
VBoxClient --display
VBoxClient --clipbboard
VBoxClient --seamless

There are three $HOME/.vboxclient-*.pid files in my home directory.

Window auto resize used to work for opensolaris guests with older opensolaris releases, probably up to b129 (IIRC, b130 was the first release to include the new Xorg 1.7.x)

Attachments

OpenSolaris-2010-02-13-13-55-48.log Download (43.0 KB) - added by jkeil2 4 years ago.
VBox.log for the opensolaris b132 guest
Xorg.0.log Download (12.0 KB) - added by jkeil2 4 years ago.
Xorg.0.log from the 64-bit opensolaris b132 guest

Change History

Changed 4 years ago by jkeil2

VBox.log for the opensolaris b132 guest

Changed 4 years ago by jkeil2

Xorg.0.log from the 64-bit opensolaris b132 guest

comment:1 Changed 4 years ago by jkeil2

These messages from the opensolaris guest might be relevant, too:

jk@opensolaris:~$ dmesg | grep vbox
Feb 13 13:32:07 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:32:13 opensolaris vboxguest: [ID 931919 kern.notice] VBoxGuestCommonIOCtl: WAITEVENT: returns 0 but no events!
Feb 13 13:32:13 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:32:19 opensolaris vboxguest: [ID 931919 kern.notice] VBoxGuestCommonIOCtl: WAITEVENT: returns 0 but no events!
Feb 13 13:32:19 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:32:32 opensolaris vboxguest: [ID 931919 kern.notice] VBoxGuestCommonIOCtl: WAITEVENT: returns 0 but no events!
Feb 13 13:32:32 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:35:27 opensolaris vboxguest: [ID 931919 kern.notice] VBoxGuestCommonIOCtl: WAITEVENT: returns 0 but no events!
Feb 13 13:35:27 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:35:27 opensolaris vboxguest: [ID 931919 kern.notice] VBoxGuestCommonIOCtl: WAITEVENT: returns 0 but no events!
Feb 13 13:35:27 opensolaris vboxguest: [ID 839533 kern.notice] vboxguest::IOCtl: VBoxGuestCommonIOCtl failed. rc=-225
Feb 13 13:40:19 opensolaris vboxguest: [ID 234141 kern.notice] vboxguest::IOCtl: bad size 0x0; pArg=fffffd7fffdfeda0 Cmd=0xc0105605.
Feb 13 13:50:58 opensolaris vboxguest: [ID 137117 kern.notice] vboxguest::IOCtl: bad size 0x0; pArg=fffffd7fffdfe830 Cmd=0xc0105605.

comment:2 Changed 4 years ago by jkeil2

So far, I'm unable to reproduce this problem on a MacOS X or Windows vbox host.

comment:3 Changed 4 years ago by ramshankar

  • Summary changed from opensolaris b132 Xorg 1.7.5 guest window does not auto-resize with vbox 3.1.4 guest additions to opensolaris b132 Xorg 1.7.5 guest window does not auto-resize with vbox 3.1.4 guest additions => Fixed in SVN

As I mentioned in the forum, the "WAITEVENT: returns 0 but no events!" and the follow lines are just superfluous logging, the 'bad size' request has now been fixed.

As for the guest resizing not working, I cannot replicate the issue here with Xorg 1.7.3 and snv_130. Perhaps it's only for snv_132 specific, will try it shortly. Just FYI apart from the logging, the additions work fine on snv_130/Xorg 1.7.3 here.

comment:4 Changed 4 years ago by ramshankar

  • Summary changed from opensolaris b132 Xorg 1.7.5 guest window does not auto-resize with vbox 3.1.4 guest additions => Fixed in SVN to opensolaris b132 Xorg 1.7.5 guest window does not auto-resize with vbox 3.1.4 guest additions

comment:5 Changed 4 years ago by jkeil2

b133 was released today, and with a fresh b133 install + virtualbox 3.1.4 additions the problem is gone.

Maybe the problem was fixed, or the problem isn't always 100% reproducible and for me doesn't reproduce any more on b133. Booting the old b132 guest installation still shows the auto resize problem.

I don't see any changes in the opensolaris b133 changelog for the X window server that could be relevant for this issue:

 http://hub.opensolaris.org/bin/view/Community+Group+x_win/changelogs-nv_130

comment:6 Changed 4 years ago by ramshankar

  • Status changed from new to closed
  • Resolution set to fixed

Since the problem isn't reproducible and it works with the latest additions I'll close this defect for now. If problem reappears, please reopen or open a new defect. Thank you.

comment:7 Changed 4 years ago by jkeil2

In the opensolaris forums, a user reported a similar problem...
 http://www.opensolaris.org/jive/thread.jspa?threadID=129645&tstart=0

So I played a bit with my old b132 guest that showed the broken auto-resize behavior. The problem is still present when I run that opensolaris build 132 guest under vbox 3.1.8, and install the vbox 3.1.8 guest additions, log out from the gnome desktop and re-login.

What I found out is that the "Machine" -> "Auto-resize Guest Display" (Host-G) icon in the guest's window menu isn't checked for that build132 opensolaris guest. As soon as I use the Host-G command, the guest display auto-resizes just fine.

Is the "Auto-resize Guest Display" option supposed to be enabled by default for a guest when the guest additions are installed?

What I do see is that when I restore my b132 guest from a snapshot (before the guest additions are installed), the "Auto-resize Guest Display" menu item is disabled, and shows no checkbox mark in the disabled menu icon. The "Adjust Window Size" menu item is enabled. After installing the guest additions, log out and re-login, the "Auto-resize Guest Display" menu item is enabled, but there still is no checkbox mark on the icon. And of cause the guest does not adjust it's desktop size when I resize the vbox guest window. After Host-G it resizes automatically.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use