VirtualBox

Ticket #6155 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Bridged Network problem

Reported by: skuda Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Hello,

i have detected a serious problem with virtualbox in my machine, i dont know what version introduced this behavior but i had not this problems any time ago (any months before but with a 3.0 release i think), my host so it is Arch Linux (kernel 2.6.32), the problem i have it is that linux guests degrade my host network (and guest too) when i use the network inside the guest (not have this problem with windows guests or almost not as easily to reproduce), for example if i download anything in my linux guest or transfer files between guest and host the host network go slow as hell.

host ip: 192.168.1.4 lan ip: 192.168.1.1 (one printer in lan)

ping from my host: 64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.382 ms

64 bytes from 192.168.1.1: icmp_seq=5 ttl=64 time=0.399 ms

64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=0.346 ms

64 bytes from 192.168.1.1: icmp_seq=7 ttl=64 time=0.376 ms

64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=0.332 ms

64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=411 ms <--- here begin a simple download from internet in a guest.

64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=4606 ms

64 bytes from 192.168.1.1: icmp_seq=11 ttl=64 time=3604 ms

64 bytes from 192.168.1.1: icmp_seq=12 ttl=64 time=2604 ms

64 bytes from 192.168.1.1: icmp_seq=13 ttl=64 time=4300 ms

64 bytes from 192.168.1.1: icmp_seq=14 ttl=64 time=3301 ms

64 bytes from 192.168.1.1: icmp_seq=15 ttl=64 time=4126 ms

64 bytes from 192.168.1.1: icmp_seq=16 ttl=64 time=3117 ms

64 bytes from 192.168.1.1: icmp_seq=17 ttl=64 time=3959 ms

I had before a bridge (br0) that i used for the bridge interface (like old versions of virtualbox needed) but after search how to fix this problem i read in the forum that in the last versions it is not recommended so i deleted the bridge and used eth0 for the interface in the guests configuration, this does not helped though. The linux kernel in the guest vm it is 2.6.30-1-686 (debian) but i have tried too with 2.6.24 and have the same problem. If i disable the guest interface and enable other time i have a small time of working better (normal) but in less that 2 minutes i have the same problem.

Host uses a intel 1000 desktop network interface (i have tried disabling tso) and in the guest i have tried three different cards with the same result.

This post in the forum seems to be related too  http://forums.virtualbox.org/viewtopic.php?f=6&t=25543&p=123376#p123376.

I have attached the log of a session with the problem but i think this problem does not log anything.

Attachments

VBox.log Download (70.1 KB) - added by skuda 4 years ago.
VirtualBox Log.

Change History

Changed 4 years ago by skuda

VirtualBox Log.

comment:1 Changed 4 years ago by aleksey

Hi,

I could not reproduce the problem on my host (2.6.32-ARCH). Can you capture the network traffic with 'tcpdump -w' and send the resulting file to me in private mail to aleksey _dot_ ilyushin _at_ sun _dot_ com?

comment:2 Changed 4 years ago by aleksey

The initial packet capture analysis showed plenty of PAUSE messages with no traffic at all. After disabling flow control the ping time went down to 100-250 ms which is still not right.

comment:3 Changed 3 years ago by frank

  • Component changed from network to network/hostif

comment:4 Changed 3 years ago by aleksey

Is the problem still present in 4.0.2?

comment:5 Changed 3 years ago by skuda

Seems to be fixed or it is much more difficult than before make it appear. I will be alert to notify here if i get the problem.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if necessary.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use