VirtualBox

Ticket #614 (closed defect: fixed)

Opened 7 years ago

Last modified 4 years ago

VirtualBox hangs on "Starting the virtual machine... 0%"

Reported by: Nolan Owned by:
Priority: critical Component: other
Version: VirtualBox 1.5.0 Keywords:
Cc: Guest type: other
Host type: other

Description

When starting a VM with VirtualBox 1.5, it hangs on "Starting the virtual machine..." at 0%. I am forced to use kill -9 to kill the process - it hangs indefinitely. The dmesg output is below:

[  157.048000] CPU:    0
[  157.048000] EIP:    0060:[<c01675bf>]    Tainted: PF     VLI
[  157.048000] EFLAGS: 00210202   (2.6.20-15-generic #2)
[  157.048000] EIP is at split_vma+0x6f/0xe0
[  157.048000] eax: 00000001   ebx: c03a9c98   ecx: 00000000   edx: 00000054
[  157.048000] esi: b3f0c000   edi: 00000000   ebp: f5980668   esp: f5a8fdc4
[  157.048000] ds: 007b   es: 007b   ss: 0068
[  157.048000] Process VirtualBox (pid: 8157, ti=f5a8e000 task=f6604560 task.ti=f5a8e000)
[  157.048000] Stack: 00000000 00000000 b3f0c000 c03a9cb4 c03a9c98 b3f26000 c01676c8 00000000 
[  157.048000]        f65899b0 ffffffff ffffffff b3f26000 00000007 00000000 0000001a b3f0c000 
[  157.048000]        f6604560 f70b3490 f8fc1fb0 f6604560 00000007 f70b3490 f5a8fe60 00000027 
[  157.048000] Call Trace:
[  157.048000]  [<c01676c8>] do_munmap+0x98/0x1e0
[  157.048000]  [<f8fc1fb0>] rtR0MemObjNativeMapUser+0x260/0x270 [vboxdrv]
[  157.048000]  [<f8fc07b0>] RTR0MemObjMapUser+0xe0/0x190 [vboxdrv]
[  157.048000]  [<f8fbd639>] SUPR0LowAlloc+0xc9/0x190 [vboxdrv]
[  157.048000]  [<f8fbe8cf>] supdrvIOCtl+0x3df/0x1540 [vboxdrv]
[  157.048000]  [<c016b30c>] __vmalloc_area_node+0xdc/0x130
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<f8fbc1bb>] VBoxSupDrvDeviceControl+0xeb/0x160 [vboxdrv]
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<c01826e8>] do_ioctl+0x78/0x90
[  157.048000]  [<c018275c>] vfs_ioctl+0x5c/0x2a0
[  157.048000]  [<c0182a12>] sys_ioctl+0x72/0x90
[  157.048000]  [<c01031f0>] sysenter_past_esp+0x69/0xa9
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  =======================
[  157.048000] Code: ba d0 00 00 00 e8 e2 b5 00 00 85 c0 89 c5 74 d2 b9 54 00 00 00 89 da e8 50 a3 08 00 85 ff 74 45 89 75 08 8b 45 48 85 c0 74 04 90 <ff> 40 14 8b 45 40 85 c0 74 0a 8b 10 85 d2 74 04 89 e8 ff d2 85 
[  157.048000] EIP: [<c01675bf>] split_vma+0x6f/0xe0 SS:ESP 0068:f5a8fdc4

This is on Ubuntu 7.04 32-bit on an AMD64 processor, 2GB RAM, if that helps.

Attachments

vboxdrv.tar.bz2 Download (147.1 KB) - added by frank 7 years ago.
vboxdrv kernel module with debug output
dmesg09052007 Download (41.8 KB) - added by Nolan 7 years ago.

Change History

comment:1 Changed 7 years ago by frank

Please could you add some more lines of the dmesg output, in particular the reason for the backtrace. Which trap occurred or which page fault?

comment:2 Changed 7 years ago by Nolan

Sure. Sorry, I missed a few lines. This is the ENTIRE dmesg output that gets written when I try to start a VM with VirtualBox.

[  248.796000] BUG: unable to handle kernel NULL pointer dereference at virtual address 00000015
[  248.796000]  printing eip:
[  248.796000] c01675bf
[  248.796000] *pde = 00000000
[  248.796000] Oops: 0002 [#1]
[  248.796000] SMP 
[  248.796000] Modules linked in: smbfs nls_cp437 isofs udf binfmt_misc rfcomm hidp l2cap vboxdrv ppdev powernow_k8 cpufreq_powersave cpufreq_userspace cpufreq_ondemand cpufreq_conservative cpufreq_stats freq_table sony_acpi dev_acpi tc1100_wmi pcc_acpi battery asus_acpi button sbs backlight i2c_ec container video ac dock ipv6 xt_multiport xt_limit xt_tcpudp ipt_LOG ipt_MASQUERADE ipt_TOS ipt_REJECT nf_conntrack_irc nf_conntrack_ftp xt_state iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nfnetlink iptable_mangle iptable_filter ip_tables x_tables af_packet sbp2 lp parport fuse joydev snd_intel8x0 snd_ac97_codec ac97_bus snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss lmpcm_usb hci_usb wlan_scan_sta bluetooth nvidia(P) snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device sdhci psmouse ath_rate_sample agpgart sky2 pcspkr mmc_core serio_raw ath_pci wlan snd soundcore i2c_nforce2 snd_page_alloc k8temp ath_hal(P) shpchp pci_hotplug i2c_core uinput tsdev evdev ext3 jbd mbcache dm_mirror dm_mod ide_cd cdrom usbhid hid sg sd_mod generic amd74xx sata_nv ohci1394 ieee1394 ata_generic libata scsi_mod ehci_hcd ohci_hcd usbcore thermal processor fan fbcon tileblit font bitblit softcursor vesafb capability commoncap
[  248.796000] CPU:    0
[  248.796000] EIP:    0060:[<c01675bf>]    Tainted: PF     VLI
[  248.796000] EFLAGS: 00010202   (2.6.20-15-generic #2)
[  248.796000] EIP is at split_vma+0x6f/0xe0
[  248.796000] eax: 00000001   ebx: c03a9c98   ecx: 00000000   edx: 00000054
[  248.796000] esi: b3f13000   edi: 00000000   ebp: f4455908   esp: f3981dc4
[  248.796000] ds: 007b   es: 007b   ss: 0068
[  248.796000] Process VirtualBox (pid: 8228, ti=f3980000 task=f3973a90 task.ti=f3980000)
[  248.796000] Stack: 00000000 00000000 b3f13000 c03a9cb4 c03a9c98 b3f2d000 c01676c8 00000000 
[  248.796000]        f3fa7cf8 ffffffff ffffffff b3f2d000 00000007 00000000 0000001a b3f13000 
[  248.796000]        f3973a90 f52c0a90 f9036fb0 f3973a90 00000007 f52c0a90 f3981e60 00000027 
[  248.796000] Call Trace:
[  248.796000]  [<c01676c8>] do_munmap+0x98/0x1e0
[  248.796000]  [<f9036fb0>] rtR0MemObjNativeMapUser+0x260/0x270 [vboxdrv]
[  248.796000]  [<f90357b0>] RTR0MemObjMapUser+0xe0/0x190 [vboxdrv]
[  248.796000]  [<f9032639>] SUPR0LowAlloc+0xc9/0x190 [vboxdrv]
[  248.796000]  [<f90338cf>] supdrvIOCtl+0x3df/0x1540 [vboxdrv]
[  248.796000]  [<c016b30c>] __vmalloc_area_node+0xdc/0x130
[  248.796000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  248.796000]  [<f90311bb>] VBoxSupDrvDeviceControl+0xeb/0x160 [vboxdrv]
[  248.796000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  248.796000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  248.796000]  [<c01826e8>] do_ioctl+0x78/0x90
[  248.796000]  [<c018275c>] vfs_ioctl+0x5c/0x2a0
[  248.796000]  [<c0182a12>] sys_ioctl+0x72/0x90
[  248.796000]  [<c01031f0>] sysenter_past_esp+0x69/0xa9
[  248.796000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  248.796000]  =======================
[  248.796000] Code: ba d0 00 00 00 e8 e2 b5 00 00 85 c0 89 c5 74 d2 b9 54 00 00 00 89 da e8 50 a3 08 00 85 ff 74 45 89 75 08 8b 45 48 85 c0 74 04 90 <ff> 40 14 8b 45 40 85 c0 74 0a 8b 10 85 d2 74 04 89 e8 ff d2 85 
[  248.796000] EIP: [<c01675bf>] split_vma+0x6f/0xe0 SS:ESP 0068:f3981dc4
[  248.796000] 

The only other line related to VirtualBox occurs on the module load:

[   48.264000] vboxdrv: Trying to deactivate the NMI watchdog permanently...
[   48.264000] vboxdrv: Successfully done.

I hope this helps. Is there something else I can do to provide more info?

comment:3 Changed 7 years ago by Technologov

I believe you must disable KVM first.

Try "rmmod kvm_intel" and "rmmod kvm_amd"

-Technologov

comment:4 Changed 7 years ago by frank

No, he has kvm not loaded and I doubt that this is compiled into the Ubuntu kernel. It seems that some memory allocation failed and the cleanup path is wrong.

Nolan, how did you configure your VM? How much memory?

comment:5 Changed 7 years ago by Nolan

This VM is configured with 192MB of memory. This is a "vanilla" VM which I started from scratch just to make sure it wasn't a problem with an existing configuration. It is set to an OS Type of Windows XP, Base Mem of 192MB, Vid Mem or 8MB, Boot Order Floppy, CD/DVD-ROM, Hard Disk, ACPI Enabled, IO APIC Disabled. I have at least 192MB memory free when I check with the "free" command.

This is the stock Ubuntu kernel, so I am pretty sure kvm is not compiled in as well.

If it helps, with 1.4.2 I was also unable to start a VM because VirtualBox couldn't allocate enough contiguous memory. This makes no sense to me since I am running a system that more than meets the requirements to run the VMs I am trying to start up.

Changed 7 years ago by frank

vboxdrv kernel module with debug output

comment:6 Changed 7 years ago by frank

I have attached the vboxdrv sources with slightly modifications. Please could you extract the archive, compile the module with

make KERN_DIR=/lib/modules/`uname -r`

insert this module and try to start VirtualBox again? Then, please post (or better attach) the complete output of dmesg.

comment:7 Changed 7 years ago by Nolan

Ok, here's the complete output of dmesg after the kernel module has been replaced with the modified ones. Doesn't mean anything to me, but maybe it does to you.

Changed 7 years ago by Nolan

comment:8 Changed 7 years ago by Nolan

Is there any hope of getting this issue resolved?

Thanks!

comment:9 Changed 7 years ago by Aelia

I sometimes get the same problem with a macbook core duo 2.0GHz with 2Gb ram. But I can't reproduce at will... another problem gets in the way... I will make another ticket for it if I don't find anything similar.

comment:10 Changed 7 years ago by Aelia

Ok this was related to VT-x enabled, too. The second bug was a protection error in dmesg (host) linux kernel and a missing int in the bios for the virtual machine. I have 4 logs that say the same thing.

comment:11 Changed 7 years ago by Nolan

On mine, I've got the following Extended Features turned off:

Enable ACPI Enable IO APIC Enable VT-x/AMD-V

The issue still occurs for me.

comment:12 Changed 7 years ago by Nolan

As of Ubuntu 7.10 this issue is resolved.

comment:13 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:14 in reply to: ↑ description Changed 6 years ago by blueraven

  • Status changed from closed to reopened
  • Resolution fixed deleted

Folks I am having exactly the same problem except not on ubuntu but on Fedora 7 x86_64 and VirtualBox-1.5.4_27034_fedora7-1.x86_64.rpm

I am allocating 512 MB to the VM, using Fedora-8-i386-DVD.iso as the cdrom (just wanted to see if I could make it work).

Only difference is I am not getting a core dump. Just a hang.

Please advise what data I need to gather to attach to this problem report.

Replying to Nolan:

When starting a VM with VirtualBox 1.5, it hangs on "Starting the virtual machine..." at 0%. I am forced to use kill -9 to kill the process - it hangs indefinitely. The dmesg output is below:

[  157.048000] CPU:    0
[  157.048000] EIP:    0060:[<c01675bf>]    Tainted: PF     VLI
[  157.048000] EFLAGS: 00210202   (2.6.20-15-generic #2)
[  157.048000] EIP is at split_vma+0x6f/0xe0
[  157.048000] eax: 00000001   ebx: c03a9c98   ecx: 00000000   edx: 00000054
[  157.048000] esi: b3f0c000   edi: 00000000   ebp: f5980668   esp: f5a8fdc4
[  157.048000] ds: 007b   es: 007b   ss: 0068
[  157.048000] Process VirtualBox (pid: 8157, ti=f5a8e000 task=f6604560 task.ti=f5a8e000)
[  157.048000] Stack: 00000000 00000000 b3f0c000 c03a9cb4 c03a9c98 b3f26000 c01676c8 00000000 
[  157.048000]        f65899b0 ffffffff ffffffff b3f26000 00000007 00000000 0000001a b3f0c000 
[  157.048000]        f6604560 f70b3490 f8fc1fb0 f6604560 00000007 f70b3490 f5a8fe60 00000027 
[  157.048000] Call Trace:
[  157.048000]  [<c01676c8>] do_munmap+0x98/0x1e0
[  157.048000]  [<f8fc1fb0>] rtR0MemObjNativeMapUser+0x260/0x270 [vboxdrv]
[  157.048000]  [<f8fc07b0>] RTR0MemObjMapUser+0xe0/0x190 [vboxdrv]
[  157.048000]  [<f8fbd639>] SUPR0LowAlloc+0xc9/0x190 [vboxdrv]
[  157.048000]  [<f8fbe8cf>] supdrvIOCtl+0x3df/0x1540 [vboxdrv]
[  157.048000]  [<c016b30c>] __vmalloc_area_node+0xdc/0x130
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<f8fbc1bb>] VBoxSupDrvDeviceControl+0xeb/0x160 [vboxdrv]
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  [<c01826e8>] do_ioctl+0x78/0x90
[  157.048000]  [<c018275c>] vfs_ioctl+0x5c/0x2a0
[  157.048000]  [<c0182a12>] sys_ioctl+0x72/0x90
[  157.048000]  [<c01031f0>] sysenter_past_esp+0x69/0xa9
[  157.048000]  [<c0102210>] __switch_to+0xa0/0x1f0
[  157.048000]  =======================
[  157.048000] Code: ba d0 00 00 00 e8 e2 b5 00 00 85 c0 89 c5 74 d2 b9 54 00 00 00 89 da e8 50 a3 08 00 85 ff 74 45 89 75 08 8b 45 48 85 c0 74 04 90 <ff> 40 14 8b 45 40 85 c0 74 0a 8b 10 85 d2 74 04 89 e8 ff d2 85 
[  157.048000] EIP: [<c01675bf>] split_vma+0x6f/0xe0 SS:ESP 0068:f5a8fdc4

This is on Ubuntu 7.04 32-bit on an AMD64 processor, 2GB RAM, if that helps.

comment:15 Changed 6 years ago by frank

blueraven: Does this issue still persisits for you? Could you try VirtualBox 1.5.6? Could you attach the VBox.log file of the VM which you are about to start?

comment:16 Changed 6 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

Try again with 1.6.0 and report back if it's still relevant. Thanks.

comment:17 Changed 5 years ago by krawetko

  • Status changed from closed to reopened
  • Resolution fixed deleted

I got this "Starting virtual machine 0%" error running Ubuntu 8.10 Guest on Windows Vista x64 Business Host.
I'm using VirtualBox 64 Bit ver 2.1.4. I've been using virtualBox in this configuration for a long of time and I get this error
since I installed version which added 3D support.

ACPI and VT is Enabled.

My notebook configuration:

C2D T9500 2.6 Ghz
4GB RAM in Dual Channel
Mainboard based on PM965
Nvidia GF 8600GT
Seagate Momentus 250GB

comment:18 Changed 5 years ago by krawetko

Here is a Log after such an error:

00:00:00.373 VirtualBox 2.1.4 r42893 win.amd64 (Feb 16 2009 17:13:48) release log
00:00:00.373 Log opened 2009-02-21T10:40:16.573296400Z
00:00:00.373 OS Product: Windows Vista Business Edition
00:00:00.373 OS Release: 6.0.6001
00:00:00.373 OS Service Pack: 1
00:00:00.373 Package type: WINDOWS_64BITS_GENERIC
00:00:00.378 SUP: Loaded VMMR0.r0 (C:\PROGRA~1\Sun\xVM VirtualBox/VMMR0.r0) at 0xfffffa80069ff080 - ModuleInit at fffffa8006a0cff0 and ModuleTerm at fffffa8006a0d060
00:00:00.378 SUP: VMMR0EntryEx located at fffffa8006a0db40, VMMR0EntryFast at fffffa8006a0d210 and VMMR0EntryInt at fffffa8006a0d200
00:00:00.378 SUP: windbg> .reload /f C:\PROGRA~1\Sun\xVM VirtualBox/VMMR0.r0=0xfffffa80069ff080
00:00:00.434 VBoxSharedClipboard mode: Bidirectional

comment:19 Changed 5 years ago by domdorn

I'm having the exact same problem on Gentoo, however I found a workaround.

When i normally start Virtualbox and try to load my win xp image, its also hanging with the "Starting the virtual machine... 0%" message.

I then do the following:

domdorn@camelion ~ $ ps -ef | grep -i virt
domdorn   6640  5295  0 00:11 pts/1    00:00:00 /opt/VirtualBox/VirtualBox
domdorn   6654  6640  0 00:11 pts/1    00:00:00 /opt/VirtualBox/VBoxXPCOMIPCD
domdorn   6661     1  0 00:11 ?        00:00:00 /opt/VirtualBox/VBoxSVC --automate
domdorn   6680  6661  0 00:12 ?        00:00:00 /opt/VirtualBox/VirtualBox --comment Windows XP --startvm deaee5b9-55e1-4f81-849b-fd0e48a4e8fc
domdorn   6775  6770  0 00:16 pts/2    00:00:00 grep --colour=auto -i virt
domdorn@camelion ~ $ kill -9 6640 6654 6661 6680

domdorn@camelion ~ $ export VBOX_GUI_DBG_ENABLED=true
domdorn@camelion ~ $ export VBOX_GUI_DBG_AUTO_SHOW=true
domdorn@camelion ~ $ VirtualBox

this now opens the Virtualbox window again. When i now mark my vm and click on start, it attaches some debugwindows to the main window, and the machine is not really started. now I click "Machine" -> "Resume" and it boots.

I now can shutdown and start the machine as often I want (till the next reboot, then it's happening again)

I'm using virtualbox 2.2.0

this is my gentoo info:

camelion ~ # emerge --info
Portage 2.1.6.11 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.29-gentoo-r1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Mon, 27 Apr 2009 19:30:17 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.fi.muni.cz/pub/linux/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 apic arch_perfmon bash-completion berkdb bluetooth branding bts bzip2 cairo cdda cdr clflush cli cmov constant_tsc cracklib crypt cups cx16 cx8 dbus de directfb dri ds_cpl dts dvd dvdr dvdread eds emboss encode esd est evo fam firefox flac fortran fpu fxsr gdbm gif gimp gnome gnome-keyring gphoto2 gpm gstreamer gtk hal ht iconv ida ipv6 isdnlog java jpeg kde lahf_lm laptop libnotify lm loop-aes mad mca mce midi mikmod mmx monitor mp3 mpeg mplayer msr mtrr mudflap multilib ncurses nls nptl nptlonly nvidia nx ogg openal opengl openmp pae pam pat pbe pcre pdf pebs perl pge png pni ppds pppd pse pse36 python qt3 qt3support qt4 quicktime readline reflection rep_good sdl sep session smp spell spl ss sse sse2 sse4_1 ssl ssse3 startup-notification svg syscall sysfs tcpd tiff tm tm2 truetype tsc unicode usb vim-syntax vme vmx vorbis xml xorg xscreensaver xtpr xulrunner xv zlib" ALSA_CARDS="usb-audio emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

comment:20 Changed 5 years ago by frank

Actually an strace log of the VM would be interesting:

sudo chmod u+s /usr/bin/strace
killall VBoxSVC
strace -f -o ~/log /opt/VirtualBox/VirtualBox --startvm VM_NAME

I would be interested in ~/log, please attach a bzip2-compressed version to this ticket.

comment:21 Changed 5 years ago by brocky

I too have the same problem on Windows Vista x64 and VirtualBox 2.2.4.

This happens to all my VMs occasionally, usually when I try to start a second or a third VM. when this happens the currently running VMs work, no other VMs will start and occasionally the main UI freezes. Once this has happened, the process will not exit, even when I try toend the process via windows task manager, and any newly loaded .exe's will also freeze, but can be terminated.

This had never happened on the same PC until i updraded to version 2.X.X

All my VMs have similar configurations:

Video Memory: 128MB
VTx/AMD-V: Enabled
Nested Paging: Disabled
Base Memory: 1024MB - 4069MB
3D Acceleration: Enabled
VRDP: Disabled
A single HDD
All other settings are the defaults

The host computer has: CPU: Intel Core 2 Quad Q9550 overclocked to 3.2GHz Motherboard: Gigabyte X48T-DQ6 RAM: 4x 2GB Corsair 1333MHz GFX Card: Asus GTX260TOP 896MB 650MHz

comment:22 Changed 5 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

comment:23 Changed 4 years ago by cederom

  • Status changed from closed to reopened
  • Resolution fixed deleted

Again the same with VirtualBox 3.2.8 r64453 for Windows. Using platon and windows 2003 on VM. After initial format and file copy, reboot finish with "Starting Platon Config..." then nothing. Tried almost all settings fuzz but no change. Sometimes it starts and move forward (very rare). Image created on VMWare hangs after text progress bar reaches full on boot. Please advise. This seems to propagate among versions 1.x 2.x and 3.x...

comment:24 Changed 4 years ago by sandervl73

  • Status changed from reopened to closed
  • Resolution set to fixed

This doesn't seem related to this ticket. I suggest you open a new one and provide more information (VBox.log at least).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use