VirtualBox

Ticket #6096 (closed defect: fixed)

Opened 4 years ago

Last modified 2 years ago

WinXP crashes @ boot if GuestAdditions are installed (SMP/IO-APIC - AMD cpu)

Reported by: bendj Owned by:
Priority: critical Component: guest smp
Version: VirtualBox 3.2.12 Keywords: Windows XP Guest Additions VT-x
Cc: Guest type: Windows
Host type: Linux

Description

on,

uname -ri

2.6.31.8-0.1-desktop x86_64

cat /proc/cpuinfo | grep "model name"

model name : AMD Phenom(tm) II X4 945 Processor

i've installed,

rpm -qa | grep -i virtualbox

VirtualBox-3.1-3.1.2_56127_openSUSE111-1.x86_64

with VT-x enabled.

i've installed WinXP Pro. the install goes fine, and the Guest (re)boots & functions normally.

if I install Guest Additions, the GA install completes ok. But, when I reboot the Guest, it FAILs, dropping me to the SafeMode etc selection screen. I can boot into SafeMode, but can't "Boot normally" at this point. It's not the Guest that's crashing, but rather the GuestOS ...

If I UNinstall GAs @ SafeMode desktop, thee reboot the machine, all's OK.

If I first DISable VT-x, then repeat -- installing GAs -- then, at reboot, the Guest boots fine.

Fully reproducible here.

Attachments

builder-2010-08-10-08-59-56-GuestAdditions3.2.8.log Download (58.7 KB) - added by bpk 4 years ago.
This is a log of the bsod reboot loop using guest additions 3.2.8 on phenom II
builder-2010-08-10-09-03-32-GuestAdditions2.2.4.log Download (56.1 KB) - added by bpk 4 years ago.
This is a log of the same machine using same version of virtualbox but guest additions 2.2.4 allowing smp xp pro to run
bsod1.png Download (10.7 KB) - added by bpk 4 years ago.
bsod after first reboot after installing guest additions
bsod2.png Download (11.3 KB) - added by bpk 4 years ago.
second reboot after selecting "normal startup"
bsod3.png Download (10.7 KB) - added by bpk 4 years ago.
third bsod after selecting "normal startup"
bsod4.png Download (11.3 KB) - added by bpk 4 years ago.
fourth bsod after selecting "normal startup"

Change History

comment:1 Changed 4 years ago by bendj

just realized it's NOT the turning off of VT-x, but rather the reduction from 2 procs -> 1 proc that went along with it.

i.e.,

VT-x -> ON, # cpus == 1, boots OK with GAs VT-x -> ON, # cpus == 2, Windows fails to boot

comment:2 Changed 4 years ago by Technologov

This means that the component must be "Guest SMP"

-Technologov

comment:3 Changed 4 years ago by sandervl73

  • Component changed from other to guest smp
  • Summary changed from with VT-x enabled, WinXP Pro OS crashes @ boot if GuestAdditions are installed to WinXP Pro OS crashes @ boot if GuestAdditions are installed (smp) -> retry witt 3.1.4

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:4 Changed 4 years ago by bendj

installing,

rpm -Uvh VirtualBox-3.1-3.1.4_BETA1_57050_openSUSE112-1.x86_64.rpm

get a version # mismatch,

rpm -qa | grep -i VirtualBox

VirtualBox-3.1-3.1.4_BETA1_57050_openSUSE111-1.x86_64

openSUSE 111 vs 112 ...

but, launching VB with VT-d "ON", and any # cpus 1 -4, the GuestOS WinXP_Pro -- with GuestAdditions installed -- now launches OK.

one thing I _do_ notice is that time from launch to GuestOS Desktop seems significantly longer than b4. nothing quantitative, atm, though.

comment:5 Changed 4 years ago by bendj

but, with the BETA, i can no longer get Display/Window resizing to work. If I zoom the container window to maximized - 1920 x 923, atm) the actual GuestOS display no longer changes with it.

Switching BACK to the release, non-bate version -- as well as switching back to 1-CPU -- cures the problem.

comment:6 follow-up: ↓ 7 Changed 4 years ago by frank

bendj, that version mismatch is not an issue, we are just maintaining the same package for openSUSE 11.1 and openSUSE 11.2.

Regarding your problem with resizing the guest window: Did resizing the guest window stopped at all or only if you switch to host maximum? How much video RAM did you set for this VM?

But finally at least your XP guest crashes are gone, correct?

comment:7 in reply to: ↑ 6 Changed 4 years ago by bendj

Replying to frank:

bendj, that version mismatch is not an issue

Ok.

Regarding your problem with resizing the guest window: Did resizing the guest window stopped at all or only if you switch to host maximum?

Afaict, it stopped completely -- neither switching to host maximum, nor to any arbitrary size, seemed to work.

How much video RAM did you set for this VM?

The Maximum -- 128Mb.

But finally at least your XP guest crashes are gone, correct?

As a result of the #cpus > 1, yes - the crashes are gone. I may be imagining it, but GuestOS system responsiveness seemed slower with the Beta + 4 CPUS, compared to the Release Version + 1 CPUS.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

I will close this defect as the original problem seems solved. Please create new tickets for remaining problems with VBox 3.1.4.

comment:9 Changed 4 years ago by bpk

  • Status changed from closed to reopened
  • Resolution fixed deleted

I am having this same problem with 3.2.6, and only on a Phenom II. If I run an smp XP Pro SP3 guest on 3.2.6 with multiple cpus it boots fine, after installing the guest additions booting failed with a variety of different BSODs. Reducing the number of cpus to 1 allows booting again. However installing guest additions on an smp XP guest works fine on an AMD Athalon II X3. If I use an older version of the guest additions (pre 3.0, such as 2.2.4 or 1.6.6) then multi cpu on the Phenom II is fine, and I still get graphic resizing, seamless, mouse integration, etc, so this seems like it might be related to the guest additions smp fixes for amd chipsets maybe? I am reopening this ticket because I also tried 3.1.8 with the same results, so I believe this problem existed before but seems to be CPU specific so maybe was missed.

comment:10 Changed 4 years ago by frank

  • Summary changed from WinXP Pro OS crashes @ boot if GuestAdditions are installed (smp) -> retry witt 3.1.4 to WinXP Pro OS crashes @ boot if GuestAdditions are installed (SMP)

comment:11 Changed 4 years ago by bpk

Same problem in virtualbox 3.2.8 using guest additions 3.2.8 on Phenom II, endless bsod loops at boot. Using pre-3.0 guest additions, e.g. 2.2.4 then smp is fine and the guest runs normally using as many processors as I can set.

Changed 4 years ago by bpk

This is a log of the bsod reboot loop using guest additions 3.2.8 on phenom II

Changed 4 years ago by bpk

This is a log of the same machine using same version of virtualbox but guest additions 2.2.4 allowing smp xp pro to run

comment:12 Changed 4 years ago by sandervl73

Does it make any difference if you disable nested paging?

comment:13 Changed 4 years ago by bpk

No difference disabling nested paging in 3.2.8, downloaded 3.2.10 and tried again with the same results. Installing the guest additions using an smp enabled xp guest and it goes in to a bsod loop. Disabling nested paging in 3.2.10 also made no difference. This smp guest functions fine on other 64 bit cpus (core i5, amd athalon II x3, etc) Here is my cpu info for the problematic cpu:

model name : AMD Phenom(tm) II X6 1055T Processor

flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt

comment:14 Changed 4 years ago by sandervl73

What kind of blue screen is it? A screenshot might help.

comment:15 Changed 4 years ago by bpk

I took 4 bsod screen shots and I'm going to attach them, they occur during the initial bootup before you get a desktop or login prompt immediately after rebooting from installing the guest additions. So it's install guest additions, reboot, watch the windows logo thing, bsod. Now if I reboot I get the prompt to start normally or safe mode, etc, selecting start normally will then show the windows logo briefly then bsod. At this point it just loops like that, each startup will ask about normal or safe or last good startup, and anything except last good startup will bsod.

Changed 4 years ago by bpk

bsod after first reboot after installing guest additions

Changed 4 years ago by bpk

second reboot after selecting "normal startup"

Changed 4 years ago by bpk

third bsod after selecting "normal startup"

Changed 4 years ago by bpk

fourth bsod after selecting "normal startup"

comment:16 Changed 4 years ago by sandervl73

Are you able to extract a minidump from the guest? Only the BSOD from the 1st and 3rd one are interesting. (0x0000008E bug checks)

You should be able to work around the problem by executing:

VBoxManage setextradata "VM name" "VBoxInternal/HWVirtExt/TPRPatchingEnabled" 0

comment:17 Changed 4 years ago by bpk

It doesn't look like it's generating minidumps for the bsod's at bootup. I can force a bsod during a normal bootup using ctrl+scroll lock+scroll lock and get a minidump, then reboot, install the guest additions, reboot and get the blue screen again but then it doesn't generate a new minidump, even though I know they are configured and should work since I was able to force a minidump before installing the guest additions.

However the vboxmanage command does allow the system to boot normally, even with the latest guest additions installed, however it seems to run slower.

comment:18 Changed 3 years ago by jmac9

I have the same problem with 3.2.10 with XPSP3 under Linux on a x64 AMD; except that it doesn't matter how many CPUs are configured or whether or not VT-x is enabled. Same BSOD; same values.

$ cat /proc/cpuinfo | grep "model name"
model name : AMD Athlon(tm) 7850 Dual-Core Processor

$ uname -a
Linux host 2.6.32-24-generic #43-Ubuntu SMP Thu Sep 16 14:58:24 UTC 2010 x86_64 GNU/Linux

$ dpkg -l | grep virtualbox
ii  virtualbox-3.2     3.2.10-66523~Ubuntu~lucid    Oracle VM VirtualBox
rc  virtualbox-ose     3.1.6-dfsg-2ubuntu2          x86 virtualization solution - base binaries
rc  virtualbox-ose-qt  3.1.6-dfsg-2ubuntu2          x86 virtualization solution - Qt based user 

comment:19 Changed 3 years ago by bpk

I tried again with the latest version (3.2.12) of the guest additions with the same results, installing guest additions and enabling more than 1 cpu results in bsod loop

comment:20 Changed 3 years ago by sandervl73

  • Summary changed from WinXP Pro OS crashes @ boot if GuestAdditions are installed (SMP) to WinXP crashes @ boot if GuestAdditions are installed (SMP - AMD cpu)

comment:21 Changed 3 years ago by sandervl73

  • Version changed from VirtualBox 3.1.2 to VirtualBox 3.2.12

comment:22 Changed 3 years ago by sandervl73

  • Summary changed from WinXP crashes @ boot if GuestAdditions are installed (SMP - AMD cpu) to WinXP crashes @ boot if GuestAdditions are installed (SMP/IO-APIC - AMD cpu)

comment:23 Changed 3 years ago by jmac9

I replaced my AMD Athlon II X2 CPU with an AMD Phenon II X6 CPU and the problem disappeared.

This is using the exact same hardware, software, and virtual images in both cases (expect the CPU).

There's something about the architecture on the Athlon CPU that VirtualBox implements incorrectly.

comment:24 Changed 2 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.1.6.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use