VirtualBox

Ticket #6030 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

additions: unresolved symbols in VBoxOGL.so

Reported by: hajma Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Solaris
Host type: Linux

Description

on a osol b130 box with additions from  http://www.greenviolet.net/articles/2010/01/19/vbox-additions-osol-130.gv installed (note the same was observed with vbox 2.2 onwards):

test@opensolaris:~$ ldd -r /usr/lib/VBoxOGL.so warning: ldd: /usr/lib/VBoxOGL.so: is not executable

VBoxOGLcrutil.so => /usr/lib/VBoxOGLcrutil.so libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 librt.so.1 => /lib/librt.so.1 libsocket.so.1 => /lib/libsocket.so.1 libgcc_s.so.1 => /usr/sfw/lib/libgcc_s.so.1 libc.so.1 => /usr/lib/libc.so.1 libX11.so.4 => /usr/lib/libX11.so.4 libXfixes.so.1 => /usr/lib/libXfixes.so.1 libXext.so.0 => /usr/lib/libXext.so.0 libnsl.so.1 => /lib/libnsl.so.1 libXau.so.6 => /usr/lib/libXau.so.6 libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 libmp.so.2 => /lib/libmp.so.2 libmd.so.1 => /lib/libmd.so.1 libscf.so.1 => /lib/libscf.so.1 libuutil.so.1 => /lib/libuutil.so.1 libgen.so.1 => /lib/libgen.so.1 libsmbios.so.1 => /usr/lib/libsmbios.so.1 symbol not found: XDamageDestroy (/usr/lib/VBoxOGL.so) symbol not found: XDamageCreate (/usr/lib/VBoxOGL.so) symbol not found: XDamageQueryExtension (/usr/lib/VBoxOGL.so) symbol not found: XDamageQueryVersion (/usr/lib/VBoxOGL.so) symbol not found: cos (/usr/lib/VBoxOGLcrutil.so) symbol not found: sin (/usr/lib/VBoxOGLcrutil.so) libm.so.2 => /lib/libm.so.2 libXevie.so.1 => /usr/lib/libXevie.so.1 libXss.so.1 => /usr/lib/libXss.so.1

because of this the KDE4 session in OpenSolaris crashes with

'Could not open library ksmserver: Cannot load library /opt/kde4/lib/libkdeinit4_ksmserver.so: (ld.so.1: kdeinit4: fatal: relocation error: file /usr/lib/libGL.so.1: symbol XDamageDestroy: referenced symbol not found)'

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #5297.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use