VirtualBox

Ticket #6018 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

opengl window covers other windows -> Fixed in SVN

Reported by: branco_ Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.2 Keywords: linux blender3d nvidia_propriatary_driver opengl_buffer ubuntu
Cc: Guest type: Linux
Host type: Linux

Description

Reproduce by :

install virtual box 3.1.2 PUEL on ubuntu 8.04 32 bit with nvidia proprietary drivers on intel core 2 quad q8200 , 4GB ram , nvidia 8800gt

install ubuntu 9.10 guest with 1GB memory , 3d acceleration enabled , installed guest additions

download and unpack blender 3d 2.49b - a one opengl heavy app that makes the bug visible - this is a very widely used program that doesn't have gross bugs on a widely used platform for it

start blender 3d from the binary in the unpacked folder and move to another workspace form the guest and back - everything ok - then move the cube on screen to force some opengl stuff by pressing middle mouse button and moving the mouse around , then move to other workspace - everything not ok : the opengl stuff shows on the other workspace .

This is a manifestation of a problem that makes some other software I use completely unusable in the guest . It would be easy to test on a non-proprietary driver or an ati driver to confirm that it is a problem with virtual box or the nvidia driver .

Change History

comment:1 Changed 4 years ago by branco_

The problem seems to be fixed in 3.1.6 even though there seems no activity related to my bug report . Probably one of the updates related to accelerated 3d support did the trick .

comment:2 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the update.

comment:3 Changed 4 years ago by branco_

  • Status changed from closed to reopened
  • Resolution fixed deleted

I have encountered the bug again and it looks like it is caused by the guest additions .

I created a new virtual machine still on top of ubuntu 8.04 32 bit on the same machine , but with a debian unstable guest . I have 3d enabled from the creation of the virtual machine . After installing from a debain testing iso and changing the repositores to unstable I download blender and it works , even without the guest additions which is odd according to the documentation that says I need the guest additions for 3d support . Then I install freecad and it works . And only then do I install the guest additions to get to have higher resolutions and instant mouse transition . That is when freecad misbehaves again as it did on the ubuntu 9.10 guest . Exactly the same behaviour . I didn't look at how blender was behaving but I imagine the same bad way . When I uninstalled the guest additions everything came back to normal .

The guest runs on kernel 2.6.32-3 right know and randr 1.2 or 1.3 - anyway latest debian unstable stuff .

I also tried to increase the video memory to the guest to have a higher resolution so I wouldn't need to lower the guest resolution but that didn't work . I would like to see higher resolutions in the default video driver for cases like this .

comment:4 Changed 4 years ago by leonid

  • Summary changed from opengl window covers other windows to opengl window covers other windows -> Fixed in SVN

comment:5 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use