VirtualBox

Ticket #5972 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VirtualBox x64 crashes trying to install Solaris8 32bit -> fixed in SVN/3.1.4

Reported by: dbeusee Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: Solaris
Host type: Windows

Description

Vb crashes pretty early on whlie copying the mini-root to the local disk. My host is Windows 7 x64 (rtm).

Attachments

VBox.png Download (10.3 KB) - added by dbeusee 4 years ago.
screenshot
VBox.log Download (179.5 KB) - added by dbeusee 4 years ago.
Log file

Change History

Changed 4 years ago by dbeusee

screenshot

Changed 4 years ago by dbeusee

Log file

comment:1 Changed 4 years ago by dbeusee

I tried different settings (IO APIC, PAE/NX, etc) but nothing worked.3.1.0 and 3.1.2 both failed. 2.2.4 can't even get to that point because there's some keyboard issue at the language prompt in the Solaris 8 installer. Pls advise.

comment:2 Changed 4 years ago by sandervl73

Try to turn on VT-x for the VM. I've added a check for the possible reason of the guru meditation.

comment:3 Changed 4 years ago by sandervl73

  • Summary changed from VirtualBox x64 crashes trying to install Solaris8 32bit to VirtualBox x64 crashes trying to install Solaris8 32bit -> fixed in SVN/3.1.4

Fix will be present in 3.1.4.

comment:4 Changed 4 years ago by michaln

Out of curiosity - which version of S8 was this exactly (which update), were you booting from the CD, and why were you using CD passthrough?

comment:5 Changed 4 years ago by dbeusee

Without passthrough, I get "cannot find boot.bin" error. With VT-x turned on, it hangs very early on (after saying "Running Configuration Assistant..."). This is the release that came out in April 2001. Do you have a patch I can try?

comment:6 Changed 4 years ago by michaln

OK, April 2001 should be Update 4/01 or S8U4. Not something we tried.

Yes, VT-x is known not to work with Solaris versions prior to S10U1 (i.e., before GRUB). AMD-V works.

And yes, S8 uses keyboard input code different from any other Solaris version (and just about every other OS on the planet), which is why the keyboard doesn't work right with VBox prior to 3.1.0.

Interesting about the passthrough; I know that Solaris boot CDs use somewhat unusual format, but we rarely use physical CDs. You might want to try creating an ISO image from your CD, in case there are problems either with the media or with the passthrough mode. Besides, booting/installing from ISO images is *so* much faster.

comment:7 Changed 4 years ago by dbeusee

It looks like the issue might be with passthrough mode, since making iso image seems to get around that issue. However, now, kdmconfig hangs during it's test no matter what I choose for the display and adaptor. It was unable to determine it automatically (it had unknown for both). I tried setting to many different possibilities. Now what?

comment:8 Changed 4 years ago by michaln

The X server does not run in the old Solaris versions without VT-x or AMD-V (and with VT-x, S8 won't boot at all). So you either have to run the VM without X or use an AMD box. S10U2 (or is that S10U1? not sure) and later don't have that problem.

BTW were there any problems at all during the ISO creation? The guru meditation could have been caused by transient read errors which weren't handled properly in passthrough mode.

comment:9 Changed 4 years ago by dbeusee

No problem creating the ISO at all. I had an older install of S8u4 on virtual pc - I managed to boot that single user and bring it up without X. I am disappointed that MS Virtual PC can run S8u4 better than VirtualBox can.

comment:10 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use