VirtualBox

Ticket #5887 (new defect)

Opened 4 years ago

Last modified 4 years ago

XP guest won't get an IP address from DHCP server

Reported by: kaptain1 Owned by:
Priority: minor Component: network
Version: VirtualBox 3.1.2 Keywords: dhcp network ubuntu xp
Cc: Guest type: Windows
Host type: Linux

Description

Hello.

Host: Ubuntu 9.10, Vbox 3.1.2 r56127 Guest: Windows XP SP3, bridged to wlan0 (wi-fi nic on hp dv2000 laptop)

Windows XP worked perfectly for a few months, then all of a sudden XP guest isn't able to receive an IP address from the Linksys router's dhcp server. Haven't changed anything, but 'maybe' Ubuntu update ran before it broke, not sure.

Tried switching different Vbox NIC controllers on XP guest. If i set static IP on the XP guest, I can ping LAN pcs and even surf the web for 5-10 seconds, but then Internet Connectivity stops. Can't ping public ips...

Thanks in advance!

Attachments

WinXP-2009-12-30-00-11-27.log Download (36.2 KB) - added by kaptain1 4 years ago.

Change History

Changed 4 years ago by kaptain1

comment:1 Changed 4 years ago by WTcIPv2Ers

Same issue here:

  • host: FreeBSD 7.2 release
  • VirtualBox: virtualbox-3.0.51.r22902_3 (compiled from FreeBSD ports) . bridged networking . <Adapter slot="0" enabled="true" MACAddress="005056280182" cable="true" speed="0"

type="Am79C973">

  • client: Windows XP SP3

tcpdump reveals that DHCP queries are sent by the client, and DHCP replies appear on the wire; however, they do not seem to be seen by the client.

Tried other adapter types too, no change in behavior.

comment:2 Changed 4 years ago by WTcIPv2Ers

A follow-up on the issue with FreeBSD:

I got it to work by *not* loading the vboxdrv, vboxnetflt, and vboxnetadp kernel modules during boot time but manually later.

Maybe there is an interaction with the FreeBSD firewall which is also loaded, or some other problem with the interaction of FreeBSD's network stack with the pseudo-network device of VirtualBox.

comment:3 Changed 4 years ago by kaptain1

Mine still doesn't work... I'm about to just reinstall Ubuntu and start over. Nobody really helps on this board?

comment:4 Changed 4 years ago by regeland

I can confirm this bug also on Xubuntu 9.10 and VirtualBox 3.1.2. I also examined the traffic, and although the XP guest sends the request and wlan0 on the host receives a response from the DHCP server, the wlan0 -> XP NIC seems to fail. Tried with various virtual NIC drivers in XP as well as the paravirtual driver.

comment:5 Changed 4 years ago by regeland

Forgot to add: When setting a static IP, GW, and DNS server in XP guest, all networking is fine. So I have to assume the problem lies with the UDP translation of DHCP packets somewhere in the linux VirtualBox networking stack?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use