VirtualBox

Ticket #5884 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

Cannot upgrade existing Fedora Linux VB install to 3.1 using 'rpm --upgrade' or 'yum update'

Reported by: daveu8282 Owned by:
Priority: minor Component: installer
Version: VirtualBox 3.1.2 Keywords: RedHat RPM
Cc: Guest type: other
Host type: Linux

Description

Prior to VB 3.1, the Fedora RPM's name was structured in such a way that "rpm -q VirtualBox" would return something like this:

VirtualBox-3.1.2_56127_fedora11-1.i586

but with the new VB 3.1 RPM, the full name is as follows:

VirtualBox-3.1-3.1.2_56127_fedora11-1.i586

and the short name includes the version number '3.1':

# rpm -q VirtualBox-3.1 VirtualBox-3.1-3.1.2_56127_fedora11-1.i586

The 'rpm' command provides an '--upgrade' option that allows the user to uninstall an older version and install a newer version in its place. With prior VirtualBox RPMs this feature worked, but the new naming convention makes it impossible to use '--upgrade'. Instead, this command sequence is necessary:

# rpm --erase VirtualBox

# rpm --install VirtualBox-3.1-3.1.2_56127_fedora11-1.i586.rpm

As a side effect, this naming change also breaks 'yum update VirtualBox' when the Sun VirtualBox Fedora repository is configured in /etc/yum.repos.d/.

Change History

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

This is not a bug but a feature. The reason is that some users might prefer to stay at VirtualBox version 3.0.x for some reason. We tried several times to build a smoother upgrade path but to my knowledge this isn't possible with rpm. See  here for the discussion.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use