VirtualBox

Ticket #5841 (closed defect: invalid)

Opened 4 years ago

Last modified 4 years ago

VBoxHeadless does not support '-p' anymore => fixed in 3.1.2

Reported by: ewb Owned by:
Priority: major Component: RDP
Version: VirtualBox 3.1.0 Keywords: VBoxHeadless RDP
Cc: Guest type: Windows
Host type: Linux

Description

starting a VM with 'VBoxHeadless --startvm "W2008srv" -p 13389' creates this output:


VirtualBox Headless Interface 3.1.0_OSE (C) 2008-2009 Sun Microsystems, Inc. All rights reserved.

Unknown option: -p

Usage:

.............


without the '-p' parameter I am unable to connect to the machine via 'rdesktop localhost'. I get:

ERROR: connect: Verbindungsaufbau abgelehnt (something like 'connection denied')

I'm running OpenSuSE 11.2 >> uname -a > "Linux gateway 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 x86_64 x86_64 x86_64 GNU/Linux"

The procedure was working well with OpenSuSE 11.1.

Attachments

VB-XP8-2009-12-26-09-32-04.log Download (46.0 KB) - added by ewb 4 years ago.
logfile

Change History

Changed 4 years ago by ewb

logfile

comment:1 Changed 4 years ago by klaus

  • Status changed from new to closed
  • Resolution set to invalid
  • Summary changed from VBoxHeadless does not support '-p' anymore to VBoxHeadless does not support '-p' anymore => fixed in 3.1.2

That's absolutely expected behavior, since VirtualBox OSE has no RDP support.

There was a bug parsing -p in the binary 3.1.0 packages, which is already fixed in 3.1.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use