VirtualBox

Ticket #5780 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VBoxNetFltNotify.dll does not unregister itself => Fixed in SVN

Reported by: mhanor Owned by:
Priority: minor Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: Windows

Description

This is an old issue, tested only with Windows XP SP3 as host. I've also tested the current version, 3.1.2.

Uninstalling VirtualBox always leaves behind the "VirtualBox Bridged Networking Driver Notify Object 1.0 Type Library" registry class (I don't know exactly what it's called).

Also, running "regsvr32 /u VBoxNetFltNotify.dll" doesn't unregister the dll.

example of what's left behind (regedit export):

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}\1.0]
@="VirtualBox Bridged Networking Driver Notify Object 1.0 Type Library"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}\1.0\0]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}\1.0\0win32]
@="C:\WINDOWS\system32\VBoxNetFltNotify.dll"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}\1.0\FLAGS]
@="0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\{1EA703AF-A150-4FDD-83DC-C07A7A460C7E}\1.0\HELPDIR]
@="C:\WINDOWS\system32\"

Change History

comment:1 Changed 4 years ago by mhanor

the "regsvr32 /u VBoxNetFltNotify.dll" command always displays the "DllUnregisterServer succeeded" message

comment:2 Changed 4 years ago by mhanor

it's still there, in 3.2.0 beta1

at the bottom of src/VBox/HostDrivers/VBoxNetFlt/win/notifyobj/VBoxNetFltNotify.cpp

STDAPI DllUnregisterServer(void)
{
    TraceMsg( L"DllUnregisterServer.\n");
    _Module.UnregisterServer();
    return S_OK;
}

shouldn't it be...?

STDAPI DllUnregisterServer(void)
{
    TraceMsg( L"DllUnregisterServer.\n");
    return _Module.UnregisterServer(TRUE);
}

comment:3 Changed 4 years ago by misha

  • Summary changed from VBoxNetFltNotify.dll does not unregister itself to VBoxNetFltNotify.dll does not unregister itself => Fixed in SVN

We have fixed the issue. The fix will be available in the next VBox release. Note that I kept the old

    _Module.UnregisterServer();
    return S_OK;

rather than

    return _Module.UnregisterServer();

for now to avoid possible regressions, because the latest mux sample from WDK does exactly the same, and I expect this could be done intentionally to avoid network filter uninstall failures caused by notify dll unregistration failures.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 3.1.8

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use