VirtualBox

Ticket #5778 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

supR3HardenedMainGetTrustedMain Error

Reported by: coto Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I have a error message when i put VirtualBox command with any user (even root)

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libSDL-1.2.so.0: cannot restore segment prot after reloc: Permission denied

Version: VirtualBox 3.1.3 (this version is not in ticket propierties) Host: Red Hat Enterprise Linux Server release 5.4 (Tikanga) Linux version 2.6.18-164.6.1.el5 (mockbuild@…) (gcc version 4.1.2 20080704 (Red Hat 4.1.2-46))

Change History

comment:1 Changed 4 years ago by frank

Which VBox package did you install from which source?

comment:2 Changed 4 years ago by coto

PUEL Version, I downloaded the file VirtualBox-3.1-3.1.0_55467_rhel5-1.i386.rpm from here....

 http://www.virtualbox.org/wiki/Linux_Downloads

I hope this answer your question!!

comment:3 Changed 4 years ago by frank

Yes, but this is version 3.1.0 (VBoxManage --version will tell you that as well).

Unfortunately I cannot reproduce your problem. I have CentOS 5.4 here, SELinux is enabled and installed VirtualBox 3.1.2 (just released). Installation was successful and saw not such problem.

comment:4 Changed 4 years ago by coto

VBoxManage --version => 3.1.0r55467

comment:5 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 3.2.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use