VirtualBox

Ticket #5771 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

OSX kernel panic in VBoxDrv.kext when starting virtual machines -> fixed in SVN/3.1.6

Reported by: poeml Owned by:
Priority: blocker Component: VMM/HWACCM
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

OSX 10.5.8, VirtualBox 3.1.0 (iMac Intel Core 2 Duo)

Since today, I get host kernel crashes when starting a virtual machine.

I haven't seen the problem so far, and have been using several different Linux VMs over weeks, with no problem.

Today, I resumed an old CentOS VM that had been suspended since June. The VM has thus been created with a VirtualBox version older than 3.1.0. When the resume started, I shortly saw some kind of scroll bar, and then the crash happened (forcing me to reboot my iMac). I'll attach the kernel backtrace below.

After rebooting, I tried this VM once more, and it resumed successfully (date was showing some day in June...), and seemed to work fine just fine.

When I then started another VM (that I had been using several times during the last days/weeks), I got the same crash again. That one had been shutdown, not suspended.

After another reboot, I tried it vice versa, and the crash happened when starting the second VM.

Therefore, I have the suspicion that when I start more then one VM, starting the second results in the crash - at least when the one CentOS image is involved.

I had been using several VMs simultaneously in the past, with no problem.

[I'm not sure what the right component is for this, thus I chose other (the default)]

Attachments

vbox-crash Download (11.4 KB) - added by poeml 4 years ago.
two kernel backtraces from the crash
VBox.log Download (30.6 KB) - added by poeml 4 years ago.
log from the CentOS VM
VBox.log.1 Download (30.3 KB) - added by poeml 4 years ago.
log.1 from the CentOS VM
VBox.2.log Download (52.7 KB) - added by poeml 4 years ago.
log from the other VM
R0014175.jpg Download (69.4 KB) - added by poeml 4 years ago.
Screenshot showing the state during the crash
Kernel_Panic_Logs_OS_X_10_6_2.txt Download (21.5 KB) - added by xabriel 4 years ago.
3 kernel panic logs from an OS X 10.6.2 machine
kernel_panic_log.txt Download (7.4 KB) - added by Comradin 4 years ago.
kernel panic log
vbox_log.txt Download (74.3 KB) - added by Comradin 4 years ago.
the vbox.log from one of the crashes

Change History

Changed 4 years ago by poeml

two kernel backtraces from the crash

Changed 4 years ago by poeml

log from the CentOS VM

Changed 4 years ago by poeml

log.1 from the CentOS VM

Changed 4 years ago by poeml

log from the other VM

comment:1 follow-up: ↓ 2 Changed 4 years ago by poeml

Ah; while trying to attach the log.2 from the other VM I noticed that Trac doesn't want it - because it's empty:

% l Library/VirtualBox/Machines/mbwork/Logs

total 328 -rw------- 1 peter staff 54005 17 Dec 03:56 VBox.log -rw------- 1 peter staff 0 17 Dec 03:49 VBox.log.1 -rw------- 1 peter staff 44271 17 Dec 03:13 VBox.log.2 -rw------- 1 peter staff 63197 9 Dec 00:21 VBox.log.3

comment:2 in reply to: ↑ 1 Changed 4 years ago by poeml

Sorry for the unreadable paste. It should look like this:

-rw-------  1 peter  staff  54005 17 Dec 03:56 VBox.log
-rw-------  1 peter  staff      0 17 Dec 03:49 VBox.log.1
-rw-------  1 peter  staff  44271 17 Dec 03:13 VBox.log.2
-rw-------  1 peter  staff  63197  9 Dec 00:21 VBox.log.3

The crashes happened around the following times: 3:17, 3:51, 3:57.

comment:3 Changed 4 years ago by poeml

It seems I can reproduce the crash reliably, by starting one of the two VMs and then the other.

The window for the second VM is created, it displays its title, and the OSX mouse cursor becomes a turning wheel, and while the window is still black the crash happens.

comment:4 Changed 4 years ago by poeml

No logfile is written.

Changed 4 years ago by poeml

Screenshot showing the state during the crash

comment:5 Changed 4 years ago by xabriel

I can confirm this bug, as it has manifested on my machine 3 times now. I have an Apple iMac i7 running OS 10.6.2. It always happens when I already have a VM running and I try to start another one. This might be relevant: the machines I was trying to boot had been newly imported from an OVF. They had the "Non-optimal settings detected" flag.

I'm attaching the 3 kernel panic logs.

Changed 4 years ago by xabriel

3 kernel panic logs from an OS X 10.6.2 machine

comment:6 follow-up: ↓ 10 Changed 4 years ago by xabriel

I just noticed that it doesn't matter if another VM is running or not. When I launch some specific VMs it crashes. One of the VMs was imported from an OVF made by VirtualBox. The other one is an OpenSolaris VM that I made from scratch.

Note that I am using the latest VirtualBox build 3.1.4 r57640.

comment:7 Changed 4 years ago by Comradin

I experience the same problem. Its just OS X 10.6.2 with VirtualBox 3.1.4

I try to install Windows XP SP2. Tried to change with different numbers of cpu cores assigned to the machine, reducing memory or virtual disk size.

Changed 4 years ago by Comradin

kernel panic log

comment:8 follow-up: ↓ 9 Changed 4 years ago by poeml

I (the original reporter) regularly update VirtualBox, and the problem went away for me with the next update or so. (Currently using 3.1.4 and no problem with that.) So the problem that I reported is definitely fixed for me.

comment:9 in reply to: ↑ 8 Changed 4 years ago by Comradin

Replying to poeml:

I (the original reporter) regularly update VirtualBox, and the problem went away for me with the next update or so. (Currently using 3.1.4 and no problem with that.) So the problem that I reported is definitely fixed for me.

I have a second machine here at the office with OS X 10.5.x and VirtualBox 3.1.4 and no problems. Unfortunately this is the machine of the boss. :(

Changed 4 years ago by Comradin

the vbox.log from one of the crashes

comment:10 in reply to: ↑ 6 Changed 4 years ago by Comradin

Replying to xabriel:

Note that I am using the latest VirtualBox build 3.1.4 r57640.

I've seen from your kernel panics tracelog, that your iMac has the same Model and CPU like the one Im having problems with.

I just kind of "solved" my problem by disabling the system option "Nested Pages". My xp host doesn't raise kernel panics any longer. Maybe this will help you, too.

comment:11 Changed 4 years ago by michaln

Unfortunately there seem to be at least two separate problems here... The original reporter's (poeml) system is a Core 2, so nested paging can't be a problem (not supported by that CPU).

A VBox.log from xabriel might help, as well as information whether turning off nested paging on xabriel's system made a difference or not.

comment:12 Changed 4 years ago by sandervl73

  • Summary changed from OSX kernel panic in VBoxDrv.kext when starting virtual machines to OSX kernel panic in VBoxDrv.kext when starting virtual machines -> fixed in SVN/3.1.6

comment:13 Changed 4 years ago by sandervl73

  • Component changed from other to VMM/HWACCM

comment:14 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use