VirtualBox

Ticket #5727 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Unable to delete snapshots with v3.1.0

Reported by: r0lZ Owned by: umoeller
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords: delete snapshot
Cc: Guest type: other
Host type: Windows

Description

Since v3.1.0, it is not possible any more to delete the snapshots. It is still possible to create a new snapshot and to restore it, but not to delete it. This bug is present in the GUI and in vboxmanage, with all Machines, and has been reported on the forum by several users:  http://forums.virtualbox.org/viewtopic.php?f=6&t=25397

It is easy to reproduce: in the main GUI, create a new snapshot. Then, immediately after, right-click the new snapshot and delete it. (It is not necessary to launch the virtual machine to change its state.) After the warning message, a new dialog appears with "Failed to delete the snapshot X of the virtual machine Y."

Same thing if the current state is modified or saved. The problem does not depend of the guest type.

Note that I have created two snapshots with v3.0.12. They cannot be deleted neither.

Attachments

VBox.log Download (71.8 KB) - added by preinkemeier 4 years ago.
Log file after trying to delete a snapshot
VirtualBox.xml Download (5.6 KB) - added by preinkemeier 4 years ago.
Virtualbox configuration file
dike-win.xml Download (92.5 KB) - added by preinkemeier 4 years ago.
configuration file of the virtual machine

Change History

comment:1 Changed 4 years ago by xr1140

i can confirm this bug

comment:2 follow-up: ↓ 3 Changed 4 years ago by flszen

I can reproduce this bug in 3.1.2 via vboxmanage. My specific situation deals with all three hard disk types.

Creating Hard Disks

kryon:~ flszen$ vboxmanage createhd --filename normal.vdi --size 4
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Disk image created. UUID: 6ac153aa-cacb-4340-93c7-80eb0694fc16
kryon:~ flszen$ vboxmanage createhd --filename writethrough.vdi --size 4 --type writethrough
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Disk image created. UUID: e0d54e64-9990-4083-a0a5-d58de8049b78
kryon:~ flszen$ vboxmanage createhd --filename immutable.vdi --size 4
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Disk image created. UUID: a742bbaf-3bda-4584-9c3c-3c5b2b6e741a

Opening Hard Disks and Setting Types

kryon:~ flszen$ vboxmanage openmedium disk immutable.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage openmedium disk writethrough.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage openmedium disk normal.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage modifyhd immutable.vdi --type immutableVirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage modifyhd writethrough.vdi --type writethrough
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Creating and Configuring Virtual Machine

kryon:~ flszen$ vboxmanage createvm --name Test --register
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Virtual machine 'Test' is created and registered.
UUID: 3ae45c3c-efb9-4add-a8e4-17b3d2e7464c
Settings file: '/Users/flszen/Library/VirtualBox/Machines/Test/Test.xml'

kryon:~ flszen$ vboxmanage storagectl Test --name ide --add ide
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage storageattach Test --storagectl ide --port 0 --device 0 --type hdd --medium normal.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage storageattach Test --storagectl ide --port 0 --device 1 --type hdd --medium writethrough.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

kryon:~ flszen$ vboxmanage storageattach Test --storagectl ide --port 1 --device 0 --type hdd --medium immutable.vdi
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Taking and Deleting Snapshot

kryon:~ flszen$ vboxmanage snapshot Test take TestSnapshot
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

kryon:~ flszen$ vboxmanage snapshot Test showvminfo Test
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.
...snip...
Name: TestSnapshot (UUID: 4db48382-5f41-4047-b544-4aa02d34daff) *

kryon:~ flszen$ vboxmanage snapshot Test delete 4db48382-5f41-4047-b544-4aa02d34daff
VirtualBox Command Line Management Interface Version 3.1.2
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...FAILED
Error: snapshot operation failed. No error message available!

comment:3 in reply to: ↑ 2 Changed 4 years ago by flszen

Replying to flszen: I initially thought this was the same bug, but it may be that I'm reproducing a different bug. The thread the description refers to is talking about how you can't refer to a snapshot by name to delete through vboxmanage (I use UUID in my test.). I'll keep an eye on this.

comment:4 Changed 4 years ago by void64

I also have this problem. Below is the output from a script I use to back up my VM:

VBoxManage ( taking new snapshot )
VirtualBox Command Line Management Interface Version 3.1.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

VBoxManage ( shutting down )
VirtualBox Command Line Management Interface Version 3.1.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%

VBoxManage ( discarding old snapshot )
VirtualBox Command Line Management Interface Version 3.1.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

ERROR: Argument aId is invalid (must be Guid(aId).isEmpty() == false)
Details: code E_INVALIDARG (0x80070057), component Console, interface IConsole,
callee IUnknown
Context: "DeleteSnapshot(guidSnap, pProgress.asOutParam())" at line 369 of file
VBoxManageSnapshot.cpp

VBoxManage ( starting VM )
VirtualBox Command Line Management Interface Version 3.1.0
(C) 2005-2009 Sun Microsystems, Inc.
All rights reserved.

Waiting for the remote session to open...
Remote session has been successfully opened.

comment:5 Changed 4 years ago by null

I'm encountering the same issue, but further testing I've noticed the I could not discard a snapshot if and only if there is an attached write-through disk. I have one disk with the OS that is immutable and a write-through disk where my project files are on.

comment:6 Changed 4 years ago by xr1140

3.1.2 - a VM with 2 hdds, one normal(system) and one immutable(temp) still can`t delete a snapshot

comment:7 Changed 4 years ago by preinkemeier

I am also experiencing the very same problem and error message as flszen. Log and configuration files follow...

Changed 4 years ago by preinkemeier

Log file after trying to delete a snapshot

Changed 4 years ago by preinkemeier

Virtualbox configuration file

Changed 4 years ago by preinkemeier

configuration file of the virtual machine

comment:8 Changed 4 years ago by preinkemeier

Note that this does NOT seem to be related to #6070 as even the following command does NOT work:
VBoxManage snapshot ece61632-b857-4bf1-9b82-cc62d106e406 delete c298da11-27d7-4f19-8ff7-4a8252f505b5

comment:9 Changed 4 years ago by r0lZ

I don't understand how it is possible that a major bug like this one has not yet been fixed, and even assigned to someone. I have downgraded my installation to v3.0.12 (the last usable version), but if there is no quick response to the problem, I think I will try another product. There are free alternatives that have better support.

comment:10 Changed 4 years ago by sandervl73

Works fine here. Threatening will not help your case.

Try the 3.1.4 beta mentioned in the forum.

comment:11 Changed 4 years ago by flszen

I just tried creating, doing a VM little execution, discarding state, and deleting a snapshot in 3.1.4 Beta 1. Still getting "Failed to delete the snapshot" message. This is still my VM with immutable and write-through disks attached.

comment:12 Changed 4 years ago by r0lZ

sandervl73, you are right, but the fact is that there has been 2 official releases and a beta since that bug has been reported, and it is still not fixed. It's a major problem for many of us. You're lucky if the bug doesn't happen on your system. I don't want to stay blocked with an obsolete version for ages, so I'm considering to try other products. That's not a threat, just a fact.

comment:13 Changed 4 years ago by sandervl73

There has been 1 (one) official release since 3.1.0 and it's not a generic problem with snapshots, but apparently one with multiple disks, immutable and/or write through images. So, no, I'm not lucky.

This bug tracker is free support on a best effort basis for a product we provide free of charge, so I'd appreciate if you tone down your comments a bit. The problem will be fixed in 3.1.4 if we can reproduce it. Fortunately some of your fellow reporters gave more detailed descriptions on how to actually do that.

comment:14 Changed 4 years ago by r0lZ

My previous post was an attempt to "tone down" my comments. I've said "you are right". Sorry if you misunderstood me. English is not my native language, and I am probably not subtle enough. The fact remains that this bug is a major problem for us, at least when it happens. What's wrong in noticing the fact?

I have tried to explain clearly how to reproduce the bug in my first post. I was not aware that it happens only with several discs. Luckily, the community has helped to narrow it. You can't blame me if I had not all elements to understand what happened.

I really hope someone will be able to fix the bug in v3.1.4 final, as I really like VBox, and I don't want to have to reinstall my virtual systems under another product. I sincerely wish you good luck.

comment:15 Changed 4 years ago by umoeller

  • Owner set to umoeller
  • Status changed from new to assigned

comment:16 Changed 4 years ago by r0lZ

Great news! Huge thanks to umoeller!

comment:17 Changed 4 years ago by umoeller

  • Status changed from assigned to closed
  • Resolution set to fixed

We believe to have a fix now. "Delete snapshot" only failed if a machine had immutable or writethrough disks attached and worked fine with normal images, which is why I guess the regression slipped through the cracks. We'll add this case to our test suite.

So, thanks for the bug report, although I have to agree 100% with Sander's remarks. Threats never help.

Now, we will probably release a second 3.1.4 beta this week, so if you all could test whether that fixes the issue for you, that would be great. Thanks!

comment:18 Changed 4 years ago by xr1140

this is great news! thank you!

comment:19 Changed 4 years ago by flszen

I am able to delete snapshots again with 3.1.4 Beta 2. Thank you very much!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use