VirtualBox

Ticket #5721 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Saving VM state triggers Out-Of-Memory killer

Reported by: therp Owned by:
Priority: major Component: VMM
Version: VirtualBox 3.1.0 Keywords: OOM saving
Cc: Guest type: Windows
Host type: Linux

Description

Saving my VM triggers the OOM for me.

My configuration is special with respect to two things: The VM state dump goes to an NFSv4 share, and the NFS share is connected via the interface the VM is bridged to network-wise.

I do have swap attached but it is totally unused. Under normal circumstances, the kernel should start swapping out if there is actually memory pressure, but for some reason it doesn't here, and starts the killing. That's my memory stats a few ms before the box freezes to ponder which thing to kill

             total       used       free     shared    buffers     cached
Mem:       6155480    3971364    2184116          0          0     930180
-/+ buffers/cache:    3041184    3114296
Swap:      3911672          0    3911672

What's really strange is that there is clearly memory left to allocate, but probably not below the mysterious <3GB DMA boundary (32 bit machine)

When I switch the network adapter from being bridged to eth0 to "Not attached" before suspend the VM, it seems to work.

I suspect that the VirtualBox bridging uses some kind of network filter to intercept packets to virtual adapter. I suspect that this filtering is the culprint here.

Attachments

kern.log-cut Download (33.7 KB) - added by therp 4 years ago.
kern.log - it starts with eth0 going out of promisc mode - a minute later you see the OOM in action
VBox.log Download (38.3 KB) - added by therp 4 years ago.
My VBox.log - interesting it succeed to suspend before I logged into win7 (presumably before starting guest tools)

Change History

Changed 4 years ago by therp

kern.log - it starts with eth0 going out of promisc mode - a minute later you see the OOM in action

comment:1 Changed 4 years ago by frank

Please attach the VBox.log file from this session.

Changed 4 years ago by therp

My VBox.log - interesting it succeed to suspend before I logged into win7 (presumably before starting guest tools)

comment:2 Changed 4 years ago by therp

I also forgot to mention that this is on 2.6.31.6 (ArchLinux version)

comment:3 Changed 3 years ago by frank

Still relevant with VBox 4.0.4?

comment:4 Changed 3 years ago by therp

No. Please close the bug. The interfaces goes out of promisc before going to sleep, and I don't see any OOM with my configuration. Thanks!

However, I found VirtualBox 4.0.4 to unstable otherwise, with apparently disk access randomly stopping. I am not yet sure what's the cause. I will do some research, and file a new bug in case I find out.

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback. Note that 4.0.4 has currently an issue with .vmdk snapshots and asynchronous I/O (#8408).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use