VirtualBox

Ticket #5713 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

WinXP guest (32 bit) on Win7 host (64 bit) crashes when accessing 3D features

Reported by: sbudde Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.2.4 Keywords: ig4icd64.dll, APPCRASH
Cc: Guest type: other
Host type: other

Description

Hi everybody,

I'm running a host with Windows 7 Home Premium (64 bit) with VBox 3.1.0.

The guest is a freshly installed Windows XP SP3 Professional (32 bit).

I turned on the 3D support in the machine settings and installed the guest additions (once in normal mode and after experiencing the crash also in save mode).

If I try to run dxdiag.exe in the guest, the whole guest instance crashes when dxdiag.exe is accessing the Direct3D features. After restarting the guest and rerunning dxdiag.exe, it askes wether it should attempt to use Direct3D or not, as it is aware of the crash (how convinient).

The Win7 host reports an APPCRASH with following details (roughly translated the description fields, as I am running a non-english Windows version) :

problem signature:
  problem event name:	APPCRASH
  application name:	VirtualBox.exe
  application version:	3.1.0.0
  application timestamp:	4b13a361
  error module name:	ig4icd64.dll
  error module version:	8.15.10.1855
  error module timestamp:	4a6f79ac
  exception code:	c0000005
  exception offset:	000000000003ee1f
  operating system version:	6.1.7600.2.0.0.768.3
  area scheme-ID:	1031
  additional info 1:	60ec
  additional info 2:	60ec1fa508d969f3b082b2d208deccd5
  additional info 3:	6bd7
  additional info 4:	6bd723dfa2b8a0c51a6e896518d59105

dxdiag.exe reports on the XP guest, that the files

d3d8.dll
d3d9.dlll

are outdated. These two are dated to 11/30/2009, so I assume these are the ones VBox has replaced to provide 3D support.

However, these files are listed as verion 3.01.xx, although all other DirectX files are listed with versions greater 5.x.

I don't know if this oddity has anything to do with the crash.

I'd be happy to provide any more information, e.g. minidumps ... I configered them to be written on each of the two systems, but there's nothing written. Any hints?

Best regards, Sven

Attachments

VBox.log Download (41.0 KB) - added by sbudde 4 years ago.
Guest log
VBox.2.log Download (40.9 KB) - added by JimmyJ 4 years ago.
File attached by JimmyJ
VBox.log.1 Download (40.7 KB) - added by walexand 4 years ago.
crashdata.txt Download (818 bytes) - added by SunCrushr 4 years ago.
Crash data from windows
Ubuntu_host_XP_Guest.log Download (64.9 KB) - added by FokkerCharlie 4 years ago.
windows xp-2010-06-24-17-40-49.log Download (50.2 KB) - added by frankp 4 years ago.

Change History

Changed 4 years ago by sbudde

Guest log

comment:1 Changed 4 years ago by sbudde

Addendum:

the end of the log file shows clearly that the crash occurs after OpenGL has been enabled:

<snip>
00:11:00.446 Switching Gl mode on
00:11:00.740 OpenGL Info: Render SPU: GL_VENDOR:   Intel
00:11:00.740 OpenGL Info: Render SPU: GL_RENDERER: Mobile Intel(R) 4 Series Express Chipset Family
00:11:00.740 OpenGL Info: Render SPU: GL_VERSION:  2.1.0 - Build 8.15.10.1855
00:11:00.740 OpenGL Info: Render SPU: GL_EXTENSIONS:
</snip>

The host's graphics is a Mobile Intel GMA 4500M, with Intel driver version 8.15.10.1855 from 07/28/2009.

comment:2 follow-up: ↓ 4 Changed 4 years ago by Grnch

Another confirmation here, it's not a freak occurence, it happens on my machine as well.

Host OS: Win7 Home Premium 64-bit Guest OS: WinXP SP2 32-bit Graphics card: Intel GMA 4500 VirtualBox version: 3.1.2

Guest additions were installed in Safe Mode from the start. I get the same crash in dxdiag as soon as it tries to initialize Direct3D. Same crash also happens when I start any Direct3D game. The log file also ends soon after "Switching Gl mode on", except that on mine it manages to actually list the GL_EXTENSIONS before crashing.

The common thread here seems to actually be the Intel GMA 4500 adapter, there is probably some incompatibility between the Intel GMA driver and the way VirtualBox accesses it. I don't think it's the host/guest OS combination that is the problem here, although I haven't yet had a chance to install VBox on another Win7 machine to confirm this.

comment:3 Changed 4 years ago by teermans

I, too, have the same issue. Discovered it when Alibre crashed my VM and get the same crash in dxdiag as soon as it tries to initialize Direct3D. Guest additions were installed in Safe Mode.

Host OS: Win7 Home Premium, Guest OS: WinXP Pro SP3, Display adapter: Mobile Intel 4 Series Express Chipset Family

Hope this helps.

comment:4 in reply to: ↑ 2 Changed 4 years ago by JimmyJ

HOST OS: Windows 7 Home premium, Guest OS: Windows XP SP2 , Intel 4500MHD, Display adapter: Mobile Intel 4 Series Express Chipset Family

Faced the same issue.

Did exactly as mentioned in docs to enable 3D Accelaration.

Some more info


Created an ISO bootable image of windows XP SP2 and created a VM (using VirtualBox) on a machine (HOST) running Windows XP SP2 and tried to enable 3D accelaration and it worked !! [The processor on this machine has Intel VT]

But when using the above ISO on another machine running Windows 7 32 bit Home premium, the issue mentioned issue in the ticket occurs. [The processor on this machine does not have Intel VT]

Changed 4 years ago by JimmyJ

File attached by JimmyJ

Changed 4 years ago by walexand

comment:5 Changed 4 years ago by walexand

I'm having the same issue where the host is Ubuntu, running the proprietary ATI/AMD FGLRX drivers.

In my case I can reproduce this on demand by simply expanding a particular folder in Visual Studio. Why that has anything to do with a call to GL is anyone's guess. Perhaps it's the 2D acceleration?

I've got a folder full of log files which end with "Switching Gl mode on".

comment:6 Changed 4 years ago by walexand

FYI, since turning off 2D acceleration the problem has not reoccurred.

comment:7 Changed 4 years ago by jem-rey

I'm having the issue on one computer but not the other. Both are running Windows 7 Professional 64-bit. The one having the problem has an Intel GMA 4500 onboard GPU. The other has a discrete PCI Express nVidia GTX 280 OCX. The virtual machine settings are the same on both.

comment:8 Changed 4 years ago by jem-rey

FYI, I'm using VirtualBox 3.1.4 r57640 and installed the Guest Additions in safe mode. The guest OS is Windows XP Professional SP3.

comment:9 Changed 4 years ago by techno.scavenger

Bump....

Same issue here...

Seems like this is common to W7 64 host. I am using VB 3.1.4. Guest was wxp sp3.

Changed 4 years ago by SunCrushr

Crash data from windows

comment:10 Changed 4 years ago by SunCrushr

Same issue here. Windows 7 x64 host, Intel GMA 4500 HD graphics card.

Crash details from windows attached.

comment:11 follow-up: ↓ 12 Changed 4 years ago by virtual_pommes

Same issue on VirtualBox 3.1.6 r59338 on Windows 7 x64 Host, ATI Radeon HD4600

Workaround: disable 2D video acceleration since disable 2D video acceleration the problem has not occurred.

comment:12 in reply to: ↑ 11 Changed 4 years ago by misha

Replying to virtual_pommes: What are the steps to reproduce in your case? Does the crash happen when:

  1. both 2D & 3D Acceleration are enabled
  2. only 3D is enabled
  3. only 2D is enabled
  4. neither 2D not 3D is enabled

comment:13 Changed 4 years ago by cyb

host: debian lenny 5.1.4 64bit, guest: Win XP SP2 32bit, graphics: Intel GMA 4500 HD guest crashes when 1) both 2D & 3D Acceleration are enabled 2) only 3D is enabled

comment:14 Changed 4 years ago by thomasn

I have the same problem on my machine: Windows 7 x64 host with a Windows XP x86 virtualbox. Does not crash with 2d support enabled. It crashes when 3d support is enabled. Tried 3.1.6 and 3.1.8 with the same result.

comment:15 Changed 4 years ago by thomasn

I just tried with the same problem on version 3.2.0 r61806.

comment:16 Changed 4 years ago by leonid

Please retry with 3.2.2, as there's a fix for 64bit hosts.

comment:17 Changed 4 years ago by leonid

  • Summary changed from WinXP guest (32 bit) on Win7 host (64 bit) crashes when accessing 3D features to WinXP guest (32 bit) on Win7 host (64 bit) crashes when accessing 3D features -> Fixed in SVN.

comment:18 Changed 4 years ago by JimmyJ

My host machine is a Win7 32 bit and have the issue, I will try with the 3.2.2 but not sure whether it will help.

comment:19 Changed 4 years ago by thomasn

I'll be happy to try 3.2.2. When will the download become available?

comment:20 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:21 Changed 4 years ago by thomasn

  • Status changed from closed to reopened
  • Resolution fixed deleted

I tried with version 3.2.2 r62298 and I still have the same problem. I've tried with XP sp2 and XP sp3 with the exact same result.

comment:22 Changed 4 years ago by techno.scavenger

Issue not fixed, Windows XP SP3 guest still crashing when dxdiag is run.

Host: Windows Home Premium 64bit/Intel Quad Core

Please let me know if you need more information.

Changed 4 years ago by FokkerCharlie

comment:23 Changed 4 years ago by FokkerCharlie

Same issue remains with Ubuntu 10.04 64-bit host, WinXP guest.

Just updated to 3.2.4, problem remains.

Log attached

comment:24 Changed 4 years ago by frank

  • Summary changed from WinXP guest (32 bit) on Win7 host (64 bit) crashes when accessing 3D features -> Fixed in SVN. to WinXP guest (32 bit) on Win7 host (64 bit) crashes when accessing 3D features

Please: Could you verify which settings has to be enabled to get this crash? Does it crash if

  • both 2D and 3D are disabled
  • only 3D is enabled
  • only 2D is enabled
  • only if 2D plus 3D is enabled

?

comment:25 Changed 4 years ago by thomasn

  • both 2D and 3D are disabled -- No Problems
  • only 3D is enabled -- Crashes when trying to run dxdiag. If you bypass the direct3d check dxdiag works fine.
  • only 2D is enabled -- no problems
  • only if 2D plus 3D is enabled -- Crashes when trying to run dxdiag. If you bypass the direct3d check dxdiag works fine.

comment:26 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.1.0 to VirtualBox 3.2.4

Thanks for this confirmation.

comment:27 Changed 4 years ago by frankp

I just wanted to also confirm this.

I am using VirtualBox 3.2.4 with a WinXP 32 bit guest and Win7 64 bit host.

My log is attached.

Changed 4 years ago by frankp

comment:28 Changed 4 years ago by aktai

I also have this bug, with both 3D and 2D enabled and with just 3D enabled. It crashes when I try to test DX8 or DX9 through dxdiag. I have done two installs, the first I did wined3d in safe mode and GA in normal mode, then GA in safe mode. The second was with the correct instructions: GA in safe mode and no wined3d. Both crash the same way.

My display adapter is Mobile Intel(R) 4 Series Express Chipset Family with driver version 8.15.10.2086 (02/20/2010) and I'm using Windows 7 Pro as a host, with Windows XP SP2 as the guest. It crashes when the guest has 8 MB video memory, 12 MB and 128 MB (haven't tested others).

00:01:47.160 OpenGL Info: Render SPU: GL_VENDOR:   Intel
00:01:47.160 OpenGL Info: Render SPU: GL_RENDERER: Mobile Intel(R) 4 Series Express Chipset Family
00:01:47.160 OpenGL Info: Render SPU: GL_VERSION:  2.1.0 - Build 8.15.10.2086
00:01:47.160 OpenGL Info: Render SPU: GL_EXTENSIONS: GL_EXT_blend_minmax [and 81 more GL_ prefixed items, cut off to save space]

comment:29 Changed 4 years ago by aktai

Oh, also my host is Windows 7 Professional x32 (not x64 as the bug description says)

comment:30 Changed 3 years ago by sunlover

Could you please try to install latest host graphics driver? A similar crash in ig4icd64.dll was fixed by updating the driver. See  http://www.virtualbox.org/ticket/8316

comment:31 Changed 3 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

No response, closing.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use