VirtualBox

Ticket #5710 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

[Regression] 3D support: Celestia renders textures incorrectly

Reported by: Technologov Owned by:
Priority: major Component: 3D support
Version: VirtualBox 3.1.4 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Celestia, Open-Source OpenGL application renders textures incorrectly with VBox 3.1.0 additions. It worked fine with 3.0.10.

Host: Windows Vista 32-bit, Core 2 P8600, NVIDIA GeForce 9700M GTS, VBox 3.1.0

Guest: Windows XP

It looks like a regression in OpenGL component.

-Technologov, 9.12.2009.

Attachments

Windows XP-2010-01-25-19-19-49.log Download (41.2 KB) - added by Technologov 4 years ago.
XP-on-XP VBox Log, Intel GPU
Celestia-Earth.PNG Download (291.9 KB) - added by Technologov 4 years ago.
Celestia-Earth.PNG -- correct rendering
Celestia-Earth-broken.PNG Download (114.4 KB) - added by Technologov 4 years ago.
Celestia-Earth-broken.PNG -- incorrect rendering, VBox 3.1.0
XP-on-Vista-NVIDIA.log Download (65.9 KB) - added by Technologov 4 years ago.
XP-on-Vista VBOX log NVIDIA GPU, VBox 3.1.2
Celestia-Earth-broken2.png Download (63.7 KB) - added by Technologov 4 years ago.
Celestia-Earth-broken2.png screenshot on NVIDIA
Windows XP 3D-2010-01-29-12-43-41.log Download (41.3 KB) - added by Technologov 4 years ago.
XP-on-XP VBox Log, ATI GPU, VBox 3.1.4-BETA1

Change History

comment:1 Changed 4 years ago by Technologov

This bug looks related to bug #5720

-Technologov

comment:2 Changed 4 years ago by Technologov

Any news on this one ?

-Technologov

comment:3 Changed 4 years ago by leonid

I've checked it on winxp/winxp combo with latest vbox and it looks correct. Could you post a screenshot of corrupted textures please and steps to reproduce...as this app features alot of objects...and manually checking em one by one will take a while :)

Changed 4 years ago by Technologov

XP-on-XP VBox Log, Intel GPU

Changed 4 years ago by Technologov

Celestia-Earth.PNG -- correct rendering

Changed 4 years ago by Technologov

Celestia-Earth-broken.PNG -- incorrect rendering, VBox 3.1.0

comment:4 Changed 4 years ago by Technologov

Correct rendering can be observed on host, or in guests in 3.0.10.

Incorrect rendering can be observed in VBox 3.1.0/3.1.2 guests, with Intel/ATI/NVIDIA GPUs.

-Technologov

comment:5 Changed 4 years ago by Technologov

Steps to reproduce: "Start Celestia", and wait 5 seconds so it moves to "Earth".

comment:6 Changed 4 years ago by leonid

Hm, it works ok here still. Although on ATI/NVidia GPUs. It seems to be an issue with older cards, like intel with opengl 1.4 you have.

comment:7 Changed 4 years ago by Technologov

I have this problem on NVIDIA and ATI GPUs too... on both XP and Vista 32bit Hosts.

Changed 4 years ago by Technologov

XP-on-Vista VBOX log NVIDIA GPU, VBox 3.1.2

Changed 4 years ago by Technologov

Celestia-Earth-broken2.png screenshot on NVIDIA

comment:8 Changed 4 years ago by Technologov

I have attached logs and screenshot to show how it looks like on NVIDIA.

comment:9 Changed 4 years ago by Technologov

3.1.4 BETA1 looks the same as "Celestia-Earth-broken.PNG" on ATI GPU.

Host: Windows XP, Core 2, ATI Radehon HD 3850, VBox 3.1.4-BETA1.

Guest: Windows XP, VBox 3.1.4-BETA1 GA installed.

-Technologov

Changed 4 years ago by Technologov

XP-on-XP VBox Log, ATI GPU, VBox 3.1.4-BETA1

comment:10 Changed 4 years ago by Technologov

Problem still exists with VBox 3.1.4 (final, r57640). I have reinstalled GA.

Host: Windows Vista 32-bit, Core 2 P8600, NVIDIA GeForce 9700M GTS, VBox 3.1.4

-Technologov

comment:11 Changed 4 years ago by frank

  • Version changed from VirtualBox 3.1.0 to VirtualBox 3.1.4

comment:12 Changed 4 years ago by Technologov

This problem is still true as of VBox 3.2.0-BETA1.

comment:13 Changed 4 years ago by Technologov

Problem exists in VBox 3.2.0; This is a regression vs 3.0.10.

-Technologov

comment:14 Changed 4 years ago by Technologov

v3.2.8. Fixed, Verified.

-Technologov

comment:15 Changed 4 years ago by Technologov

FIXED in 3.2.8

comment:16 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use