VirtualBox

Ticket #5700 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

SATA fails on Centos 4.8 guest

Reported by: litz Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.1.0 Keywords: SATA CENTOS
Cc: Guest type: Linux
Host type: Linux

Description

SATA does not work on Centos 4.8 guests .... kernel fails to ID and mount the drives - no panic, but definitely a driver failure.

Same exact configuration under Centos 5 works fine.

Reproducible using LiveCD isos and/or install CDs (boot into rescue mode).

Setup is easy - create a redhat vbox, assign 1 hdd to the SATA controller, and boot the appropriate CD. 4 will crash during boot.

See attached picture for an attempt mounting some SATA drives using the Centos 4.8 boot CD

vbox log files should not be necessary since this is such a basic failure, but will be provided if requested.

Attachments

satafail.jpg Download (142.2 KB) - added by litz 4 years ago.
SATA errors

Change History

Changed 4 years ago by litz

SATA errors

comment:1 Changed 4 years ago by litz

Update please?

This has been open 2 weeks with NO response from development.

This is a BIG HUGE issue for anyone using RH EL4/Centos 4, since the SATA driver is completely unusable.

Please advise.

comment:2 Changed 4 years ago by aeichner

I can reproduce this issue. Seems that the guest uses the BIOS to detect the SATA disks because it works as soon as I disable BIOS emulation but than I can't boot from the disk anymore. Will look into this issue in one of the next days.

comment:3 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use