VirtualBox

Ticket #5697 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Screen resolutions above 1600x1200 cause X in guest to crash in CentOS 5.3 amd64

Reported by: moasat Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Setting any video mode with a width of 1920 (1920x1200 or 1920x1080) causes X in the guest OS to crash. I am unable to retrieve the Xorg.0.log file from the machine but I can see what appears to be a kernel crash on the console.

Host and guest are both CentOS 5.3 amd64.

I can see part of the stack trace from the crash. It appears to go:

/usr/lib64/xorg/modules/libramdac.so
/usr/lib64/xorg/modules/libvbe.so
/usr/lib64/xorg/modules/libvbe.so
/usr/lib64/xorg/modules/libvbe.so
/usr/lib64/xorg/modules/libfb.so
/usr/lib64/xorg/modules/libfb.so
/usr/lib64/xorg/modules/libfb.so
/usr/lib64/xorg/modules/libshadowfb.so
/usr/lib64/xorg/modules/libshadowfb.so
/usr/lib64/xorg/modules/libshadowfb.so
[stack]
[vdso]

I'm sure there's more but it scrolls off the screen and I can't retrieve it.

Here is the xorg.conf I'm trying to use:

# VirtualBox generated configuration file
# based on /etc/X11/xorg.conf.
# Xorg configuration created by system-config-display

Section "InputDevice"
  Identifier   "Keyboard[0]"
  Driver       "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
  Option       "Protocol" "Standard"
  Option       "CoreKeyboard"
EndSection

Section "InputDevice"
  Identifier  "Mouse[1]"
  Driver      "vboxmouse"
  Option      "Buttons" "9"
  Option      "Device" "/dev/input/mice"
  Option      "Name" "VirtualBox Mouse"
  Option      "Protocol" "explorerps/2"
  Option      "Vendor" "Sun Microsystems Inc"
  Option      "ZAxisMapping" "4 5"
  Option      "CorePointer"
EndSection

Section "ServerLayout"
  Identifier   "Layout[all]"
  InputDevice  "Mouse[1]" "CorePointer"
  Option       "Clone" "off"
  Option       "Xinerama" "off"
  Screen       "Screen[0]"
EndSection

Section "Monitor"
  Identifier   "Monitor[0]"
  ModelName    "VirtualBox Virtual Output"
  VendorName   "Sun Microsystems Inc"
EndSection

Section "Device"
  BoardName    "VirtualBox Graphics"
  Driver       "vboxvideo"
  Identifier   "Device[0]"
  VendorName   "Sun Microsystems Inc"
EndSection

Section "Screen"
  SubSection "Display"
    Depth      24
    Modes "1920x1200"
  EndSubSection
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"
EndSection

Attachments

VBox.log Download (49.9 KB) - added by moasat 4 years ago.
Log file
CentOS 5.3 64-Bit Developers Machine.xml Download (6.9 KB) - added by moasat 4 years ago.
Virtual Machine configuration file

Change History

Changed 4 years ago by moasat

Log file

Changed 4 years ago by moasat

Virtual Machine configuration file

comment:1 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Cannot reproduce. Please reopen if still relevant with VBox 3.2.6 (including the corresponding guest additions).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use