VirtualBox

Ticket #5674 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

BSOD when USB & Uniprocessor HAL * VT-x/AMD-V

Reported by: MarkCranness Owned by:
Priority: major Component: other
Version: VirtualBox 3.1.0 Keywords: BSOD ntoskrnl stop usb
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

Enabling USB on an existing Windows VM that did not have USB enabled causes a BSOD on the second boot after Windows has installed USB drivers.

Affects 3.1.0 r55467. The same steps do not affect 3.0.10 or 3.0.12 (There are other similar reports on Windows XP guests, but presumably on VMs that always has USB; they will not boot anymore.)

Reproduce:

Windows 2000 Server VM with NO USB controllers OR drivers installed: 'set devmgr_show_nonpresent_devices=1& start devmgmt.msc' and Uninstall any USB controllers with Device Manager.

Enable USB in VirtualBox and boot VM. Windows recognizes USB and installs drivers. Shutdown and reboot gives BSOD as below:

*** Stop: 0x0000001E (0xC0000005,0x8046ACC8,0x00000000,0x00000000)
KMODE_EXCEPTION_NOT_HANDLED
*** Address 8046ACC8 base at 80400000, DateStamp 4a781d9e - ntoskrnl.exe

... BSOD occurs (80%+ of the time) when all of these conditions are true:

  • Uniprocessor version of ntoskrnl.exe in use.
    This means 'ACPI Uniprocessor PC' HAL or 'Advanced Configuration and Power (ACPI) PC' HAL.
    (When 'ACPI Multiprocessor PC' HAL is installed, ntoskrnl.exe == ntkrnlmp.exe, and boot is OK.)
  • USB host controllers recognised in Device Manager and drivers installed.
  • Guest Additions installed. 3.0.10 or 3.1.0 beta1,2,3,release does not matter: they all BSOD.
    (If Guest Additions are not installed then boot is OK.)

Because VT-x/AMD-V is involved, my CPU might be significant: Intel Core 2 Duo E8400 E0.

Logs and more description here:  http://forums.virtualbox.org/viewtopic.php?f=15&t=24753

Change History

comment:1 Changed 4 years ago by MarkCranness

Happens with 3.1.2 also.

comment:2 Changed 4 years ago by frank

  • Description modified (diff)

comment:3 Changed 4 years ago by MarkCranness

Retested in 3.2.0, and is now fixed; enabling USB as above and the VM can install USB devices and reboot (3+ times) with no BSOD.

comment:4 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use