VirtualBox

Ticket #5672 (reopened defect)

Opened 4 years ago

Last modified 3 years ago

Mouse scrolling too fast (pageup/pagedown triggered) -> Fixed in SVN

Reported by: gionn Owned by:
Priority: major Component: guest additions
Version: VirtualBox 3.1.0 Keywords: mouse
Cc: Guest type: Linux
Host type: Mac OS X

Description

Hi,

after upgrading on MacOSX host to VirtualBox 3.1.0, both with Debian Lenny and Ubuntu Karmic guest, the mouse scrolling with the mouse wheel (central button) or with the two-finger touchpad scrolling is hardly usable:

  • when I do a single, slow, scroll, it works correctly, like pressing down arrow key;
  • when I do a fast scroll, it seems that get triggered a pageup/pagedown instead of some down arrow key;

Change History

comment:1 Changed 4 years ago by vila

Confirmed here whatever mouse is used (I first suspected the Apple magic mouse but a regular mouse exhibit the same, painful, behavior), the fix for  http://www.virtualbox.org/ticket/5049 is probably related.

host: OSX 10.6 guest: Ubuntu 9.10

comment:2 Changed 4 years ago by vila

I failed to mention that the *cursor* is moved which is the main source of problems since the target of the events is changed accordingly (irritating targets include: the tab line in FireFox while scrolling a page, the top applet in Ubuntu almost always (since after several jumps the cursor ends up there)).

This is also timing dependent as it doesn't occur on all uses of the scroll wheel.

Finally, the cursor sometimes comes back to its original position (which presumably explains the timing dependency above).

comment:3 Changed 4 years ago by gionn

If on Mac Host the Scrolling Speed is set to the minimum under System Preferences -> Mouse, the scrolling with central button in the guest became correct.

comment:4 Changed 4 years ago by vila

@gionn: Close, very close, but no cigar.

The bug occurs less often with the scrolling speed set to the minimal value, but it's still there when scrolling fast enough.

My regular mouse doesn't trigger it anymore, but the Apple magic mouse triggers it at will.

If there any setting that can activate some debug option to provide more detailed info, just tell me, this bug is really annoying even with gionn's workaround.

comment:5 Changed 4 years ago by vila

More observations:

  • the first scroll wheel event moves the cursor,
  • slightly moving the mouse brings the cursor back to its original position (modulo the move)

So, some code, somewhere, may be sending a spurious event (motion cursor).

comment:6 Changed 4 years ago by d0b33

I suspect it's related to my ticket...  http://www.virtualbox.org/ticket/5749

comment:7 Changed 4 years ago by poetzsch

  • Summary changed from Mouse scrolling too fast (pageup/pagedown triggered) to Mouse scrolling too fast (pageup/pagedown triggered) -> Fixed in SVN

Fixed in the next minor update of VirtualBox.

comment:8 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:9 in reply to: ↑ description Changed 4 years ago by vila

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry guys, but it's still not fixed :-/

Well, it's fixed only when Mouse Integration is enabled, it's the same as before otherwise (motion events, mouse cursor jumping, focus changed, nightmare).

My problem is that I need to enable mouse integration (even when working full screen) because otherwise I run into compatibility problems with synergy (I'm pretty sure there is another old bug about that but I can't find it).

comment:10 Changed 4 years ago by vila

Grr, I need to *disable* mouse integration of course.

And I found the bug:  http://www.virtualbox.org/ticket/3880

So for me it's either no scroll wheel or no shared mouse/keyboard :-/

Please, fix at least one of these :)

comment:11 Changed 4 years ago by poetzsch

Not sure if you understand correctly. You tried 3.1.2, right? This doesn't work for you in general or only when synergy is enabled?

comment:12 Changed 4 years ago by vila

I use 3.1.2 right now.

synergy is related *for my use case* but the behavior is the same whether I activate it or not.

If I enable Mouse Integration:

  • this bug (5672) is fixed,
  • I can't use synergy (3880),

If I disable Mouse Integration:

  • this bug (5672) is *not* fixed (same behavior as before),
  • I can use synergy.

If can help debugging or even fixing the problem just don't hesitate to ask, I use the same nick on IRC at #freenode so you can even ping there during european business hours.

comment:13 Changed 4 years ago by vila

More concretely, I encounter the problem on OSX host only, so my proposal for help can is in fact: how can I get a trace of the mouse events. Either the one received by vbox or the ones emitted by vbox and more probably both.

As an additional data point: when I use the Apple magic mouse, even with scrolling preference set to the minimal value, the cursor movements are bigger than with my other mouse. I.e. with the regular mouse the cursor jumps from say, a quarter of the screen (24" so 1920x1200) for a single scroll event (as much as I can judge with only a visual feedback) while with the magic mouse it seems to jump half of the screen.

Of course the jumps makes it impossible to use xev in the guest to further analyze the behavior.

Hence my question: cann you give me pointers on how to get some xev-like output from xbox ?

comment:14 Changed 4 years ago by kurtraschke

I am observing the following behavior with VirtualBox 3.1.2 on Mac OS X 10.6.2:

Regardless of guest platform (this happens on Xubuntu, Windows XP, and Windows 7):

-with mouse integration off, scrolling either with a mouse scroll wheel or two-finger scrolling on the trackpad is erratic and results in the pointer jumping vertically

-with mouse integration on, scrolling using two-finger scrolling on the trackpad works normally, but scrolling with a mouse scroll wheel is erratic - the pointer does not move vertically, but the scrolling is very sluggish

comment:15 Changed 4 years ago by henry74

I have a similar issue when using a Linux Host and a Windows XP guest AFTER upgrading to the latest version of VirtualBox.

Scoll speed is erratic and sometimes uncontrollable - it jumps around as it thinks I am scrolling up and down quickly. I find if I move the trackpointer to the upper right or lower left, it scrolls correctly so it appears the axises are off somehow.

It used to work perfectly before the recent update.

comment:16 Changed 4 years ago by lazylady

Ever since 3.1.x the two-finger-scrolling from a MacBook trackpad have been very slow and erratic. Up until 3.0.12 this was working great. I've been searching a lot regarding this matter and came up very short.

Host: OS X 10.6 Guest: Windows XP

comment:17 Changed 4 years ago by vila

Still present in 3.1.8 when mouse integration is disabled.

This bug has become critical with 3.2.0 since the 'Disable Mouse Integration' menu item is now greyed out.

Can you please consider re-opening this bug or should I file a new one ?

Note that there is  http://www.virtualbox.org/ticket/6714 about the mouse integration but disabling mouse integration was only a *workaround*, the fact that it's not possible to use it in 3.2.0 just makes the problem worse (i.e. I had to revert to 3.1.8 :-( ).

comment:18 Changed 3 years ago by celsius1414

Happening currently for me as well in 3.2.10.

  • MacBook Pro 6,2
  • Mac OS X Snow Leopard 10.6 host
  • Ubuntu Maverick Meerkat 10.10 guest
  • Macally USB iOptinet wired mouse with scrollwheel (as well as Magic Mouse and Trackpad).
  • Only happens when Mouse Integration is disabled.
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use