VirtualBox

Ticket #5666 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

close > save state > restart - leads to deactivating port forwards

Reported by: codemedic Owned by:
Priority: major Component: network/NAT
Version: VirtualBox 3.1.0 Keywords: nar portforward linux
Cc: Guest type: Linux
Host type: Linux

Description

When I close a VM with port-forwards setup, and opt to save state. Then when I restart the VM, the portforwards are inaccessible from the Host machine.

Attachments

VBox.log.tar.bz Download (19.8 KB) - added by codemedic 4 years ago.
( tar + bz2 )ed log files

Change History

comment:1 follow-up: ↓ 2 Changed 4 years ago by frank

Sounds like a duplicate of #5654.

comment:2 in reply to: ↑ 1 Changed 4 years ago by codemedic

It isnt similar to #5654 Mine does work normally. The bug I reported gets triggered only after closing with "save state" option, which is then restarted from the saved state. If I shutdown and power off the VM normally; it does work on the next restart.

Sounds like some sort of skipped initialisation on waking up from saved state.

Replying to frank:

Sounds like a duplicate of #5654.

comment:3 Changed 4 years ago by frank

It sounds like that bug anyway. Because in #5654, the user does static IP assignment in the guest, and after suspend / resume, you have a static IP assignment as well (because your guest still uses the old DHCP lease).

comment:4 Changed 4 years ago by codemedic

In my case, I use DHCP, and before I closed the VM it was 10.0.2.15 and it remained the same when I restarted the VM. Same with the IP for the host machine from the VM ( 10.0.2.2 ). I am using NAT by the way!

When I restarted, outward connections from the VM is still working. Only the port-forwarding is broken.

comment:5 Changed 4 years ago by codemedic

Sorry frank

You do have a case here.

My guest OS is Slackware 9.1 ( pain ... ) So once restarted, if I go in and do the below, it gets sorted.

ifconfig eth0 down ifconfig eth0 up dhcpcd -t 10 -h <hostname> -d eth0

comment:6 follow-up: ↓ 7 Changed 4 years ago by codemedic

More precisely

/sbin/ifconfig eth0 down
killall dhcpcd
/sbin/ifconfig eth0 up
/sbin/dhcpcd -t 10 -h dkorah-v3-uk -d eth0

comment:7 in reply to: ↑ 6 ; follow-up: ↓ 8 Changed 4 years ago by Hachiman

Replying to codemedic: The way I'm doing fix for #5654 should fix this issue as well, because they have the same root. But could you please add a log file that will help me offer right bits to test.

comment:8 in reply to: ↑ 7 ; follow-up: ↓ 9 Changed 4 years ago by codemedic

Replying to Hachiman:

Could you please be a bit more specific on the log file you are interested in. I am pretty new to VirtualBox

comment:9 in reply to: ↑ 8 Changed 4 years ago by Hachiman

Replying to codemedic:

Replying to Hachiman:

Could you please be a bit more specific on the log file you are interested in. I am pretty new to VirtualBox

sure, they're placed at ~/.VirtualBox/Machines/[your-vm-name]/Logs I need any one of them. Thank you.

Changed 4 years ago by codemedic

( tar + bz2 )ed log files

comment:10 Changed 4 years ago by Hachiman

Thank you, will provide you debug bits for ubuntu 9.04/32 later today.

comment:11 Changed 4 years ago by Hachiman

Could you please verify if  http://www.virtualbox.org/download/testcase/VBoxDD.so.5666.debug.fix fixes problem for you? please replace VBoxDD.so in your installation directory with binary above. Please don't forget save original in the safe place.

comment:12 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use