VirtualBox

Ticket #5655 (closed defect: fixed)

Opened 4 years ago

Last modified 7 months ago

Full-screen guest applications corrupt host screen when VM is in seamless mode => fixed in SVN

Reported by: Technologov Owned by:
Priority: major Component: GUI/seamless
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: other

Description (last modified by frank) (diff)

Host1: RHEL 5.3/x64, Core 2 P8600, VBox 3.1.0.

Host2: Windows Vista, 32-bit, Core 2 P8600, VBox 3.1.0.

Guest: Windows XP

When a Windows VM is in seamless mode, and some application enters full-screen mode in VM, it starts rendering garbage on host's screen. After an app exists, seamless mode restores.

Expected behavior: VM must exit seamless mode, when any application asks Full-Screen. VM must become windowed application.

-Technologov, 03.12.2009.

Attachments

Windows XP Full 3D-2009-12-03-12-58-25.log Download (46.9 KB) - added by Technologov 4 years ago.

Change History

Changed 4 years ago by Technologov

comment:1 Changed 4 years ago by Technologov

Examples: "Heroes of Might and Magic III" and "TuxRacer"

comment:2 Changed 4 years ago by Technologov

Another example: Windows 7, which asks to close applications.

See:  http://forums.virtualbox.org/viewtopic.php?f=1&t=25311&p=113860#p113860

-Technologov

comment:3 follow-up: ↓ 4 Changed 4 years ago by Technologov

Can you please take a look at it ?

comment:4 in reply to: ↑ 3 Changed 4 years ago by misha

Replying to Technologov: I've reproduced the problem, it is reproducible with 3.0.x as well. We'll have a look into this.

comment:5 follow-ups: ↓ 6 ↓ 7 Changed 4 years ago by Technologov

More info: (XP guest)

The problem is not with Full-screen applications per-se, but with their behavior to change guest's resolution.

Try those in seamless mode:

Example1: (Works) Internet Explorer 6, press F11 (enters full-screen). This Works perfectly, because guest resolution was not changed.

Example2: (Broken) Control Panel->Display->Change resolution. This renders garbage on host's screen.

Basically we need to detect any app in the guest that tries to change guest's resolution to become different than seamless mode, and switch VM to windowed mode automatically in this case.

This problem also exists with Linux guests.

-Technologov

comment:6 in reply to: ↑ 5 Changed 4 years ago by misha

Replying to Technologov: That's right. That's what we've discovered here as well. We have a fix already. I should be able to provide you a test build the next week.

comment:7 in reply to: ↑ 5 Changed 4 years ago by misha

  • Summary changed from Full-screen guest applications corrupt host screen when VM is in seamless mode to Full-screen guest applications corrupt host screen when VM is in seamless mode => fixed in SVN

Replying to Technologov: We've fixed the issue. The fix should be included in the next release.
Please post me an email at mikhail dot sennikovsky at sun dot com if you're willing to try a test version with the fix, I'll then post you a link to the test version.

comment:8 Changed 4 years ago by Technologov

I have tested your build v3.1.3-r56263, and found the solution to be poor.

Any new build to test ?

-Technologov

comment:9 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

comment:10 Changed 4 years ago by Technologov

  • Status changed from closed to reopened
  • Resolution fixed deleted

Broken in 3.2.0

Reopened.

Found a duplicate of this one: #3547 (this one is more generic)

-Technologov

comment:11 Changed 7 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.18.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use