VirtualBox

Ticket #5607 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Windows 7 Guest hard locks with > 1 CPU -> retry with 3.1.4

Reported by: walmartshopper Owned by:
Priority: major Component: guest smp
Version: VirtualBox 3.1.0 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

With Slackware 64bit host (kernel 2.6.32-rc7) and Windows 7 64bit RTM guest, the guest hard locks after a few minutes with more than 1 cpu enabled. Screen is frozen and does not accept input. If I select Machine > Pause or Machine > ACPI Shutdown, the screen becomes corrupted with black and random colors. Sometimes the crash occurs as early as the welcome screen, and sometimes it crashes after 5 or 10 minutes. Virtualbox itself remains stable, and other running VMs are not affected. With one cpu enabled, everything is stable.

Attachments

VBox.log Download (72.8 KB) - added by walmartshopper 4 years ago.

Change History

Changed 4 years ago by walmartshopper

comment:1 Changed 4 years ago by anon4321

I have the same issue using 3.1.0 on a Windows 7 host and a Windows 2003 x64. Same graphic corruption.

This problem did not exist with the VM in 3.0.12. After upgrading 3.1.0, it hangs with more than 1 cpu.

comment:2 Changed 4 years ago by sandervl73

  • Summary changed from Windows 7 Guest hard locks with > 1 CPU to Windows 7 Guest hard locks with > 1 CPU -> retry with 3.1.2

Should be fixed now.

comment:3 Changed 4 years ago by walmartshopper

It's much more stable with 3.1.2. I've had the guest running for several days now, and it does seem to be fixed. I did experience this same crash one time on 3.1.2, so I don't know if I would say it's 100% fixed, but I haven't been able to reproduce it again since then. It's at least stable enough that I'm actually running it with all four cores enabled. Thanks!

comment:4 Changed 4 years ago by walmartshopper

I left the guest running overnight with 4 cores enabled. There were no applications open, just idle on the desktop. In the morning, all four of my cores were at 100% usage and the guest was not responding to input. It was the same crash with the same graphical corruption. So now it has happened twice so far with 3.1.2, but stability has definitely increased quite a bit.

comment:5 Changed 4 years ago by walmartshopper

Forgot to mention I was running kernel 2.6.32.1 when the second crash happened on 3.1.2.

comment:6 Changed 4 years ago by frank

  • Summary changed from Windows 7 Guest hard locks with > 1 CPU -> retry with 3.1.2 to Windows 7 Guest hard locks with > 1 CPU

comment:7 Changed 4 years ago by sandervl73

  • Summary changed from Windows 7 Guest hard locks with > 1 CPU to Windows 7 Guest hard locks with > 1 CPU -> retry with 3.1.4

Retry with 3.1.4. That version will include an important stability fix for SMP guests.

comment:8 Changed 4 years ago by sandervl73

Please check if 3.1.4 beta 1 solves the problem:  http://forums.virtualbox.org/viewtopic.php?f=15&t=27300

comment:9 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if it still occurs with 3.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use