VirtualBox

Ticket #5569 (closed defect: worksforme)

Opened 4 years ago

Last modified 4 years ago

dependencies fail on Fedora 12

Reported by: bowerj Owned by:
Priority: major Component: installer
Version: VirtualBox 3.0.12 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I cannot install VB on Fedora 12. It gives the following dependency errors: libQtCore.so.4 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686

libQtGui.so.4 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libQtNetwork.so.4 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libSDL-1.2.so.0 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libXcursor.so.1 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libXmu.so.6 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libXt.so.6 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libcurl.so.4 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libpython2.6.so.1.0 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libxslt.so.1 is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libxslt.so.1(LIBXML2_1.0.11) is needed by VirtualBox-3.0.12_54655_fedora12-1.i686 libxslt.so.1(LIBXML2_1.0.24) is needed by VirtualBox-3.0.12_54655_fedora12-1.i686

All the mentioned libraries/files are present if I do a RPM -ql of the package that provides the required dependency.

Change History

comment:1 Changed 4 years ago by frank

What is your host architecture?

comment:2 Changed 4 years ago by uniredes_br

Almost the same problem here with my Pentium Duo 2.8 Ghz IBM Thinkpad:

rpm -ivh VirtualBox-3.0.12_54655_fedora12-1.i686.rpm aviso: VirtualBox-3.0.12_54655_fedora12-1.i686.rpm: Cabeçalho V4 assinatura DSA: NOKEY, ID da chave 6dfbcbae erro: Dependências não satisfeitas:

libQtCore.so.4 é requerido por VirtualBox-3.0.12_54655_fedora12-1.i686 libQtGui.so.4 é requerido por VirtualBox-3.0.12_54655_fedora12-1.i686 libQtNetwork.so.4 é requerido por VirtualBox-3.0.12_54655_fedora12-1.i686

comment:3 Changed 4 years ago by frank

I'm sorry, but please could you answer my question?

comment:4 Changed 4 years ago by uniredes_br

Please, keep in mind that you're talking to dummy guys around the world (Brazil, in my case). So, explain what exactly do you mean with "What is your host architecture?" :-)

comment:5 Changed 4 years ago by frank

Please open a terminal window (for example konsole on KDE or gnome-terminal on GNOME) and enter the command

uname -a

Please post the output here.

comment:6 Changed 4 years ago by uniredes_br

Linux nproc-660041.trf 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686 i686 386 GNU/Linux

comment:7 Changed 4 years ago by frank

uniredes_br, are you sure you installed the packages which are shown in the warning? That is, what is the output of rpm -q qt?

bowerj, you still didn't answer my question. Could you provide the output of uname -a of the host where you tried to install the .rpm package?

I just double checked, the F12 package installs fine here on an up-to-date F12 installation.

comment:8 Changed 4 years ago by uniredes_br

Frank, it's a shame ! [rpm -q qt] says that the package ins not installed. But how to find it ?

comment:9 Changed 4 years ago by uniredes_br

Hum...I think I can find it here [  http://www.baixaki.com.br/download/qt.htm ] and live you alone :-) I'll try and let you know. Please tell me if there is a better (preferable) place to find it.

comment:10 Changed 4 years ago by frank

The correct way to install a missing package on Fedora12 is

yum install qt

comment:11 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

I will close this bug as the original reporter doesn't respond and uniredes obviously forgot to install the proper packages.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use