VirtualBox

Ticket #5554 (closed defect: obsolete)

Opened 4 years ago

Last modified 3 months ago

Guru meditation on booting Damn Small Linux via PXE/boot.kernel.org

Reported by: Donuts Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.12 Keywords: pxe boot.kernel.org DSL damn small linux
Cc: Guest type: Linux
Host type: Linux

Description (last modified by frank) (diff)

Hi.

I downloaded a boot floppy image from  http://boot.kernel.org/gpxe_images/gpxe.dsk

After extending the image file size to 1.44MB, I created a VM to test that in. Booting over the internet worked and once the initial menu screen appeared I chose Live Images then DSL. Text on the screen is:

Loading live/dsl/linux24.................

Loading live/dsl/minirt24.gz...ready.

and then a Guru Meditation dialog box appears.

The full log is attached but the relevant part seems to be:

00:03:08.545 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'.

00:03:21.366 ERROR [COM]: aRC=VBOX_E_INVALID_VM_STATE (0x80bb0002) aIID={0a51994b-cbc6-4686-94eb-d4e4023280e2} aComponent={Console} aText={Invalid machine state 6 when checking if the guest entered the ACPI mode)} aWarning=false, preserve=false

Attachments

VBox.log.gz Download (16.7 KB) - added by Donuts 4 years ago.
Guru meditation log file
vbox.log.gz Download (28.5 KB) - added by linuxrulez 3 years ago.

Change History

Changed 4 years ago by Donuts

Guru meditation log file

comment:1 Changed 4 years ago by Donuts

Some more information...

Host has Core 2 Duo T8100 CPU, 4GB RAM, running Ubuntu 9.10 with 32-bit PAE kernel. uname -a output:

Linux ubuntu 2.6.31-15-generic-pae #50-Ubuntu SMP Tue Nov 10 16:12:10 UTC 2009 i686 GNU/Linux

VirtualBox dumped an additional log file in my home directory, named e.g. 2009-11-25-09-59-59.033-VirtualBox-10665.log. It is only a few lines so I have pasted it here:

Log created: 2009-11-25T09:59:59.333697000Z
Executable: /usr/lib/virtualbox/VirtualBox
Arg[0]: /usr/lib/virtualbox/VirtualBox
Arg[1]: --comment
Arg[2]: boot.kernel.org test
Arg[3]: --startvm
Arg[4]: 5a9a4e5d-498c-4eba-99d3-a3e01cbf2dba
fatal error in recompiler cpu: Trying to execute code with memory type addr_code=000000003e4d4020 addend=00000000737c6000 at 000000003e4d42e6. (iHandlerMemType=0x38 iMMIOMemType=0x30)

comment:2 Changed 4 years ago by Donuts

Whoops, sorry about the formatting!

comment:3 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

comment:4 Changed 3 years ago by linuxrulez

  • Status changed from closed to reopened
  • Resolution fixed deleted

A little different scenario, but same error:
Loading PXELINUX with gPXE, upon aquiring IP
Syslinux ( http://syslinux.zytor.com) GIT 239fed5, all flavors: pxelinux.0, gpxelinux.0, gpxelinuxk.0)
Host: Linux v2.6.38 x86_64

Log on home dir:
Log created: 2011-03-21T17:53:02.169849000Z
Executable: /usr/lib/virtualbox/VirtualBox
Arg[0]: /usr/lib/virtualbox/VirtualBox
Arg[1]: --comment
Arg[2]: Live PXE
Arg[3]: --startvm
Arg[4]: a9869289-7cca-487d-abb9-7b83ad72a6cd
Arg[5]: --no-startvm-errormsgbox
fatal error in recompiler cpu: Trying to execute code with memory type addr_code=000000006166a020 addend=00007f4a8b93e000 at 000000006166a02c. (iHandlerMemType=0x38 iMMIOMemType=0x30)

Changed 3 years ago by linuxrulez

comment:5 Changed 3 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to obsolete
  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use