VirtualBox

Ticket #5514 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Shared Folders don't work anymore

Reported by: ceronman Owned by:
Priority: major Component: shared folders
Version: VirtualBox 3.0.12 Keywords: shared-folders
Cc: Guest type: Windows
Host type: Linux

Description

Host: Ubuntu Linux 9.10 Guest: Windows XP SP3

I just updated from VirtualBox 3.0.10 to 3.0.12. I uninstalled Guest Additions 3.0.10 and installed GA 3.0.12.

Shared folders are not working anymore. I've tried removing the shared folder an add it again. Change its permissions, change its name. Nothing works.

The command

net use x: \vboxsvr\shared

Works fine in the guest, but when I try to open the shared resource it says: "Can't access X: Parameter is incorrect"

Attachments

VBox.log Download (52.4 KB) - added by ceronman 4 years ago.
Log of the machine
VBox.2.log Download (57.6 KB) - added by bsprowl 4 years ago.
Just saw the box that is used to attach files.

Change History

Changed 4 years ago by ceronman

Log of the machine

comment:1 follow-up: ↓ 4 Changed 4 years ago by frank

Check the shared folder VM setting for this VM. We have some reports that the shared folders setting is sometimes lost after an upgrade so just recreate this setting. We are investigating.

comment:2 follow-up: ↓ 3 Changed 4 years ago by sunlover

ceronman, how do you "open the shared resource"? In Windows Explorer? What is the output of "dir x:\" command in a command prompt window?

comment:3 in reply to: ↑ 2 Changed 4 years ago by ceronman

Replying to sunlover:

ceronman, how do you "open the shared resource"? In Windows Explorer? What is the output of "dir x:\" command in a command prompt window?

I usually double click the network unit in the Windows Explorer.

C:\Documents and Settings\Manuel>dir x:\

El volumen de la unidad X es VBOX_shared El número de serie del volumen es: 0000-0804

Volume in drive X is VBOX_shared Volume Serial Number is 0000-0804

Directory of X:\

File not found

comment:4 in reply to: ↑ 1 Changed 4 years ago by ceronman

Replying to frank:

Check the shared folder VM setting for this VM. We have some reports that the shared folders setting is sometimes lost after an upgrade so just recreate this setting. We are investigating.

I've done this. I removed the old shared folders and created new ones. It doesn't work.

comment:5 Changed 4 years ago by bsprowl

I'm having a similar problem with shared folders with a Mac 10.62 host and a Windows XP SP 3 guest.

The error message is "Z: refers to a location that is unavailable..."

On the forum I'd posted on this in Aug and then several times in the last month. No solution has been provided.

comment:6 Changed 4 years ago by ceronman

I've updated to VB 3.1 and this is fixed now.

comment:7 Changed 4 years ago by frank

Guys, everone who is experiencing this problem should attach a VBox.log file of a VM session where they tried to mount a shared folder, then add a note which folder you tried to mount from the guest.

comment:8 Changed 4 years ago by bsprowl

I'm running Virtualbox 3.1.0 on iMac Host (10.6.2). The shared folder is /Documents/vboxtemp. THE permission have been verified on the host and it is a shared folder.

THe guest is Windows XP pro With service pack 3 and current updates except IE 8. I've tried the command line: "net use Z: \vboxsvr\vboxtemp" and I've tried setting the shared folder using the GUI interface. While it appears to be established correctly neither allows access to the shared folder. I get the error message "Z:\ refers toa location that is unavailable..." when I attempt to use Explorer to access the folder.

Changed 4 years ago by bsprowl

Just saw the box that is used to attach files.

comment:9 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use