VirtualBox

Ticket #5497 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

VBoxManage clonehd fails on Leopard Snow

Reported by: macala Owned by:
Priority: major Component: virtual disk
Version: VirtualBox 3.0.10 Keywords: clonehd
Cc: Guest type: Windows
Host type: Mac OS X

Description (last modified by frank) (diff)

VBoxManage clonehd fails at start of command: VBoxManage clonehd WinXP.vdi WinXP1.vdi with the following message:

ERROR: Cannot register the hard disk
  '/Users/adamlasota/VirtualBox/Czyste maszyny/WinXP.vdi'
  with UUID {af69d29a-11cb-4f13-9af5-129db6fe5c40} because a hard disk '/Users/Shared/WinXP.vdi'
  with UUID {af69d29a-11cb-4f13-9af5-129db6fe5c40} already exists in the media registry
  ('/Users/adamlasota/Library/VirtualBox/VirtualBox.xml')

Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox,
  callee nsISupports Context: "OpenHardDisk?(Bstr(szFilenameAbs),
  AccessMode?_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())"
  at line 624 of file VBoxManageDisk.cpp

Attachments

list hdds.rtf Download (1.7 KB) - added by macala 4 years ago.
I attached VBoxManage list hdds report

Change History

comment:1 Changed 4 years ago by macala

The same problem on VirtualBox 3.0.12

comment:2 Changed 4 years ago by frank

  • Description modified (diff)

Please attach the output of

VBoxManage list hdds

to this ticket (use the Attach button please).

comment:3 Changed 4 years ago by frank

  • Cc lasota.adam@… removed

Changed 4 years ago by macala

I attached VBoxManage list hdds report

comment:4 follow-up: ↓ 5 Changed 4 years ago by klaus

Workaround: use absolute path names instead of just file names (or relative path names).

comment:5 in reply to: ↑ 4 Changed 4 years ago by macala

Replying to klaus:

Workaround: use absolute path names instead of just file names (or relative path names).

Below You find effect after used absolute path names instead just file names:

ERROR: Cannot register the hard disk '/Users/adamlasota/VirtualBox/Czyste maszyny/SQL2008.vhd' with UUID {53d5a9c9-23ff-dd11-80f1-a9443e0786e6} because a hard disk '/Users/adamlasota/VirtualBox/HardDisks/Srv2008.vhd' with UUID {53d5a9c9-23ff-dd11-80f1-a9443e0786e6} already exists in the media registry ('/Users/adamlasota/Library/VirtualBox/VirtualBox.xml') Details: code NS_ERROR_INVALID_ARG (0x80070057), component VirtualBox, interface IVirtualBox, callee nsISupports Context: "OpenHardDisk(src, AccessMode_ReadWrite, false, Bstr(""), false, Bstr(""), srcDisk.asOutParam())" at line 627 of file VBoxManageDisk.cpp

comment:6 Changed 4 years ago by macala

The command was : VboxManage clonehd '/Users/adamlasota/VirtualBox/Czyste maszyny/SQL2008.vhd' '/Users/adamlasota/VirtualBox/Czyste maszyny/SQL2008.vdi' --format VDI

comment:7 follow-up: ↓ 8 Changed 4 years ago by klaus

I'm very puzzled. Apparently you have the image already registered, but VirtualBox fails to find it when looking for it by name, and thus tries to register it again. If I only could reproduce this. Spaces in filenames are certainly not the issue.

A possible workaround would be to unregister the vhd file, but that's just a guess.

comment:8 in reply to: ↑ 7 Changed 4 years ago by macala

Replying to klaus:

I'm very puzzled. Apparently you have the image already registered, but VirtualBox fails to find it when looking for it by name, and thus tries to register it again. If I only could reproduce this. Spaces in filenames are certainly not the issue.

A possible workaround would be to unregister the vhd file, but that's just a guess.

I don't know how VirtualBox try to find it (by name or UUID). Fact is this command worked on earlier version. At this moment I makes the new copy of VHD by copying manually the VHD file and using the command "VBoxManage internalcommands setvdiuuid" which works without any problems.

comment:9 Changed 4 years ago by klaus

The algorithm to locate the file hasn't changed lately, which is why I'm so puzzled. VirtualBox first tries to interpret the parameter as a UUID, which obviously fails. Then it tries to find the image by name, and that always works for me when I specify an absolute path.

The error you get happens after the unexpected failure to find the image.

Do you remember which VirtualBox version worked for you? Maybe there's a subtle change which has some unintended side effect on OSX...

comment:10 Changed 4 years ago by macala

Few days ago i installed the update for Leopard Snow. Today I noticed that VBoxManage command work correctly. See below. I don't know by who but the problem is resolved.

MyMac:Czyste maszyny adamlasota$ VBoxManage clonehd WinXP.vdi WinXP1.vdi VirtualBox Command Line Management Interface Version 3.0.12 (C) 2005-2009 Sun Microsystems, Inc. All rights reserved.

0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100% Clone hard disk created in format 'VDI'. UUID: 419fc9de-7197-4fb4-a5bf-4f2c63a6c1d7

comment:11 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use