VirtualBox

Ticket #5460 (closed defect: duplicate)

Opened 4 years ago

Last modified 4 years ago

Networking extremely unreliable for bridged OpenSolaris guest

Reported by: buffyg Owned by:
Priority: major Component: network
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Solaris
Host type: Mac OS X

Description

I'm running an OpenSolaris 2009.06 guest under Mac OS X Server 10.5.8. After a fresh install of OpenSolaris using bridged networking, I was unable to get a sufficiently reliable network connection to patch the system. I tried all available NIC drivers without success. By comparison, netstat -s on Ubuntu 9.10 and OpenBSD 4.6 guests running in bridged mode show retransmits and duplicates at levels comparable to that of the host OS, but still tolerable enough that applications don't complain about it, let alone fail to complete basic operations (e.g. I can patch Ubuntu, and I can refresh the source code for OpenBSD via CVS).

Network performance on the OpenSolaris box became tolerable after I switched it to run in NAT mode, but even after patching I couldn't get reliable bridged connectivity.

Attachments

VBox.log Download (43.9 KB) - added by buffyg 4 years ago.
current log
sunshine.xml Download (5.7 KB) - added by buffyg 4 years ago.
VM config

Change History

Changed 4 years ago by buffyg

current log

Changed 4 years ago by buffyg

VM config

comment:1 Changed 4 years ago by buffyg

On VBox 3.1 Beta 1, things seem to work well enough using pcn NICs. (I don't believe that any of the e1000g chipsets you support are on the OpenSolaris HCL.) Please close. I'll re-open if things get choppy later.

comment:2 Changed 4 years ago by buffyg

This looks like a duplicate of 3783. Any chance of getting that resolved? In any case, you should be able to close this one as a duplicate.

comment:3 Changed 4 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use