VirtualBox

Ticket #5424 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VRDP issues segfault in VBoxHeadless

Reported by: mkromer Owned by:
Priority: major Component: RDP
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I have a Windows Server 2008 (x32) running here, and it often happens with rdesktop that the machine gets killed without warning:

VBoxHeadless[5648]: segfault at 7f23d0f8c847 ip 00007f23796fa5c0 sp 00007f2379575ca0 error 4 in VBoxVRDP.so[7f23796e7000+29000]

Error 4 = no page found, read access, user-mode access.

It is reproducable on the machine, and Hardware cannot be an issue, as stress tests already have been made without errors.

Host ist openSuSE 11.1 with 2.6.31.5 Kernel

Attachments

VBox.log Download (39.8 KB) - added by mkromer 4 years ago.
vbox.log until segfault

Change History

Changed 4 years ago by mkromer

vbox.log until segfault

comment:1 Changed 4 years ago by mkromer

I forgot to mention Host is x86_64, however this can be read in vbox.log supplied

comment:2 Changed 4 years ago by sandervl73

Do you have a core dump for this crash?

comment:3 Changed 4 years ago by mkromer

no, sorry, if you tell me how i can provide one, i will do so.

comment:4 Changed 4 years ago by mkromer

Dumps have been sent to Frank Mehnert as mentioned in the WIKI

comment:5 Changed 4 years ago by frank

Still didn't get the correct core dumps but the problem is probably fixed in SVN.

comment:6 Changed 4 years ago by ged

I'm bumping into this issue with VirtualBox 3.0.12 and a Win7 guest hosted on a Linux x86_64...

[31075.868874] VBoxHeadless[29518]: segfault at 7f23c77f3244 ip 00007f22cfcb8a23 sp 00007f22cfba2c80 error 4 in VBoxVRDP.so[7f22cfca5000+2a000]

I'll try to catch a core dump off the vm and send it in

comment:7 Changed 4 years ago by locker

Same problem here. Running Windows 7 32bit on Ubuntu 9.10 x64

VBoxHeadless[27848]: segfault at 7fc858e71d74 ip 00007fc767fafac3 sp 00007fc767e2abe0 error 4 in VBoxVRDP.so[7fc767f9c000+2a000]

comment:8 Changed 4 years ago by goodrone

Same problem with 3.1.2 r56127, both GUI and headless.

Host is Windows Server 2008 R2 x64, guest is Windows XP SP3 x64. Crash is in VBoxVRDP.DLL

comment:9 Changed 4 years ago by sunlover

locker, can you provide a core dump for the crash? See  http://www.virtualbox.org/wiki/Core_dump

comment:10 Changed 4 years ago by frank

  • Priority changed from blocker to major

comment:11 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.0.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use