VirtualBox

Ticket #5421 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

Bluescreen on Windows 7 64Bit when resuming from standby -> fixed in SVN

Reported by: Ecki Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: other
Host type: other

Description

Hot is: Windows 7 Ultimate 64bit VirtualBox Version: 3.0.10 Windows XP Home as Guest going into Standby, then resuming the host gives a Bluescreen:

KMODE_EXCEPTION_NOT_HANDLED (1e)

Arguments: Arg1: ffffffffc0000005, The exception code that was not handled Arg2: fffffa80086b832a, The address that the exception occurred at Arg3: 0000000000000000, Parameter 0 of the exception Arg4: ffffffffffffffff, Parameter 1 of the exception

FAULTING_IP: +0 fffffa80`086b832a f30fc73424 vmxon qword ptr [rsp] EXCEPTION_PARAMETER1: 0000000000000000 EXCEPTION_PARAMETER2: ffffffffffffffff READ_ADDRESS: ffffffffffffffff DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT BUGCHECK_STR: 0x1E PROCESS_NAME: VirtualBox.exe CURRENT_IRQL: 2 LAST_CONTROL_TRANSFER: from fffff80002d0ea17 to fffff80002ccef00

Attachments

110709-24148-01.dmp Download (268.6 KB) - added by Ecki 4 years ago.
Minidump
VBox.log Download (46.1 KB) - added by Ecki 4 years ago.
Virtual Box log

Change History

Changed 4 years ago by Ecki

Minidump

Changed 4 years ago by Ecki

Virtual Box log

comment:1 Changed 4 years ago by schmettow

Similar problem here on a WinXP host with Ubuntu Karmic as a guest (both 32 bit) in Virtualbox 3.0.10. Can be reproduced by:

1) Starting guest machine

2) Pausing guest machine (don't know whether this is required to reproduce)

3) Hibernating host (to disk)

4) Resuming host

5) Resuming guest

6) --> Blue Screen and reboot of host

Not sure whether this problem occurred after upgrading to 3.0.8 or 3.0.10, but it wasn't there with earlier versions of VB.

comment:2 Changed 4 years ago by sandervl73

Unable to reproduce here. I suspect the BIOS is not enabling VT-x properly after resume or hibernate. (which is a bug in the BIOS) Could you try to find if a newer BIOS version fixes the problem?

You can override the VT-x initialization by defining a global enviroment variable:

  • set VBOX_HWVIRTEX_INIT=global

I'll add some additional code to reinit VT-x in the next version.

comment:3 Changed 4 years ago by sandervl73

Could you both also tell me on which machines this occurs? (brand, model, bios revision) Thanks.

comment:4 Changed 4 years ago by sandervl73

  • Summary changed from Bluescreen on Windows 7 64Bit when resuming from standby to Bluescreen on Windows 7 64Bit when resuming from standby -> fixed in SVN

Fix will appear in the next version. The above workaround should do the trick as well.

comment:5 Changed 4 years ago by Ecki

  • For now I disabled VT in the VirtualBox Settings
  • Brand Name: Home build with:

Mainboard Intel DP55KG, Bios 3822 (there is a newer one, I will try this)

comment:6 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use