VirtualBox

Ticket #5399 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

Muscle.vbx causes blue screen on Windows XP Guest -> fixed in SVN/3.1.4

Reported by: bflong Owned by:
Priority: major Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Since at least 3.0.4 (probbaly the whole 3.x series) I can crash my Windows XP guest almost instantly by running an application I have installed that has a lot of 16bit visual basic code. I took the executible and moved it to it's own directory, then added one external library at a time until I found the one that causes it to crash. It seems to be the Muscle.vbx library. I learned just enough about windows debugging to create a full debug log. I've attached it.

Attachments

fulldump.txt Download (18.8 KB) - added by bflong 4 years ago.
Full Dump Log
VBox.log Download (49.5 KB) - added by bflong 4 years ago.
VBox.log file
cpuinfo.txt Download (4.2 KB) - added by bflong 4 years ago.
output of /proc/cpuinfo for two machines

Change History

Changed 4 years ago by bflong

Full Dump Log

comment:1 Changed 4 years ago by bflong

The last version I was able to run this app was 1.6.6. I've not tried any of the 2.x series.

comment:2 Changed 4 years ago by sandervl73

Please attach the VBox.log of the crashing session.

Changed 4 years ago by bflong

VBox.log file

comment:3 Changed 4 years ago by bflong

Please let me know if there is anything else I can do to help debug this issue.

comment:4 Changed 4 years ago by sandervl73

Which application is that? And does turning on AMD-V in your computer's BIOS help?

comment:5 Changed 4 years ago by bflong

The application is called "Compass Downloader" and is made by Honeywell. It's used to program Burglar and Fire Alarm panels that Honeywell sells. I'll have to check for BIOS settings for AMD-V and get back to you.

comment:6 Changed 4 years ago by bflong

Sorry, I haven't forgotten about this ticket. I'm just getting over an illness and wasn't able to get to checking those BIOS settings yet.

comment:7 Changed 4 years ago by bflong

My BIOS has no settings for AMD-V at all. This is a Dell Optiplex 740.

I moved the VM over to a Intel Core Duo laptop. It doesn't crash on that machine, at first. This machine DOES have an option to turn on/off the virtual machine extensions. They are on by default. When I turn the VM extensions off in the BIOS, I get the same crash as the AMD machine. I notice that even if I turn off the VT-x/AMD-V option in the virtual machine, it still crashes.

This issue originally appeared on an AMD powered laptop as well. That laptop has no mention of VM extensions in it's BIOS either.

I'll attach the /proc/cpuinfo for both machines.

Changed 4 years ago by bflong

output of /proc/cpuinfo for two machines

comment:8 Changed 4 years ago by bflong

Any news on this issue? Is there any more data I can get to help resolve it?

comment:9 Changed 4 years ago by bflong

I just tested 3.1.2 and had the same result. Is there any way to force Virtualbox to ignore any VM extensions the CPU has?

comment:10 Changed 4 years ago by bflong

I also tested VMWare Player 3, and the guest does not crash as it does with VirtualBox. If I try to enable the VM CPU extensions on the virtual machine under VMWare I get a message when starting telling me that the extensions are disabled in Firmware/Bios and it's preceding with Software emulation, which is what I would expect.

comment:11 Changed 4 years ago by bflong

Anything else I can do to help get this resolved?

comment:12 Changed 4 years ago by sandervl73

There's not much we can do without access to the software or a demo version of it.

comment:13 Changed 4 years ago by bflong

[link deleted] It should be destroyed when the issue is resolved. What I've attached is just enough to hit the bug, not the complete program.

comment:14 Changed 4 years ago by sandervl73

  • Summary changed from Muscle.vbx causes blue screen on Windows XP Guest to Muscle.vbx causes blue screen on Windows XP Guest -> fixed in SVN/3.1.4

Found the problem. 3.1.4 will contain the fix (too late to be included in beta 2). Thanks for the detailed report

comment:15 Changed 4 years ago by bflong

Thank you very much!

comment:16 Changed 4 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use