VirtualBox

Ticket #5383 (closed defect: fixed)

Opened 4 years ago

Last modified 3 years ago

VM crashes when first booting after installing Utimaco SafeGuard Enterprise

Reported by: cassianoleal Owned by:
Priority: critical Component: other
Version: VirtualBox 3.0.10 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

This was tested on VirtualBox 3.0.8 and 3.0.10, on both the open and closed source versions.

I am running a Debian testing amd64 box.

I have Windows XP installed on this VM. I need to have it encrypted with SafeGuard Enterprise in order to meet company policy.

After I install SafeGuard, it boots into a Windows blue screen (not a BSOD) with the message that it's installing the "SGN Base Encryption Kernel", and then reboots.

While booting, the VM crashes.

Note that I have this setup in another VM on a 32 bit system and it works fine. I have even copied this VM's virtual hard disk over and booted it and it worked after a couple of attempts.

I am attaching the log.

Attachments

VBox.log Download (125.9 KB) - added by cassianoleal 4 years ago.
Log of the crashed VM

Change History

Changed 4 years ago by cassianoleal

Log of the crashed VM

comment:1 Changed 4 years ago by sandervl73

  • Priority changed from blocker to critical

comment:2 follow-up: ↓ 3 Changed 4 years ago by cassianoleal

Reference to the encryption program that I'm talking about:  http://www.sophos.com/products/enterprise/encryption/safeguard-enterprise/

comment:3 in reply to: ↑ 2 Changed 4 years ago by cassianoleal

It is possible to download a trial version in the referred page. The crash is reproducible with this trial.

On the first boot after the installation of the SGN Base Encryption Kernel, VirtualBox crashes. Subsequent boots accuse a corruption of \WINDOWS\SYSTEM32\CONFIG\SYSTEM (probably the file that was being read from / written to when the crash happened -- same one every time).

comment:4 Changed 3 years ago by frank

There was a fix in VBox 4.0.4 which could fix your issue. Can you retry?

comment:5 Changed 3 years ago by cassianoleal

I'm really sorry. I've changed jobs and have lost access to the offending s/w.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use