VirtualBox

Ticket #5353 (closed defect: duplicate)

Opened 10 years ago

Last modified 10 years ago

Very long file load/save times in Windows 7 guest through vboxsvr

Reported by: Eric Carroll Owned by:
Component: guest additions Version: VirtualBox 3.0.10
Keywords: Windows 7 performance Cc:
Guest type: Windows Host type: Linux

Description

A save of a powerpoint 1.5MB file using smb takes under 3 sec. Saving the same file through vboxsvr takes up to 3 minutes.

Similarly load times are very long. Loading the same 1.5 MB ppt through vboxsvr takes over 30s, while smb is less than 4 sec.

tcpdump of wire during the load and save shows significant netbios traffic attempting to resolve vboxsvr. It also shows DNS lookups of vboxsvr. I have added vboxsvr to the hosts file without success so far.

Provider Order shows Virtualbox Shared Folders first in the list.

Disabling "Client for Microsoft Networks" and "File & Printer Sharing" did not cause the netbios lookups to go away.

Significant repeats in the vb log file of the following were found:

00:20:33.024 SharedFolders host service: request to unmap folder handle 0
00:20:33.024 SharedFolders host service: unmap operation result VINF_SUCCESS.
00:20:37.990 SharedFolders host service: request to map folder Home
00:20:37.990 SharedFolders host service: map operation result VINF_SUCCESS.
00:20:37.990     Mapped to handle 0.

Upgrading to 3.0.10 resolved the "no more files" problem but did not resolve the performance issue.

Guest: Windows 7
Host: 2.6.28-16-generic in Ubuntu 9.04
Network interface in bridged mode.
CPU: Intel T2600 @2.16 GHz (dual core i686)

Attachments

load.dmp Download (14.8 KB) - added by Eric Carroll 10 years ago.
tcpdump trace during load
load.2.dmp Download (14.8 KB) - added by Eric Carroll 10 years ago.
tcpdump trace during load
save.dmp Download (78.0 KB) - added by Eric Carroll 10 years ago.
tcpdump during save
vbox-2009-10-30-17-27-17.log Download (59.7 KB) - added by Eric Carroll 10 years ago.
vbox log
vbox-2009-10-30-18-03-43.log Download (88.8 KB) - added by Eric Carroll 10 years ago.
winxp_load.dmp Download (8.7 KB) - added by Eric Carroll 10 years ago.
tcpdump of load in WinXPSP3
WINXP3-2009-10-30-18-33-09.log Download (49.0 KB) - added by Eric Carroll 10 years ago.

Change History

Changed 10 years ago by Eric Carroll

tcpdump trace during load

Changed 10 years ago by Eric Carroll

tcpdump trace during load

Changed 10 years ago by Eric Carroll

tcpdump during save

Changed 10 years ago by Eric Carroll

vbox log

Changed 10 years ago by Eric Carroll

comment:1 Changed 10 years ago by Eric Carroll

For calibration, WinXP SP3 VM with 3.0.10 guest additions: load time of 1.5 MB ppt is 16 sec, and does show netbios lookups (attached).

Changed 10 years ago by Eric Carroll

tcpdump of load in WinXPSP3

Changed 10 years ago by Eric Carroll

comment:2 Changed 10 years ago by sunlover

  • Status changed from new to closed
  • Resolution set to duplicate

This is duplicate of #1728

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use